Форум русской поддержки Joomla!® CMS
09.12.2016, 13:45:45 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
   
   Начало   Поиск Joomla 3.0 FAQ Joomla 2.5 FAQ Joomla 1.5 FAQ Правила форума Новости Joomla Реклама Войти Регистрация Помощь  
Страниц: [1]   Вниз
  Добавить закладку  |  Печать  
Автор

Ошибка 404 ( /component/users/?view=registration ) при нажатии на "Регистрация".

 (Прочитано 13029 раз)
0 Пользователей и 1 Гость смотрят эту тему.
DVG
Захожу иногда
**

Репутация: +0/-0
Offline Offline

Сообщений: 14


« : 03.02.2012, 23:00:26 »

Живой сайт: http://ScubaTime.ru

Регистрация на самОм сайте не требуется, поэтому в меню не включал.
На форум заходишь, пытаешься зарегится, ппытается перейти на страницу /component/users/?view=registration - вылазит 404.

Рег-Joomla плагины включены.

Что делать?
Подскажите новичку.
« Последнее редактирование: 05.02.2012, 03:50:33 от DVG » Записан
DVG
Захожу иногда
**

Репутация: +0/-0
Offline Offline

Сообщений: 14


« Ответ #1 : 07.02.2012, 11:28:52 »

Актуально.  !
Записан
Marques
Живу я здесь
******

Репутация: +190/-9
Offline Offline

Пол: Мужской
Сообщений: 1452


Ctrl+F5


« Ответ #2 : 08.02.2012, 03:13:54 »

Посмотрите в менеджер пользователей - настройка - Разрешить регистрацию пользователей. Может отключили ?
Записан
DVG
Захожу иногда
**

Репутация: +0/-0
Offline Offline

Сообщений: 14


« Ответ #3 : 08.02.2012, 14:32:25 »

Посмотрите в менеджер пользователей - настройка - Разрешить регистрацию пользователей. Может отключили ?

Проверил: "Разрешить регистрацию пользователей - Да."

Попробовал выкл/вкл - не помогло. Причём выкл(установка "нет") - работает: ссылка "Регистрация" из вариантов(на форуме) пропадает.

ЗЫ
Ссылки "Забыли пароль?" и "Забыли логин?" - работают.
« Последнее редактирование: 08.02.2012, 14:36:16 от DVG » Записан
Marques
Живу я здесь
******

Репутация: +190/-9
Offline Offline

Пол: Мужской
Сообщений: 1452


Ctrl+F5


« Ответ #4 : 08.02.2012, 14:39:49 »

как вариант - попробовать перезалить папку com_users со всем ее содержимым взяв ее с дистрибутива Joomla. (при этом не забыв сделать бекап)
Записан
DVG
Захожу иногда
**

Репутация: +0/-0
Offline Offline

Сообщений: 14


« Ответ #5 : 08.02.2012, 14:55:49 »

как вариант - попробовать перезалить папку com_users

Перезалил /administrator/components/com_users/ и /components/com_users/

Изменений нет.

PS  Дистр Joomla из файла: Joomla_1.7.3-Stable-Full_Package_Russian_v1.tar.gz

Записан
Zidane
Новичок
*

Репутация: +0/-0
Offline Offline

Сообщений: 2


« Ответ #6 : 27.04.2012, 00:32:48 »

такая же проблема... решение не нашли?
Записан
Влад
Осваиваюсь на форуме
***

Репутация: +2/-0
Offline Offline

Сообщений: 119



« Ответ #7 : 13.08.2012, 10:52:37 »

Если отключить стандартное SEO, то работает, а при включенном не работает  Sad

вот как выглядит http://mynewfamily.ru/component/users/?view=registration   все плохо

ссылка начинает выглядеть так  http://mynewfamily.ru/index.php?option=com_users&view=registration   все хорошо
« Последнее редактирование: 13.08.2012, 11:24:39 от Влад » Записан
Puertorikanec
Осваиваюсь на форуме
***

Репутация: +0/-0
Offline Offline

Сообщений: 44



« Ответ #8 : 24.11.2012, 22:17:48 »

актуально. Как решить проблему с SEO? Чтоб при включенном SEO стандартном все работало?
Записан
beliyadm
Профи
********

Репутация: +1566/-61
Offline Offline

Пол: Мужской
Сообщений: 8110


Севастополь == Россия


« Ответ #9 : 24.11.2012, 22:23:10 »

создать служебное меню, модуль которого не опубликован, и там прописать ссылку на регистрацию
Записан
Puertorikanec
Осваиваюсь на форуме
***

Репутация: +0/-0
Offline Offline

Сообщений: 44



« Ответ #10 : 25.11.2012, 08:50:45 »

А можно в модуле вход на сайт вставить ссылку типа "http://mynewfamily.ru/index.php?option=com_users&view=registration" и включить SEO? Если можно подробней где это можно вставить=).
Записан
Puertorikanec
Осваиваюсь на форуме
***

Репутация: +0/-0
Offline Offline

Сообщений: 44



« Ответ #11 : 25.11.2012, 09:10:54 »

А можно в модуле вход на сайт вставить ссылку типа "http://mynewfamily.ru/index.php?option=com_users&view=registration" и включить SEO? Если можно подробней где это можно вставить=).
Я попробовал и проблема решилась. Я сделал следующее в /modules/mod_login/tmpl/default.php нашел ссылки и исправил их на точные ссылки типа http://ваш сайт/index.php?option=com_users&view=registration
После включении SEO все осталось работать и еще ссылки восстановить пароль и забыли пароль отредактировать так же. Спасибо. Если кто знает как сделать лучше или проще напишите просто я дуб еще в php пока=)
Записан
RavAngell
Новичок
*

Репутация: +0/-0
Offline Offline

Сообщений: 1


« Ответ #12 : 30.11.2012, 16:15:48 »

Hello,
а у меня такая вот проблема:
При нажатии на ссылку "Создать аккаунт/Create an account" отсылает на http://site/jupgrade/index.php?option=com_users&view=registration
Появляются поля для ввода данных о пользователе. Ввожу. Но когда нажимаю на кнопку «Регистрация/Register» отправляет на http://site/jupgrade/index.php?option=com_users и появляется:

Код:
404 - Component not found
You may not be able to visit this page because of:
an out-of-date bookmark/favourite
a search engine that has an out-of-date listing for this site
a mistyped address
you have no access to this page
The requested resource was not found.
An error has occurred while processing your request.

Что собственно делать?
Система Joomla 2.5.8 (сделан апргрейд сайта с 1.5, jupgrade)
Папку com_users перезаливал.
Записан
b2z
Support Team
*****

Репутация: +710/-0
Offline Offline

Пол: Мужской
Сообщений: 7538


Разраблю понемногу


« Ответ #13 : 30.11.2012, 16:41:02 »

http://site/jupgrade - тут что-то не так...
Записан
KeepOut
Новичок
*

Репутация: +0/-0
Offline Offline

Пол: Мужской
Сообщений: 8


« Ответ #14 : 03.01.2014, 02:59:30 »

http://site/jupgrade - тут что-то не так...

Ответ отличный
Записан
KeepOut
Новичок
*

Репутация: +0/-0
Offline Offline

Пол: Мужской
Сообщений: 8


« Ответ #15 : 03.01.2014, 03:11:48 »

Hello,
а у меня такая вот проблема:
При нажатии на ссылку "Создать аккаунт/Create an account" отсылает на http://site/jupgrade/index.php?option=com_users&view=registration
Появляются поля для ввода данных о пользователе. Ввожу. Но когда нажимаю на кнопку «Регистрация/Register» отправляет на http://site/jupgrade/index.php?option=com_users и появляется:

Код:
404 - Component not found
You may not be able to visit this page because of:
an out-of-date bookmark/favourite
a search engine that has an out-of-date listing for this site
a mistyped address
you have no access to this page
The requested resource was not found.
An error has occurred while processing your request.

Что собственно делать?
Система Joomla 2.5.8 (сделан апргрейд сайта с 1.5, jupgrade)
Папку com_users перезаливал.


Столкнулся с той-же проблемой только при генерации ссылка другая.
Перепробовал куча методов:
1. перезаливка
2. перезаливка в шаблоне
3. отключение ре подключение модуля
4. файрвол Joomla
5. настройки на сервере
6. настройки компонентов SEO

Везде сплошной 00000   

Я догадываюсь что  это происходит из-за неправильной генерации ссылки

НО!! где найти генератор страницы которая появляется после заполнении профиля и "кликанья"  кнопки "Регистрации"

PS. Это глюк шаблона если заливали демо, но исправить то можно
Записан
m0skit
Новичок
*

Репутация: +0/-0
Offline Offline

Пол: Мужской
Сообщений: 2



« Ответ #16 : 29.04.2014, 16:30:29 »

Всем добрый день!

Столкнулся с аналогичной проблемой: при стандартной регистрации после заполнения формы и нажатия на кнопку "Зарегистрироваться" бросает на страницу 404 (в строке стоит адрес http://мойсайт.ru/component/users/)
На сайте стоит BT Login, там AJAX регистрация, так вот через него пользователи регистрируются без проблем.

Скорее всего, проблема в установленном шаблоне (стоит  InsightFX)

Тоже уже перепробовал все советы, что смог найти - результат нулевой.

Таких вопросов висит множество - вот только на форуме:
http://joomlaforum.ru/index.php/topic,286830.0.html
http://joomlaforum.ru/index.php/topic,243036.0.html

Цитировать
НО!! где найти генератор страницы которая появляется после заполнении профиля и "кликанья"  кнопки "Регистрации"

PS. Это глюк шаблона если заливали демо, но исправить то можно
Неужели нет решения проблемы?


Информация о сайте:
Показать текстовый блок
Записан
nikazz
Новичок
*

Репутация: +0/-0
Offline Offline

Сообщений: 4


« Ответ #17 : 17.06.2015, 03:48:46 »

../plugin/user    - измени user как хочешь или удали и не будет запросо
Записан
m0skit
Новичок
*

Репутация: +0/-0
Offline Offline

Пол: Мужской
Сообщений: 2



« Ответ #18 : 19.06.2015, 13:59:21 »

Сорри, вопрос уже неактуален - сайт давно снес, даже не помню, решил проблему или нет Sad
Записан
Страниц: [1]   Вверх
  Добавить закладку  |  Печать  
 
Перейти в:  

Powered by SMF 1.1.21 | SMF © 2006, Simple Machines

Joomlaforum.ru is not affiliated with or endorsed by the Joomla! Project or Open Source Matters.
The Joomla! name and logo is used under a limited license granted by Open Source Matters
the trademark holder in the United States and other countries.

LiveInternet