Форум русской поддержки Joomla!® CMS
04.12.2016, 12:10:13 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
   
   Начало   Поиск Joomla 3.0 FAQ Joomla 2.5 FAQ Joomla 1.5 FAQ Правила форума Новости Joomla Реклама Войти Регистрация Помощь  
Страниц: [1]   Вниз
  Добавить закладку  |  Печать  
Автор

Не работают ссылки на статьи

 (Прочитано 2629 раз)
0 Пользователей и 1 Гость смотрят эту тему.
andluser
Новичок
*

Репутация: +0/-0
Offline Offline

Сообщений: 4


« : 01.07.2013, 00:08:50 »

При вставке в статью ссылку на другую статью сайта получается адрес вроде такого:
http://мойсайт/"index.php?option=com_content&view=article&id=3&catid=2&Itemid=435\"
который никуда не ведет.
Подскажите, пожалуйста, как это лечится.
Записан
Fedor Vlasenko
Профи
********

Репутация: +696/-5
Offline Offline

Пол: Мужской
Сообщений: 3820


Все начинается с Value


« Ответ #1 : 01.07.2013, 00:22:38 »

Наличие Itemid обозначает привязку к меню. Тогда ссылка может быть такой:
href="http://мойсайт/index.php?Itemid=435"
Если материал не привязан к меню, тогда ссылка может быть такой:
href="http://мойсайт/index.php?option=com_content&view=article&id=3" здесь 3 ид материала
еще варианты ссылок на материал:
при включенном SEF
href="http://мойсайт/component/content/article.html?id=7" здесь 7 ид материала

Записан
andluser
Новичок
*

Репутация: +0/-0
Offline Offline

Сообщений: 4


« Ответ #2 : 01.07.2013, 13:53:34 »

Спасибо за ответ, но тут ключевой момент в кавычках, которые вставляются после http://мойсайт/:
http://мойсайт/"index.php?option=com_content&view=article&id=3&catid=2&Itemid=435\"
часть ссылки "index.php?option=com_content&view=article&id=3&catid=2&Itemid=435\" находится в кавычках, которые никак не убираются и поэтому, естественно, ссылка не работает.
Записан
Gover
Осваиваюсь на форуме
***

Репутация: +3/-0
Offline Offline

Пол: Мужской
Сообщений: 172



« Ответ #3 : 02.07.2013, 22:42:10 »

Попробуйте убрать http://мойсайт/ вообще.
Начинайте ссылки с index.php?option=com_content...
Записан
mlamla1111
Новичок
*

Репутация: +0/-0
Offline Offline

Сообщений: 2


« Ответ #4 : 04.07.2013, 01:29:28 »

Немного другая проблема - написав статью, отделяю ее "подробнее", выкладываю в категорию, но ссылки в заголовках статей и в "подробнее" не работают, как решить эту проблему?
Записан
Gover
Осваиваюсь на форуме
***

Репутация: +3/-0
Offline Offline

Пол: Мужской
Сообщений: 172



« Ответ #5 : 21.07.2013, 22:53:27 »

Ладно, заголовки... ссылки в заголовках можно включить в настройках Менеджера материалов,
но почему не работают ссылки на Подробнее - не могу подсказать, если есть интро и фултекст, то ссылка на подробнее должна быть обязательно
Записан
Aleks.Denezh
Практически профи
*******

Репутация: +372/-4
Offline Offline

Пол: Мужской
Сообщений: 2762



« Ответ #6 : 22.07.2013, 10:02:35 »

скорее всего проблема с волшебными кавычками Joomla 3.0 и magic_quotes_gpc
Записан
sveta777
Осваиваюсь на форуме
***

Репутация: +0/-0
Offline Offline

Сообщений: 25


« Ответ #7 : 26.04.2015, 21:26:11 »

есть кто живой?
здравствуйте!
подскажите, никак не могу настроить ссылку для выведения статей в Image Swoop для Joomla3.
ссылка на материал, если скопировать ее: http://localhost/demo/administrator/index.php?option=com_content&task=article.edit&id=9
однако при введении этой ссылки в окно ItemUrl (ссылка на статью) - ничего не показывает.
Модуль сам установлен, на странице в нужной позиции модуля надпись Image Swoop.
и что делать?
я новичок во все, что касается сайтов! прошу быть проще) только тренируюсь) спасибо.
Записан
Страниц: [1]   Вверх
  Добавить закладку  |  Печать  
 
Перейти в:  

Powered by SMF 1.1.21 | SMF © 2006, Simple Machines

Joomlaforum.ru is not affiliated with or endorsed by the Joomla! Project or Open Source Matters.
The Joomla! name and logo is used under a limited license granted by Open Source Matters
the trademark holder in the United States and other countries.

LiveInternet