Ошибка после обновления 3.1 на 3.2

  • 75 Ответов
  • 18992 Просмотров

0 Пользователей и 1 Гость просматривают эту тему.

У меня выдало такую ошибку после обновления 3.1 на 3.2 помогите исправить  
plugins/system/remember/remember.php on line 94
« Последнее редактирование: 07.11.2013, 13:43:49 от b2z »

*

Оффлайн b2z

  • *****
  • 7740
  • [+]739 / [-]0
  • Пол: Мужской
  • Разраблю понемногу
    • Просмотр профиля
    • NorrNext - расширения для Joomla! и Pagekit
ошибку после обновления 3.1 на 3.2
« Ответ #1 : 06.11.2013, 23:35:46 »
У меня выдало такую ошибку после обновления 3.1 на 3.2 помогите исправить 
plugins/system/remember/remember.php on line 94
Опа, уже выпустили... +)

ошибку после обновления 3.1 на 3.2
« Ответ #2 : 07.11.2013, 04:50:40 »
да но сайт запороло

*

Оффлайн b2z

  • *****
  • 7740
  • [+]739 / [-]0
  • Пол: Мужской
  • Разраблю понемногу
    • Просмотр профиля
    • NorrNext - расширения для Joomla! и Pagekit
ошибку после обновления 3.1 на 3.2
« Ответ #3 : 07.11.2013, 13:42:04 »
да но сайт запороло
То есть в админку уже не попасть? Если так, то залейте пакет обновлений вручную по FTP, зайдите в менеджер расширений - база данных - исправить ошибки.

Вчера сам так делал, т.к. скачался битый архив и обновление зависло посередине. Пришлось вручную обновляться.

*

Оффлайн iRaptor

Re: Ошибка после обновления 3.1 на 3.2
« Ответ #4 : 11.11.2013, 04:38:52 »
Из-за чего может быть белый фон после апдейта на 3.2?

*

Оффлайн ELLE

Re: Ошибка после обновления 3.1 на 3.2
« Ответ #5 : 11.11.2013, 09:15:26 »
Из-за чего может быть белый фон после апдейта на 3.2?
прям для вас тема - [topic=178109]
ищется на раз-два

Re: Ошибка после обновления 3.1 на 3.2
« Ответ #6 : 12.11.2013, 16:51:09 »
То есть в админку уже не попасть? Если так, то залейте пакет обновлений вручную по FTP, зайдите в менеджер расширений - база данных - исправить ошибки.

Вчера сам так делал, т.к. скачался битый архив и обновление зависло посередине. Пришлось вручную обновляться.
Привет... такая же проблема... вручную всё залил... как ты попал в админку "зайдите в менеджер расширений - база данных - исправить ошибки."
у меня как была эта ошибка в админке и на сайте так она и осталась

*

Онлайн AlekVolsk

Re: Ошибка после обновления 3.1 на 3.2
« Ответ #7 : 12.11.2013, 17:01:24 »
Привет... такая же проблема... вручную всё залил... как ты попал в админку "зайдите в менеджер расширений - база данных - исправить ошибки."
у меня как была эта ошибка в админке и на сайте так она и осталась
ага, захожу в менеджер расширений - база данных, а мне: Table '..._banners' doesn't exist SQL=SHOW COLUMNS IN `..._banners` WHERE field = 'created_by'
было дело, я удалил модуль баннеров, это было еще в 3.1.4, обнова до 3.1.5 прошла успешно, а вот теперь вдруг споткнулся

и еще карта сайта xmap:
Warning: require_once(.../includes/application.php) [function.require-once]: failed to open stream: No such file or directory in .../components/com_xmap/helpers/xmap.php on line 12
Fatal error: require_once() [function.require]: Failed opening required '.../includes/application.php' (include_path='.:/usr/local/php53/lib/php') in .../components/com_xmap/helpers/xmap.php on line 12

*

Оффлайн b2z

  • *****
  • 7740
  • [+]739 / [-]0
  • Пол: Мужской
  • Разраблю понемногу
    • Просмотр профиля
    • NorrNext - расширения для Joomla! и Pagekit
Re: Ошибка после обновления 3.1 на 3.2
« Ответ #8 : 12.11.2013, 17:07:33 »
Привет... такая же проблема... вручную всё залил... как ты попал в админку "зайдите в менеджер расширений - база данных - исправить ошибки."
у меня как была эта ошибка в админке и на сайте так она и осталась
Какая ошибка?

ага, захожу в менеджер расширений - база данных, а мне: Table '..._banners' doesn't exist SQL=SHOW COLUMNS IN `..._banners` WHERE field = 'created_by'
было дело, я удалил модуль баннеров, это было еще в 3.1.4, обнова до 3.1.5 прошла успешно, а вот теперь вдруг споткнулся

и еще карта сайта xmap:
Warning: require_once(.../includes/application.php) [function.require-once]: failed to open stream: No such file or directory in .../components/com_xmap/helpers/xmap.php on line 12
Fatal error: require_once() [function.require]: Failed opening required '.../includes/application.php' (include_path='.:/usr/local/php53/lib/php') in .../components/com_xmap/helpers/xmap.php on line 12
Интересно, куда это у Вас делать таблица баннеров? Её надо восстанавливать, но уже вручную через phpMyAdmin например.
По поводу Xmap - разработчтики дурики, напрямую подключают файлы приложения. Ждите, пока выпустят фикс.

*

Онлайн AlekVolsk

Re: Ошибка после обновления 3.1 на 3.2
« Ответ #9 : 12.11.2013, 17:14:53 »
надо восстанавливать, но уже вручную через phpMyAdmin
знать бы скрипт
По поводу Xmap - разработчтики дурики, напрямую подключают файлы приложения. Ждите, пока выпустят фикс.
ппц, обновился на свою голову...

*

Оффлайн b2z

  • *****
  • 7740
  • [+]739 / [-]0
  • Пол: Мужской
  • Разраблю понемногу
    • Просмотр профиля
    • NorrNext - расширения для Joomla! и Pagekit
Re: Ошибка после обновления 3.1 на 3.2
« Ответ #10 : 12.11.2013, 17:18:39 »
Тут на форуме в разделе Xmap был фикс, посмотрите.

Вот запрос (только поменяйте #_ на свой префикс):

[spoiler]CREATE TABLE IF NOT EXISTS `#__banners` (
  `id` int(11) NOT NULL AUTO_INCREMENT,
  `cid` int(11) NOT NULL DEFAULT 0,
  `type` int(11) NOT NULL DEFAULT 0,
  `name` varchar(255) NOT NULL DEFAULT '',
  `alias` varchar(255) CHARACTER SET utf8 COLLATE utf8_bin NOT NULL DEFAULT '',
  `imptotal` int(11) NOT NULL DEFAULT 0,
  `impmade` int(11) NOT NULL DEFAULT 0,
  `clicks` int(11) NOT NULL DEFAULT 0,
  `clickurl` varchar(200) NOT NULL DEFAULT '',
  `state` tinyint(3) NOT NULL DEFAULT 0,
  `catid` int(10) unsigned NOT NULL DEFAULT 0,
  `description` text NOT NULL,
  `custombannercode` varchar(2048) NOT NULL,
  `sticky` tinyint(1) unsigned NOT NULL DEFAULT 0,
  `ordering` int(11) NOT NULL DEFAULT 0,
  `metakey` text NOT NULL,
  `params` text NOT NULL,
  `own_prefix` tinyint(1) NOT NULL DEFAULT 0,
  `metakey_prefix` varchar(255) NOT NULL DEFAULT '',
  `purchase_type` tinyint(4) NOT NULL DEFAULT -1,
  `track_clicks` tinyint(4) NOT NULL DEFAULT -1,
  `track_impressions` tinyint(4) NOT NULL DEFAULT -1,
  `checked_out` int(10) unsigned NOT NULL DEFAULT 0,
  `checked_out_time` datetime NOT NULL DEFAULT '0000-00-00 00:00:00',
  `publish_up` datetime NOT NULL DEFAULT '0000-00-00 00:00:00',
  `publish_down` datetime NOT NULL DEFAULT '0000-00-00 00:00:00',
  `reset` datetime NOT NULL DEFAULT '0000-00-00 00:00:00',
  `created` datetime NOT NULL DEFAULT '0000-00-00 00:00:00',
  `language` char(7) NOT NULL DEFAULT '',
  `created_by` int(10) unsigned NOT NULL DEFAULT 0,
  `created_by_alias` varchar(255) NOT NULL DEFAULT '',
  `modified` datetime NOT NULL DEFAULT '0000-00-00 00:00:00',
  `modified_by` int(10) unsigned NOT NULL DEFAULT 0,
  `version` int(10) unsigned NOT NULL DEFAULT 1,
  PRIMARY KEY (`id`),
  KEY `idx_state` (`state`),
  KEY `idx_own_prefix` (`own_prefix`),
  KEY `idx_metakey_prefix` (`metakey_prefix`),
  KEY `idx_banner_catid` (`catid`),
  KEY `idx_language` (`language`)
) ENGINE=InnoDB DEFAULT CHARSET=utf8;[/spoiler]

*

Онлайн AlekVolsk

Re: Ошибка после обновления 3.1 на 3.2
« Ответ #11 : 12.11.2013, 17:22:44 »
b2z, спс за запрос, весьма выручили, +

*

Онлайн AlekVolsk

Re: Ошибка после обновления 3.1 на 3.2
« Ответ #12 : 12.11.2013, 17:36:20 »
по поводу Xmap - ручками обновил пакет до версии 2.3.4 http://www.jooxmap.com/downloads.html - все ок ))

Re: Ошибка после обновления 3.1 на 3.2
« Ответ #13 : 12.11.2013, 17:37:03 »
Какая ошибка?
Та же что и вверху.

нашел решение ты просто не описал что ремембер PHP брал из бэкапа

"Решение:
1. Перед обновлением сайта на Joomla 3.1 делаем естественно резервные копии сайта и базы данных.
2. Файл remember.php, который был в старой версии Joomla 3.1 переименовываем или сохраняем отдельно например rememberBAK.php (файл находится /home/xxx/public_html/site.ru/plugins/system/remember/remember.php )
3.  Я брал с Joomla.org Joomla_3.2.0-Stable-Update_Package.zip размер 8398890 байт. Закачиваем в корень сайта и распаковываем.
4.  Далее находим home/xxx/public_html/site.ru/plugins/system/remember/remember.php
переименовываем remember.php в rememberNEW.php. rememberBAK.php в remember.php.
5. Заходим в панель управления сайта, и заходим в «Расширения» -> «Менеджер расширений»  , слева в меню выбираем «База данных» и в левом верхнем углу будет кнопка исправить, это действие исправит таблицы БД и приведет структуру к версии Joomla 3.2.
6. Завершаем процесс, тем что возвращаем remember.php от версии Joomla 3.2. Переименовываем rememberNEW.php в remember.php"


Re: Ошибка после обновления 3.1 на 3.2
« Ответ #15 : 12.11.2013, 17:54:49 »
Ааа, у меня не было проблемы с remember.php ;) Рад, что решили проблему.
у меня после заливки вручную обновления в админку все равно не пускало, ошибка (plugins/system/remember/remember.php on line 94) оставалась

*

Оффлайн bicka

  • ***
  • 74
  • [+]3 / [-]0
  • Пол: Мужской
  • Уха-ха
    • Просмотр профиля
    • ВІнтернетІ.
Re: Ошибка после обновления 3.1 на 3.2
« Ответ #16 : 13.11.2013, 16:46:47 »
зайдите в менеджер расширений - база данных - исправить ошибки.
Большое спасибо !

Обновил с joomla 3.1.5 на 3.2.0  при входе в панель управления вскакивала ошибка, сделал как Вы описали о чудо ....
Проявите понимание к людям которые жаждут знаний ...

Re: Ошибка после обновления 3.1 на 3.2
« Ответ #17 : 20.11.2013, 11:52:59 »
После вчерашнего обновления до версии 3.2 - не смог войти в админку, выдало вот такую ошибку ( Fatal error: Call to a member function isAdmin() on a non-object in /home/user/public_html/plugins/authentication/cookie/cookie.php on line 51 ), после перезалива Joomla через FTP столо выдавать уже такую ошибку ( Fatal error: Call to a member function get() on a non-object in /home/user/public_html/plugins/system/remember/remember.php on line 94 )

Re: Ошибка после обновления 3.1 на 3.2
« Ответ #18 : 25.11.2013, 00:08:25 »
по поводу Xmap - ручками обновил пакет до версии 2.3.4 http://www.jooxmap.com/downloads.html - все ок ))
спасибо помогло

*

Оффлайн kushiy

Re: Ошибка после обновления 3.1 на 3.2
« Ответ #19 : 26.11.2013, 12:29:24 »
После обновления также при заходе в админку
Table 'kushiy.auto_postinstall_messages' doesn't exist SQL=SHOW FULL COLUMNS FROM `auto_postinstall_messages` Здесь похоже не Xmap

*

Оффлайн b2z

  • *****
  • 7740
  • [+]739 / [-]0
  • Пол: Мужской
  • Разраблю понемногу
    • Просмотр профиля
    • NorrNext - расширения для Joomla! и Pagekit
Re: Ошибка после обновления 3.1 на 3.2
« Ответ #20 : 26.11.2013, 12:57:52 »
После обновления также при заходе в админку
Table 'kushiy.auto_postinstall_messages' doesn't exist SQL=SHOW FULL COLUMNS FROM `auto_postinstall_messages` Здесь похоже не Xmap

Менеджер расширений -> База данных -> Исправить.

*

Оффлайн kushiy

Re: Ошибка после обновления 3.1 на 3.2
« Ответ #21 : 26.11.2013, 13:05:06 »
Проблема решена, спасибо

Re: Ошибка после обновления 3.1 на 3.2
« Ответ #22 : 29.11.2013, 02:22:29 »
Не удаляются модули в 3.2 пишет ошибка, кажется где-то было решение? в поиске по форуму по фразе (не удаляются модули 3.2) ничего не выдает

*

Оффлайн b2z

  • *****
  • 7740
  • [+]739 / [-]0
  • Пол: Мужской
  • Разраблю понемногу
    • Просмотр профиля
    • NorrNext - расширения для Joomla! и Pagekit
Re: Ошибка после обновления 3.1 на 3.2
« Ответ #23 : 29.11.2013, 16:07:36 »
Не удаляются модули в 3.2 пишет ошибка, кажется где-то было решение? в поиске по форуму по фразе (не удаляются модули 3.2) ничего не выдает
Какая ошибка? Откуда не удаляются?

Re: Ошибка после обновления 3.1 на 3.2
« Ответ #24 : 29.11.2013, 17:42:52 »
Не удаляются с корзины в менеджере модулей, причем на двух сайтах, думал nonumbers advanced module manadger виноват удалил его, все равно не удаляются из корзины, выделяешь модуль когда он уже к корзине, щелкаешь очистить корзину пишет ошибка, без кода, а саму ошибку в консоли не могу отловить так как перекидывает на другую страницу  в которой слово ошибка а чуть ниже кнопка вернуться в панель управления.

Вот нашел на буржуйском форуме, оказывается это баг 3.2 но проявляется не у всех, и нет решения пока, есть лиш полу-решение через убирание в модулях позиций, привязок к меню и т.д. и только потом можно удалить, или через phpMyAdmin  
http://forum.joomla.org/viewtopic.php?f=728&t=825594

Вот собственно это полу-решение

- undeleted the module
- deleted all HTML
- assigned no position
- assigned no menu items
- unpublished
- deleted
and then I successfully cleaned from trash.
Hope this help

Продолжение через 10 минут
И вот наконец, все заработало, нужно всего лишь зайти в модуль и выбрать отвязку от меню, (не на одной странице) сохраняем и потом модули удаляться, по крайней мере у меня так работает.
« Последнее редактирование: 29.11.2013, 18:23:12 от Abiladenda »

*

Оффлайн b2z

  • *****
  • 7740
  • [+]739 / [-]0
  • Пол: Мужской
  • Разраблю понемногу
    • Просмотр профиля
    • NorrNext - расширения для Joomla! и Pagekit

*

Оффлайн ELLE



*

Оффлайн vitalura

Re: Ошибка после обновления 3.1 на 3.2
« Ответ #28 : 01.12.2013, 23:21:51 »
Ура! заработало *DRINK*
СПС.

Re: Ошибка после обновления 3.1 на 3.2
« Ответ #29 : 05.12.2013, 17:57:46 »
Не удаляются с корзины в менеджере модулей, причем на двух сайтах, думал nonumbers advanced module manadger виноват удалил его, все равно не удаляются из корзины, выделяешь модуль когда он уже к корзине, щелкаешь очистить корзину пишет ошибка, без кода, а саму ошибку в консоли не могу отловить так как перекидывает на другую страницу  в которой слово ошибка а чуть ниже кнопка вернуться в панель управления.

Вот нашел на буржуйском форуме, оказывается это баг 3.2 но проявляется не у всех, и нет решения пока, есть лиш полу-решение через убирание в модулях позиций, привязок к меню и т.д. и только потом можно удалить, или через phpMyAdmin 
http://forum.joomla.org/viewtopic.php?f=728&t=825594

Вот собственно это полу-решение

- undeleted the module
- deleted all HTML
- assigned no position
- assigned no menu items
- unpublished
- deleted
and then I successfully cleaned from trash.
Hope this help

Продолжение через 10 минут
И вот наконец, все заработало, нужно всего лишь зайти в модуль и выбрать отвязку от меню, (не на одной странице) сохраняем и потом модули удаляться, по крайней мере у меня так работает.


у меня не заработало ((