Форум русской поддержки Joomla!® CMS
03.12.2016, 19:43:27 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
   
   Начало   Поиск Joomla 3.0 FAQ Joomla 2.5 FAQ Joomla 1.5 FAQ Правила форума Новости Joomla Реклама Войти Регистрация Помощь  
Страниц: [1]   Вниз
  Добавить закладку  |  Печать  
Автор

Обновление php на денвере

 (Прочитано 14336 раз)
0 Пользователей и 1 Гость смотрят эту тему.
AlekVolsk
Профи
********

Репутация: +316/-3
Offline Offline

Пол: Мужской
Сообщений: 6452



« : 18.06.2014, 09:47:36 »

Заменил содержимое папки /usr/local/php5/, оставив только родной php.ini, согласно FAQ с оф.сайта денвера. Обновляю до php 5.5.13.
Опытным путем установил, что в этой папке также должны находится файлы php5apache2_2.dll и php5ts.dll, из поставки денвера.
Сервер запускается, но выдает сообщение на все библиотеки, скрин во вложении. Как это решается?


* denwer_warn.jpg (24.02 Кб, 319x200 - просмотрено 1286 раз.)
Записан
wishlight
Профи
********

Репутация: +200/-1
Online Online

Пол: Мужской
Сообщений: 3476


skype aqaus.com


« Ответ #1 : 18.06.2014, 11:24:37 »

Опенсервер поставте, там уже все есть.
Записан
AlekVolsk
Профи
********

Репутация: +316/-3
Offline Offline

Пол: Мужской
Сообщений: 6452



« Ответ #2 : 18.06.2014, 12:01:22 »

С опенсервером понятно, мне любопытно, как на денвере это решить.
Записан
AlekVolsk
Профи
********

Репутация: +316/-3
Offline Offline

Пол: Мужской
Сообщений: 6452



« Ответ #3 : 18.06.2014, 12:11:27 »

В общем, все, что удалось - 5.3.13=>5.3.28, а выше никак...
Записан
SK
Практически профи
*******

Репутация: +161/-0
Offline Offline

Сообщений: 2153


« Ответ #4 : 18.06.2014, 13:05:41 »

Я недавно копал тему обновления php до версии 5.5 и кажись выяснил для себя, что не получится это сделать так просто - нужно сначала обновить apache с 2.2 до 2.4.
Сборки Денвера пока идут с apache 2.2
Я все-таки поставил php 5.5.11, но для этого установил сборку xampp. В ней уже apache версии 2.4.9.
Кстати, в версии apache 2.4 сильно поменялся кое-какой синтаксис. Будете ставить - изучите сначала.
Записан
AlekVolsk
Профи
********

Репутация: +316/-3
Offline Offline

Пол: Мужской
Сообщений: 6452



« Ответ #5 : 18.06.2014, 13:08:44 »

Позвольте нескромную просьбу: вашей сборкой не поделитесь?
Записан
SK
Практически профи
*******

Репутация: +161/-0
Offline Offline

Сообщений: 2153


« Ответ #6 : 18.06.2014, 13:12:35 »

Позвольте нескромную просьбу: вашей сборкой не поделитесь?
В смысле?
Идите на сайт и качайте нужный исходник https://www.apachefriends.org/ru/index.html
Но предупреждаю, что это годится только для Joomla версии 3.
Все остальные, которые ниже, будут работать с ошибками
Записан
AlekVolsk
Профи
********

Репутация: +316/-3
Offline Offline

Пол: Мужской
Сообщений: 6452



« Ответ #7 : 18.06.2014, 13:16:24 »

В смысле?
Я имел ввиду весь обновленный денвер.
Записан
SK
Практически профи
*******

Репутация: +161/-0
Offline Offline

Сообщений: 2153


« Ответ #8 : 18.06.2014, 13:21:41 »

Я имел ввиду весь обновленный денвер.
Так я ж написал, что на Денвере не получится - там apache 2.2
Поставьте вместо Денвера сборку xampp.
Записан
AlekVolsk
Профи
********

Репутация: +316/-3
Offline Offline

Пол: Мужской
Сообщений: 6452



« Ответ #9 : 18.06.2014, 13:30:43 »

Ок, спс.
Записан
AlekVolsk
Профи
********

Репутация: +316/-3
Offline Offline

Пол: Мужской
Сообщений: 6452



« Ответ #10 : 18.06.2014, 14:44:06 »

Нашел такую вещь, endels.ru, php5.4.17, обновить до 5.4.29/5.5.13 не удалось.
В общем, неплохая задумка, но вот уж как год не развивается. Регистрация на форуме через почту, письмо на почту не пришло - вопрос не задашь. Заглохла, как и денвер.
Записан
SK
Практически профи
*******

Репутация: +161/-0
Offline Offline

Сообщений: 2153


« Ответ #11 : 18.06.2014, 15:15:51 »

Нашел такую вещь, endels.ru, php5.4.17, обновить до 5.4.29/5.5.13 не удалось.
В общем, неплохая задумка, но вот уж как год не развивается. Регистрация на форуме через почту, письмо на почту не пришло - вопрос не задашь. Заглохла, как и денвер.
Так там же написано, что используется Apache 2.2.25, а не Apache 2.4...
Записан
AlekVolsk
Профи
********

Репутация: +316/-3
Offline Offline

Пол: Мужской
Сообщений: 6452



« Ответ #12 : 18.06.2014, 15:18:39 »

Но php уже не 5.3, а выше.
Я решил опробовать вообще все варианты готовых сборок, которые возможны. Мне необходимо в любой момент иметь возможность поднять локалку в любом месте, по соображения ком.тайны не всегда удобно выкладывать работу на хост (есть такие неудобные заказчики, приходится терпеть).
Записан
god02
Захожу иногда
**

Репутация: +0/-0
Offline Offline

Пол: Мужской
Сообщений: 17



« Ответ #13 : 23.11.2014, 16:08:20 »

Заменить содержимой папки \usr\local\php5 на содержимое архива php-5.5.9-Win32-VC11-x86.zip  (его сам проверил прост), скачанного с apachelounge.com, закомментить в php.ini строчку
Код:
allow_call_time_pass_reference = On
и будет счастье) Просто в этой сборке есть библиотека для взаимодействия php с apache(для php-5.5.9 и apache 2.2), чего нет в других сборках.
Записан
medwed7777
Новичок
*

Репутация: +1/-0
Offline Offline

Сообщений: 5


« Ответ #14 : 28.04.2015, 06:59:20 »

вот обнова заточенная под apache 2.2 https://phpdev.toolsforresearch.com/php-5.6.8-Win32-VC11-x86.zip
все дело вот в этой библиотеке php5apache2_2.dll которая о обычной обнове отсутствует.
в общем качаем и радуемся Smiley
Записан
12mv
Завсегдатай
*****

Репутация: +20/-0
Offline Offline

Пол: Женский
Сообщений: 580


Гульсина


« Ответ #15 : 26.10.2015, 09:51:57 »

И у меня возникла необходимость php обновить для Joomla 3)
AlekVolsk, как нибудь вопрос решился?
Записан
AlekVolsk
Профи
********

Репутация: +316/-3
Offline Offline

Пол: Мужской
Сообщений: 6452



« Ответ #16 : 26.10.2015, 10:01:24 »

я перешел на openserver
Записан
neogeek
Давно я тут
****

Репутация: +18/-2
Offline Offline

Сообщений: 212


« Ответ #17 : 26.10.2015, 10:01:38 »

И у меня возникла необходимость php обновить для Joomla 3)
AlekVolsk, как нибудь вопрос решился?
На локальной машине? Если да, то ставьте Openserver
Записан
12mv
Завсегдатай
*****

Репутация: +20/-0
Offline Offline

Пол: Женский
Сообщений: 580


Гульсина


« Ответ #18 : 26.10.2015, 10:04:03 »

я перешел на openserver

И я пошла на него))

На локальной машине? Если да, то ставьте Openserver

Уже качаю, спасибо)
Записан
Страниц: [1]   Вверх
  Добавить закладку  |  Печать  
 
Перейти в:  

Powered by SMF 1.1.21 | SMF © 2006, Simple Machines

Joomlaforum.ru is not affiliated with or endorsed by the Joomla! Project or Open Source Matters.
The Joomla! name and logo is used under a limited license granted by Open Source Matters
the trademark holder in the United States and other countries.

LiveInternet