Форум русской поддержки Joomla!® CMS
10.12.2016, 05:11:10 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
   
   Начало   Поиск Joomla 3.0 FAQ Joomla 2.5 FAQ Joomla 1.5 FAQ Правила форума Новости Joomla Реклама Войти Регистрация Помощь  
Страниц: [1]   Вниз
  Добавить закладку  |  Печать  
Автор

Белый экран в админке JoomShopping после обновления до 4.6.0

 (Прочитано 1630 раз)
0 Пользователей и 1 Гость смотрят эту тему.
e-Claire
Осваиваюсь на форуме
***

Репутация: +0/-0
Offline Offline

Сообщений: 55


« : 05.09.2014, 14:29:23 »

Последовательно загрузила обновления с 4.4.1 до 4.6.0 через "Установку и обновление" JoomShopping. Теперь при заходе в админке в Компоненты/Joomshopping вижу только белый экран.
На сайте все категории открываются нормально.

Включила в общих настройках сайта сообщения об ошибках. Вот что появилось на белом экране в Joomshopping-e:

Fatal error: Cannot redeclare getMainCurrencyCode() (previously declared in /home/a/site/public_html/components/com_jshopping/lib/functions.php:132) in /home/a/site/public_html/administrator/components/com_jshopping/functions.php on line 81

Подскажите, пожалуйста, как откатить/исправить?

Заранее спасибо!
« Последнее редактирование: 05.09.2014, 14:36:01 от e-Claire » Записан
dmitry_stas
Профи
********

Репутация: +798/-4
Offline Offline

Сообщений: 7781



« Ответ #1 : 05.09.2014, 14:33:54 »

для начала неплохо было бы включить отображение ошибок в Joomla и сказать какая ошибка. а то с белым экраном чуть сложнее чем с кофейной гущей.
Записан
e-Claire
Осваиваюсь на форуме
***

Репутация: +0/-0
Offline Offline

Сообщений: 55


« Ответ #2 : 05.09.2014, 14:36:46 »

Да, прошу прощения, не сразу сообразила, добавила в тело первого поста.
Записан
nevigen
Moderator
*****

Репутация: +734/-16
Offline Offline

Пол: Мужской
Сообщений: 8809


http://n*****n.com


« Ответ #3 : 05.09.2014, 14:38:44 »

обновление поэтапно прошли ? надеюсь
Записан
e-Claire
Осваиваюсь на форуме
***

Репутация: +0/-0
Offline Offline

Сообщений: 55


« Ответ #4 : 05.09.2014, 14:40:33 »

обновление поэтапно прошли ? надеюсь
Да, поэтапно.
Записан
nevigen
Moderator
*****

Репутация: +734/-16
Offline Offline

Пол: Мужской
Сообщений: 8809


http://n*****n.com


« Ответ #5 : 05.09.2014, 14:44:49 »

перепишите файлы версии 4.6.0 поверх

и проверьте основную валюту.
Записан
SmokerMan
Профи
********

Репутация: +694/-25
Offline Offline

Пол: Мужской
Сообщений: 5225



« Ответ #6 : 05.09.2014, 14:50:13 »

Fatal error: Cannot redeclare getMainCurrencyCode() (previously declared in /home/a/site/public_html/components/com_jshopping/lib/functions.php:132) in /home/a/site/public_html/administrator/components/com_jshopping/functions.php on line 81
home/a/site/public_html/administrator/components/com_jshopping/functions.php - в этом файле не должно быть по идее этого метода
а ошибка эта значит, что данный метод объявляется дважды
перепишете его из установочного архива
Записан
dmitry_stas
Профи
********

Репутация: +798/-4
Offline Offline

Сообщений: 7781



« Ответ #7 : 05.09.2014, 15:24:51 »

Да, поэтапно.

интересно, откуда же взялся тогда такой неправильный /administrator/components/com_jshopping/functions.php, если при обновлении до 4.5.0 он переписывается правильной версией Azn
Записан
e-Claire
Осваиваюсь на форуме
***

Репутация: +0/-0
Offline Offline

Сообщений: 55


« Ответ #8 : 05.09.2014, 17:18:55 »

перепишите файлы версии 4.6.0 поверх

и проверьте основную валюту.

Файлы поверх переписала (все, кроме update.sql - с ним что делать?). Все равно выдается та же ошибка.
Валюту проверить не могу, т.к. не могу войти в JoomShopping.
Записан
e-Claire
Осваиваюсь на форуме
***

Репутация: +0/-0
Offline Offline

Сообщений: 55


« Ответ #9 : 05.09.2014, 17:28:13 »

интересно, откуда же взялся тогда такой неправильный /administrator/components/com_jshopping/functions.php, если при обновлении до 4.5.0 он переписывается правильной версией Azn
Непонятно. Но сейчас я переписала все файлы апдейта поверх вручную, и все равно та же ошибка.
Записан
dmitry_stas
Профи
********

Репутация: +798/-4
Offline Offline

Сообщений: 7781



« Ответ #10 : 05.09.2014, 18:09:24 »

вы переписали из апдейта, а надо из полной установки.
Записан
e-Claire
Осваиваюсь на форуме
***

Репутация: +0/-0
Offline Offline

Сообщений: 55


« Ответ #11 : 05.09.2014, 18:21:07 »

вы переписали из апдейта, а надо из полной установки.
Ясно. А не подскажете, где взять полную установку 4.6.0? Дело в том, что здесь - http://www.webdesigner-profi.de/joomla-webdesign/joomla-shop/downloads.html?lang=en - лежит версия 4.6.1, а в архиве все заканчивается на версии 4.3.3  Sad
Записан
dmitry_stas
Профи
********

Репутация: +798/-4
Offline Offline

Сообщений: 7781



« Ответ #12 : 05.09.2014, 18:23:31 »

пишите из 4.6.1, но после того как попадете в админку ЖШ, обязательно обновитесь! с 4.6.0 до 4.6.1
Записан
e-Claire
Осваиваюсь на форуме
***

Репутация: +0/-0
Offline Offline

Сообщений: 55


« Ответ #13 : 05.09.2014, 19:03:10 »

пишите из 4.6.1, но после того как попадете в админку ЖШ, обязательно обновитесь! с 4.6.0 до 4.6.1

Проблема в том, что 4.6.1 мне не подходит. Я собираюсь использовать шаблон Template responsive 1.0.2, а он совместим максимум с 4.6.0
http://www.webdesigner-profi.de/joomla-webdesign/joomla-shop/downloads/templates.html?lang=en
С 4.6.1 работать видимо не будет...  (

Может можно как-то переустановить JoomShopping 4.4.1 заново? Стереть полностью файлы из  /public_html/components/com_jshopping  и  /public_html/administrator/components/com_jshopping, а потом через установщик Joomla залить старую версию? Или тогда надо в базе данных MySQL что-то будет удалять тоже?
Записан
dmitry_stas
Профи
********

Репутация: +798/-4
Offline Offline

Сообщений: 7781



« Ответ #14 : 05.09.2014, 19:05:42 »

https://www.dropbox.com/s/u39zho8ezq060ww/JoomShopping-4.6.0.zip?dl=0
Записан
e-Claire
Осваиваюсь на форуме
***

Репутация: +0/-0
Offline Offline

Сообщений: 55


« Ответ #15 : 05.09.2014, 19:12:37 »

https://www.dropbox.com/s/u39zho8ezq060ww/JoomShopping-4.6.0.zip?dl=0
Спасибо огромное, пойду ставить...
Записан
Biss
Завсегдатай
*****

Репутация: +64/-0
Offline Offline

Пол: Мужской
Сообщений: 661



« Ответ #16 : 06.09.2014, 12:10:27 »

Проблема в том, что 4.6.1 мне не подходит. Я собираюсь использовать шаблон Template responsive 1.0.2, а он совместим максимум с 4.6.0
Почему это не подходит, шаблон просто совместим с версией 4.6.0 и не ниже а не как вы написали "максимум" просто шаблон надо немного апдейтить под 4.6.1 было изменено в шаблоне всего три файла:

cart.php
wishlist.php
product_default.php
Записан
12mv
Завсегдатай
*****

Репутация: +20/-0
Offline Offline

Пол: Женский
Сообщений: 580


Гульсина


« Ответ #17 : 14.09.2015, 08:36:18 »

Та же проблема с обновлением JoomShopping-update-3.18.0-3.18.1
Записан
Страниц: [1]   Вверх
  Добавить закладку  |  Печать  
 
Перейти в:  

Powered by SMF 1.1.21 | SMF © 2006, Simple Machines

Joomlaforum.ru is not affiliated with or endorsed by the Joomla! Project or Open Source Matters.
The Joomla! name and logo is used under a limited license granted by Open Source Matters
the trademark holder in the United States and other countries.

LiveInternet