Форум русской поддержки Joomla!® CMS
09.12.2016, 19:26:22 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
   
   Начало   Поиск Joomla 3.0 FAQ Joomla 2.5 FAQ Joomla 1.5 FAQ Правила форума Новости Joomla Реклама Войти Регистрация Помощь  
Страниц: [1]   Вниз
  Добавить закладку  |  Печать  
Автор

Perfect AJAX Contact Form + Joomla 3.4

 (Прочитано 1290 раз)
0 Пользователей и 1 Гость смотрят эту тему.
onuvidelsolnce
Осваиваюсь на форуме
***

Репутация: +2/-0
Offline Offline

Сообщений: 44


нового утра новую дрожь


« : 02.03.2015, 14:20:31 »

После обновления Joomla до 3.4 модуль Perfect AJAX Contact Form перестал работать: под кнопкой "отправить" висит бесконечная - "Инициализация отправки формы.." причем сразу при загрузке модуля на странице, а не после нажатия на кнопку "отправить", на другом сайте где не обновлялся форма работает нормально. Похоже на конфликт javascript? но не могу определить в чем? Гружу библиотеки jquery и bootstrap не из ядра, а из папки шаблона. На странице кроме этого модуля больше ничего нет что может помешать работе. До обновления, в настройках модуля всегда отключал полностью любые загрузки скриптов из настроек самого модуля. Кто что посоветует по этому поводу..
Записан
onuvidelsolnce
Осваиваюсь на форуме
***

Репутация: +2/-0
Offline Offline

Сообщений: 44


нового утра новую дрожь


« Ответ #1 : 02.03.2015, 15:07:21 »

Всталяю этот скрипт(проверка версии jquery) в шаблон

Код:
$(document).ready(function(){alert(jQuery.fn.jquery);});

До позиции вывода модуля "Perfect AJAX Contact Form" скрипт работает, после - уже не работает... что то в самой работе формы нарушено(
Записан
onuvidelsolnce
Осваиваюсь на форуме
***

Репутация: +2/-0
Offline Offline

Сообщений: 44


нового утра новую дрожь


« Ответ #2 : 02.03.2015, 17:24:29 »

Начав сравнивать работу модуля на двух сайтах заметил(где работает и не работает модуль):

На сайте где работает модуль, вставляется вот такого плана скрипт. (замечу что такой же код на официальном демо-сайте для этого модуля):

Код:
(function() {
      var strings = {"Здесь абракадабра, как я понял текст самой формы в юникод формате вся кирилица вот в таких подобных символах \u0418"};
      if (typeof Joomla == 'undefined') {
        Joomla = {};
        Joomla.JText = strings;
      }
      else {
        Joomla.JText.load(strings);
      }
    })();

На сайте где модуль не работает выводится так:

Код:
(function() {
      Joomla.JText.load({"Та же абракадабра в юникоде"});
    })();

Я скопировал код с сайта на котором модуль работает (первый) и вставил непосредственно в head на сайте с неработающим... Все заработало, волнующая меня проблема пропала.

Подскажите как и где формируется этот код что бы его подправить? Почему формируется разный код, ведь версии модулей на двух сайтах одинаковые (устаналивались из одного и того же архива). Получается что-то в Joomla 3.4 поменялось...
« Последнее редактирование: 02.03.2015, 17:32:36 от onuvidelsolnce » Записан
koyot777
Осваиваюсь на форуме
***

Репутация: +1/-0
Offline Offline

Пол: Мужской
Сообщений: 110


Не щекочи койота..


« Ответ #3 : 30.06.2015, 07:28:49 »

Всем привет! подскажите как мне сделать чтобы в теме письма указывался емейл который был заполнен пользователем в самой форме? Пробовал указывать {суффикс_поля} приходит обычный текст "{суффикс_поля}" 

версия модуля 3.2.22, Дж 2.5
Записан
Страниц: [1]   Вверх
  Добавить закладку  |  Печать  
 
Перейти в:  

Powered by SMF 1.1.21 | SMF © 2006, Simple Machines

Joomlaforum.ru is not affiliated with or endorsed by the Joomla! Project or Open Source Matters.
The Joomla! name and logo is used under a limited license granted by Open Source Matters
the trademark holder in the United States and other countries.

LiveInternet