Форум русской поддержки Joomla!® CMS
07.12.2016, 12:46:30 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
   
   Начало   Поиск Joomla 3.0 FAQ Joomla 2.5 FAQ Joomla 1.5 FAQ Правила форума Новости Joomla Реклама Войти Регистрация Помощь  
Страниц: [1]   Вниз
  Добавить закладку  |  Печать  
Автор

Обновление

 (Прочитано 718 раз)
0 Пользователей и 1 Гость смотрят эту тему.
AndreySm
Осваиваюсь на форуме
***

Репутация: +1/-0
Offline Offline

Сообщений: 69



« : 23.05.2015, 00:47:17 »

Немножко в стопоре. Как его обновлять ? Есть сайт на Joomla 2.5 - нужно обновить до третьей линейки. Как его при этом обновить если пишет что новая версия только для линейки 3 ? На 2.5 не получится ? Как перенести ?
Записан
migus
Moderator
*****

Репутация: +144/-0
Offline Offline

Пол: Мужской
Сообщений: 1010


OPEN THE BOX


« Ответ #1 : 23.05.2015, 12:14:06 »

Версия AUP 1.9.13 работает на Joomla 2.5.x и на 3.x.x (upd: это не так - см.ветку ниже)
Поэтому логика такая:
1. Делайте перенос на Joomla 3.4.1 с версией AUP 1.9.13
2. После миграции можно будет сделать установку AUP 2.0.0 поверх версии 1.9.13.

не забывайте делать бэкап

- удачи Wink
« Последнее редактирование: 28.05.2015, 06:39:22 от migus » Записан
AndreySm
Осваиваюсь на форуме
***

Репутация: +1/-0
Offline Offline

Сообщений: 69



« Ответ #2 : 23.05.2015, 13:13:20 »

А как же ваш пост http://joomlaforum.ru/index.php?topic=305330.0 при этом на сайте только версия 2.
Записан
migus
Moderator
*****

Репутация: +144/-0
Offline Offline

Пол: Мужской
Сообщений: 1010


OPEN THE BOX


« Ответ #3 : 24.05.2015, 13:27:45 »

А как же ваш пост http://joomlaforum.ru/index.php?topic=305330.0 при этом на сайте только версия 2.
Вы правы. Это я неправильно указал версию AUP. Вам для миграции необходимо использовать версию AUP 1.8.9
После миграции на Joomla 3.x.x - выполните установку AUP 2.0.0 поверх.
Записан
AndreySm
Осваиваюсь на форуме
***

Репутация: +1/-0
Offline Offline

Сообщений: 69



« Ответ #4 : 24.05.2015, 20:28:35 »

Вы правы. Это я неправильно указал версию AUP. Вам для миграции необходимо использовать версию AUP 1.8.9
После миграции на Joomla 3.x.x - выполните установку AUP 2.0.0 поверх.
вот где бы еще найти Azn. на сайте не нашел.
Записан
migus
Moderator
*****

Репутация: +144/-0
Offline Offline

Пол: Мужской
Сообщений: 1010


OPEN THE BOX


« Ответ #5 : 25.05.2015, 08:17:00 »

Поищу у себя.
Upd: Нашёл, только 1.8.4 (думаю, для ваших целей подойдёт)
Ссылка для скачивания

не забывайте делать backup

- удачи Wink
« Последнее редактирование: 25.05.2015, 11:35:05 от migus » Записан
AndreySm
Осваиваюсь на форуме
***

Репутация: +1/-0
Offline Offline

Сообщений: 69



« Ответ #6 : 25.05.2015, 20:13:28 »

Пробовал по разному. Обновлять на 2.5 , обновлять после обновления Joomla. На 2.5 версия 1.8.9. После любого типа обновления в админке Joomla 3
Цитировать
"1054 Unknown column 'points2' in 'field list' SQL=INSERT INTO joomla_alpha_userpoints_rules (`id`, `rule_name`, `rule_description`, `rule_plugin`, `plugin_function`, `access`, `component`, `calltask`, `taskid`, `points`, `points2`, `percentage`, `rule_expire`, `sections`, `categories`, `content_items`, `exclude_items`, `published`, `system`, `duplicate`, `blockcopy`, `autoapproved`, `fixedpoints`, `category`, `displaymsg`, `msg`, `method`, `notification`, `emailsubject`, `emailbody`, `emailformat`, `bcc2admin`, `type_expire_date`, `chain`, `linkup`) VALUES('', 'Login', 'Attrib or remove points when a user log in into the frontend website', 'Joomla user', 'sysplgaup_login', '1', '', '', '', 0, 0, 0, '0000-00-00 00:00:00', '', '', '', '', 0, 0, 0, 0, 1, 1, 'us', '1', '', '2', '0', '', '', '0', '0', '0', '0', '0'); "
Записан
migus
Moderator
*****

Репутация: +144/-0
Offline Offline

Пол: Мужской
Сообщений: 1010


OPEN THE BOX


« Ответ #7 : 26.05.2015, 11:09:12 »

Доступ к базе у вас есть?
Записан
AndreySm
Осваиваюсь на форуме
***

Репутация: +1/-0
Offline Offline

Сообщений: 69



« Ответ #8 : 26.05.2015, 11:45:04 »

сайт на локалке.
Записан
vipiusss
Профи
********

Репутация: +261/-8
Offline Offline

Пол: Мужской
Сообщений: 4573


Skype: renor_


« Ответ #9 : 26.05.2015, 11:50:30 »

скачайте ауп на комп, распакуйте, и гоу в денвер
Записан
AndreySm
Осваиваюсь на форуме
***

Репутация: +1/-0
Offline Offline

Сообщений: 69



« Ответ #10 : 26.05.2015, 12:18:28 »

На 2.5 стоит версия 1.8.9. При обновлении до Joomla 3.4. она не работает. Вы вроде говорили что она работает и на 2.5 и на 3. Может 3.0.1 поставить ?
« Последнее редактирование: 26.05.2015, 13:04:31 от AndreySm » Записан
migus
Moderator
*****

Репутация: +144/-0
Offline Offline

Пол: Мужской
Сообщений: 1010


OPEN THE BOX


« Ответ #11 : 27.05.2015, 11:02:11 »

На 2.5 стоит версия 1.8.9. При обновлении до Joomla 3.4. она не работает. Вы вроде говорили что она работает и на 2.5 и на 3. Может 3.0.1 поставить ?
Что мешает попробовать? У меня, к сожалению, такого опыта нет.
Записан
AndreySm
Осваиваюсь на форуме
***

Репутация: +1/-0
Offline Offline

Сообщений: 69



« Ответ #12 : 27.05.2015, 13:19:50 »

Ок. Пробую описать по шагам.
Имеем:
AlphaUserPoints 1.8.9
JComments 2.3.0 обновлено до 3.0.5
JomSocial 2.4.0 обновление до 3.0.4
Kunena 1.7.2 обновление до 3.0.8
Сайт полностью работает
Ручное обновлени до Joomla 3.0.1 как и автоматческое до 3.4 выдает ошибку при заходе  в AlphaUserPoints  Fatal error: Class alphauserpointsController cannot extend from interface JController in C:\xampp\htdocs\xxxxx\administrator\components\com_alphauserpoints\controller.php on line 18

После обновления до версии 2.0 при заходе в компонет в админке ошибка : 500 - Обнаружена ошибка.

SQL=INSERT INTO joomla_alpha_userpoints_rules (`id`, `rule_name`, `rule_description`, `rule_plugin`, `plugin_function`, `access`, `component`, `calltask`, `taskid`, `points`, `points2`, `percentage`, `rule_expire`, `sections`, `categories`, `content_items`, `exclude_items`, `published`, `system`, `duplicate`, `blockcopy`, `autoapproved`, `fixedpoints`, `category`, `displaymsg`, `msg`, `method`, `notification`, `emailsubject`, `emailbody`, `emailformat`, `bcc2admin`, `type_expire_date`, `chain`, `linkup`) VALUES('', 'Login', 'Attrib or remove points when a user log in into the frontend website', 'Joomla user', 'sysplgaup_login', '1', '', '', '', 0, 0, 0, '0000-00-00 00:00:00', '', '', '', '', 0, 0, 0, 0, 1, 1, 'us', '1', '', '2', '0', '', '', '0', '0', '0', '0', '0');

Что я делаю не так ?
Записан
AndreySm
Осваиваюсь на форуме
***

Репутация: +1/-0
Offline Offline

Сообщений: 69



« Ответ #13 : 27.05.2015, 14:18:10 »

Даже полностью удалил все сторонние компоненты кроме AlphaUserPoints и все равно так же. При обновлении до версии 2:
 Обнаружена ошибка.

    1054 Unknown column 'points2' in 'field list' SQL=INSERT INTO joomla_alpha_userpoints_rules (`id`, `rule_name`, `rule_description`, `rule_plugin`, `plugin_function`, `access`, `component`, `calltask`, `taskid`, `points`, `points2`, `percentage`, `rule_expire`, `sections`, `categories`, `content_items`, `exclude_items`, `published`, `system`, `duplicate`, `blockcopy`, `autoapproved`, `fixedpoints`, `category`, `displaymsg`, `msg`, `method`, `notification`, `emailsubject`, `emailbody`, `emailformat`, `bcc2admin`, `type_expire_date`, `chain`, `linkup`) VALUES('', 'Login', 'Attrib or remove points when a user log in into the frontend website', 'Joomla user', 'sysplgaup_login', '1', '', '', '', 0, 0, 0, '0000-00-00 00:00:00', '', '', '', '', 0, 0, 0, 0, 1, 1, 'us', '1', '', '2', '0', '', '', '0', '0', '0', '0', '0');
Записан
AndreySm
Осваиваюсь на форуме
***

Репутация: +1/-0
Offline Offline

Сообщений: 69



« Ответ #14 : 27.05.2015, 14:47:24 »

Поставил 2.0 на чистую версию Joomla. Все нормально. Но таблицы joomla_alpha_userpoints_rules немного отличаются. Наверно в этом проблема.
Записан
migus
Moderator
*****

Репутация: +144/-0
Offline Offline

Пол: Мужской
Сообщений: 1010


OPEN THE BOX


« Ответ #15 : 28.05.2015, 06:42:25 »

Попробуйте вручную добавить поле points2 в таблицу...
Записан
AndreySm
Осваиваюсь на форуме
***

Репутация: +1/-0
Offline Offline

Сообщений: 69



« Ответ #16 : 28.05.2015, 11:55:49 »

Да. Спасибо за идею. Так и пришлось решить проблему. Правда там оказалось больше 5 ти недостающих полей.
Записан
migus
Moderator
*****

Репутация: +144/-0
Offline Offline

Пол: Мужской
Сообщений: 1010


OPEN THE BOX


« Ответ #17 : 28.05.2015, 21:42:15 »

На самом деле, при установке новой версии поверх - эти поля должны были прописаться в базе. Видимо, какая-то некорректная установка получалась.

- удачи Wink
Записан
AndreySm
Осваиваюсь на форуме
***

Репутация: +1/-0
Offline Offline

Сообщений: 69



« Ответ #18 : 28.05.2015, 22:10:41 »

не. Ставил на чистую Joomla - там этими полями и не пахнет. Как и еще штук 5 на старой 2.5. Не понятно как там все работало если даже ругалось на это поле в Системном отчете. По идее эти поля должны были создаваться при создании условий.
Записан
migus
Moderator
*****

Репутация: +144/-0
Offline Offline

Пол: Мужской
Сообщений: 1010


OPEN THE BOX


« Ответ #19 : 29.05.2015, 17:59:26 »

Специально посмотрел. Был большой update в версии AUP 1.9.9
Для тех кому пригодится:
надо в базе сделать такой запрос:
Код
ALTER TABLE #__alpha_userpoints_levelrank ADD `notification` tinyint(1) NOT NULL DEFAULT '0', ADD `emailsubject` varchar(255) NOT NULL DEFAULT '', ADD `emailbody` text NOT NULL DEFAULT '', ADD `emailformat` tinyint(1) NOT NULL DEFAULT '0', ADD `bcc2admin` tinyint(1) NOT NULL DEFAULT '0';
 
ALTER TABLE #__alpha_userpoints_raffle_inscriptions ADD `ticket` varchar(30) NOT NULL DEFAULT '', ADD `referredraw` int(11) NOT NULL DEFAULT '0', ADD `inscription` datetime NOT NULL DEFAULT '0000-00-00 00:00:00';
 
ALTER TABLE #__alpha_userpoints_rules ADD `chain` tinyint(1) NOT NULL DEFAULT '0', ADD `linkup` int(11) NOT NULL DEFAULT '0';
 
UPDATE #__alpha_userpoints_rules SET `duplicate`='1', `blockcopy`='0', `chain`='1' WHERE `plugin_function`='sysplgaup_bonuspoints';
 

- удачи Wink
Записан
Страниц: [1]   Вверх
  Добавить закладку  |  Печать  
 
Перейти в:  

Powered by SMF 1.1.21 | SMF © 2006, Simple Machines

Joomlaforum.ru is not affiliated with or endorsed by the Joomla! Project or Open Source Matters.
The Joomla! name and logo is used under a limited license granted by Open Source Matters
the trademark holder in the United States and other countries.

LiveInternet