Форум русской поддержки Joomla!® CMS
05.12.2016, 08:35:16 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
   
   Начало   Поиск Joomla 3.0 FAQ Joomla 2.5 FAQ Joomla 1.5 FAQ Правила форума Новости Joomla Реклама Войти Регистрация Помощь  
Страниц: [1]   Вниз
  Добавить закладку  |  Печать  
Автор

Обнаружена ошибка

 (Прочитано 1260 раз)
0 Пользователей и 1 Гость смотрят эту тему.
Сergei
Давно я тут
****

Репутация: +0/-0
Offline Offline

Сообщений: 209


« : 15.06.2015, 23:09:30 »

Компонент AlphaUserPoints v2.0.0 не устанавливается на версию Joomla 3.3.3. При установке Выводится сообщение:
Цитировать
Обнаружена ошибка.
1146 Table '1.joom_alpha_userpoints' doesn't exist SQL=SELECT id FROM joom_alpha_userpoints WHERE `userid`='0' AND `referreid`='GUEST'

Данная ошибка, только у меня или AlphaUserPoints v2.0.0 не поддерживает версию Joomla 3.3.3?
Записан
migus
Moderator
*****

Репутация: +144/-0
Offline Offline

Пол: Мужской
Сообщений: 1010


OPEN THE BOX


« Ответ #1 : 15.06.2015, 23:17:00 »

AUP 2.0.0 должен нормально устанавливаться на все версии Joomla линейки 3.x.x
А что это у вас такой префикс таблиц странный?
Другие компоненты устанавливаются без ошибок?
Записан
Сergei
Давно я тут
****

Репутация: +0/-0
Offline Offline

Сообщений: 209


« Ответ #2 : 16.06.2015, 20:33:07 »

Префикс таблиц такой я придумал сам во время установки Joomla.
Компоненты другие, а также модули устанавливаются без подобных ошибок.

Также при установке AUP появляется другая похожая ошибка:
Цитировать
Обнаружена ошибка.
1146 Table '1.joom_alpha_userpoints' doesn't exist SQL=SELECT referreid FROM joom_alpha_userpoints WHERE `userid`='557'

Скриншот ошибки: http://rghost.ru/7tTHh7cTK.view

Записан
migus
Moderator
*****

Репутация: +144/-0
Offline Offline

Пол: Мужской
Сообщений: 1010


OPEN THE BOX


« Ответ #3 : 17.06.2015, 01:57:54 »

У вас была некорректная первая установка. Вы пробовали удалить компонент через менеджер расширений?
Скорее всего остались старые таблицы.
1. Попробуйте корректно снести AUP через менеджер расширений.
2. Проверьте в БД, если остались таблицы с "ваш префикс_alpha_userpoints_" в имени - удалите их все.
3. Выполните чистую установку.

- удачи Wink
Записан
Сergei
Давно я тут
****

Репутация: +0/-0
Offline Offline

Сообщений: 209


« Ответ #4 : 17.06.2015, 19:05:00 »

migus Вы правы! После переустановки Joomla и вновь установленного компонента AUP ошибка пропала. Установка прошла успешно!
Спасибо за внимание!
Записан
AdWeb
Завсегдатай
*****

Репутация: +26/-2
Offline Offline

Пол: Мужской
Сообщений: 722


« Ответ #5 : 25.12.2015, 16:18:10 »

вопрос эт у меня косяк или в последней версии  плагина интеграции ауп с куненой косяк тк при включении плагина и попытке входа в профиль пользователя Kunena, страница крешится и выдает вместо
Код:
мойсайт/my-profile
такое
Код:
мойсайт/component/alphauserpoints/account/profile?Itemid=
и
Код:
Warning: array_merge(): Argument #2 is not an array in /home/virtwww/мойсайт/http/libraries/cms/router/router.php on line 350 Fatal error: Unsupported operand types in /home/virtwww/мойсайт1/http/libraries/cms/router/router.php on line 234
Записан
SolopoV
Завсегдатай
*****

Репутация: +12/-0
Offline Offline

Пол: Мужской
Сообщений: 462


зеленею...


« Ответ #6 : 31.07.2016, 09:22:24 »

Аналогичная ошибка (Joomla 3.6):

Код:
Unsupported operand types
...\libraries\cms\router\router.php:234

229 }
230
231 // Parse SEF URL
232 if ($this->_mode == JROUTER_MODE_SEF)
233 {
234 $vars += $this->_parseSefRoute($uri);

При просмотре профиля продавца в компоненте vmvendor.

Переустановить компонент?
Записан
Страниц: [1]   Вверх
  Добавить закладку  |  Печать  
 
Перейти в:  

Powered by SMF 1.1.21 | SMF © 2006, Simple Machines

Joomlaforum.ru is not affiliated with or endorsed by the Joomla! Project or Open Source Matters.
The Joomla! name and logo is used under a limited license granted by Open Source Matters
the trademark holder in the United States and other countries.

LiveInternet