[Решено] SP Page Builder: не работаю всплывающие окна при применении анимации к блоку в котором нахо

  • 5 Ответов
  • 2377 Просмотров

0 Пользователей и 1 Гость просматривают эту тему.

*

Оффлайн orsy

  • ****
  • 390
  • [+]21 / [-]1
  • Web-Factor Ukraine
    • Просмотр профиля
    • Студия "Web-factor"
Всем, привет.

Нашел странную проблему в SP Page Builder:
если применить к блоку в котором есть кнопка со всплывающем окном, какой-нибудь эффект, то перестает нормально работать эффект всплывающего окна, а точнее, блок, который должен затемнять фон за модальным окном, просто перекрывает его и не реагирует на клики.

SP Page Builder ставил на совершенно чистый шаблон, почти без стилей.

На официальном форуме как задать вопрос не нашел, видимо там только для купивших расширение или фиг его знает почему.

Нашел вот эти стили в файле animate.min.css

.sppb-animated {
  -webkit-animation-duration: 1s;
  animation-duration: 1s;
  -webkit-animation-fill-mode: both;
  animation-fill-mode: both;
}

вот если закоментировать последние два стиля то всплывающие окна начинают нормально отрабатывать, но тут начинают происходить чудеса с анимацией (элементы, которые должны появляться при прокрутке, уже есть, но когда к ним прокручиваешь страницу, они пропадают и типа появляются снова).

Причем проблема не только с родной кнопкой всплывающего окна, но и с самописным модул всплывающей формы обратной связи.

Кто-нибудь сталкивался, и если да, то как порешали?
« Последнее редактирование: 22.07.2015, 02:17:06 от orsy »

*

Оффлайн orsy

  • ****
  • 390
  • [+]21 / [-]1
  • Web-Factor Ukraine
    • Просмотр профиля
    • Студия "Web-factor"
В общем победил я эту штуку? теперь всплывашки отрабатывают нормально независимо от того подключена анимация или нет ) Кому интересно пишите в личку и я размещу решение в этой ветке, иначе не вижу смысла потому как смотрю интереса у публики эта проблема не вызвала, видимо мало кто столкнулся.

В общем победил я эту штуку? теперь всплывашки отрабатывают нормально независимо от того подключена анимация или нет ) Кому интересно пишите в личку и я размещу решение в этой ветке, иначе не вижу смысла потому как смотрю интереса у публики эта проблема не вызвала, видимо мало кто столкнулся.

Напиши как решил проблему. У меня вообще вся анимация порпала(

*

Оффлайн orsy

  • ****
  • 390
  • [+]21 / [-]1
  • Web-Factor Ukraine
    • Просмотр профиля
    • Студия "Web-factor"
Напиши как решил проблему. У меня вообще вся анимация порпала(

подробно расписал что и как делал вот тут в своем блоге: http://webors.in.ua/sp-page-builder-konflikt-vsplyivayushhih-okon-s-animatsiey-blokov/

*

Оффлайн nikazz

в новой версии sp нет в js этой строки куда нужно вставить код, куда теперь нужно вставить js код ? или как исправить ?

*

Оффлайн orsy

  • ****
  • 390
  • [+]21 / [-]1
  • Web-Factor Ukraine
    • Просмотр профиля
    • Студия "Web-factor"
в новой версии sp нет в js этой строки куда нужно вставить код, куда теперь нужно вставить js код ? или как исправить ?
вы хотите сказать что в новой версии осталась эта проблема?