Форум русской поддержки Joomla!® CMS
09.12.2016, 00:12:52 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
   
   Начало   Поиск Joomla 3.0 FAQ Joomla 2.5 FAQ Joomla 1.5 FAQ Правила форума Новости Joomla Реклама Войти Регистрация Помощь  
Страниц: [1]   Вниз
  Добавить закладку  |  Печать  
Автор

[Решено] SP Page Builder: не работаю всплывающие окна при применении анимации к блоку в котором нахо

 (Прочитано 1537 раз)
0 Пользователей и 1 Гость смотрят эту тему.
orsy
Давно я тут
****

Репутация: +19/-1
Offline Offline

Пол: Мужской
Сообщений: 331


Web-Factor Ukraine


« : 11.07.2015, 01:16:04 »

Всем, привет.

Нашел странную проблему в SP Page Builder:
если применить к блоку в котором есть кнопка со всплывающем окном, какой-нибудь эффект, то перестает нормально работать эффект всплывающего окна, а точнее, блок, который должен затемнять фон за модальным окном, просто перекрывает его и не реагирует на клики.

SP Page Builder ставил на совершенно чистый шаблон, почти без стилей.

На официальном форуме как задать вопрос не нашел, видимо там только для купивших расширение или фиг его знает почему.

Нашел вот эти стили в файле animate.min.css

Код:
.sppb-animated {
  -webkit-animation-duration: 1s;
  animation-duration: 1s;
  -webkit-animation-fill-mode: both;
  animation-fill-mode: both;
}

вот если закоментировать последние два стиля то всплывающие окна начинают нормально отрабатывать, но тут начинают происходить чудеса с анимацией (элементы, которые должны появляться при прокрутке, уже есть, но когда к ним прокручиваешь страницу, они пропадают и типа появляются снова).

Причем проблема не только с родной кнопкой всплывающего окна, но и с самописным модул всплывающей формы обратной связи.

Кто-нибудь сталкивался, и если да, то как порешали?
« Последнее редактирование: 22.07.2015, 01:17:06 от orsy » Записан
orsy
Давно я тут
****

Репутация: +19/-1
Offline Offline

Пол: Мужской
Сообщений: 331


Web-Factor Ukraine


« Ответ #1 : 13.07.2015, 13:31:45 »

В общем победил я эту штуку? теперь всплывашки отрабатывают нормально независимо от того подключена анимация или нет ) Кому интересно пишите в личку и я размещу решение в этой ветке, иначе не вижу смысла потому как смотрю интереса у публики эта проблема не вызвала, видимо мало кто столкнулся.
Записан
ilya_pro_rock
Новичок
*

Репутация: +0/-0
Offline Offline

Сообщений: 3


« Ответ #2 : 21.07.2015, 15:46:22 »

В общем победил я эту штуку? теперь всплывашки отрабатывают нормально независимо от того подключена анимация или нет ) Кому интересно пишите в личку и я размещу решение в этой ветке, иначе не вижу смысла потому как смотрю интереса у публики эта проблема не вызвала, видимо мало кто столкнулся.

Напиши как решил проблему. У меня вообще вся анимация порпала(
Записан
orsy
Давно я тут
****

Репутация: +19/-1
Offline Offline

Пол: Мужской
Сообщений: 331


Web-Factor Ukraine


« Ответ #3 : 22.07.2015, 01:05:21 »

Напиши как решил проблему. У меня вообще вся анимация порпала(

подробно расписал что и как делал вот тут в своем блоге: http://webors.in.ua/sp-page-builder-konflikt-vsplyivayushhih-okon-s-animatsiey-blokov/
Записан
Страниц: [1]   Вверх
  Добавить закладку  |  Печать  
 
Перейти в:  

Powered by SMF 1.1.21 | SMF © 2006, Simple Machines

Joomlaforum.ru is not affiliated with or endorsed by the Joomla! Project or Open Source Matters.
The Joomla! name and logo is used under a limited license granted by Open Source Matters
the trademark holder in the United States and other countries.

LiveInternet