Форум русской поддержки Joomla!® CMS
06.12.2016, 22:01:09 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
   
   Начало   Поиск Joomla 3.0 FAQ Joomla 2.5 FAQ Joomla 1.5 FAQ Правила форума Новости Joomla Реклама Войти Регистрация Помощь  
Страниц: [1]   Вниз
  Добавить закладку  |  Печать  
Автор

Странности Joomla 1.5

 (Прочитано 377 раз)
0 Пользователей и 1 Гость смотрят эту тему.
abrodski
Осваиваюсь на форуме
***

Репутация: +0/-0
Offline Offline

Сообщений: 74


« : 12.10.2015, 07:18:47 »

Здравствуйте,

У меня возникла странная проблема. Собственно, их две. Одна -- решаемая, а вторую я сам не могу осилить. Но может быть это как то связано...
Проблема № 1:
Для того, чтобы в админке сохранить что либо надо кликнуть 2-3 раза. С первого раза, чаще всего, ничего не меняется.
Проблема № 2:
У меня стоит VirtueMart 1.1
Там есть способ оплаты ROBOKASSA
Там вообще непонятно что происходит. Там где надо ввести пароль и т.д., вместо этого какая то ерунда сама откуда то берется (похоже на PHP код).
Типа <  ? ECHO и т.д. >
Это же система сама автоматом прописывает и в соответствующем конфигурационном файле PHP.
Само собой, что в магазине оплата при помощи системы ROBOKASSA не работает (там вместо ссылки на интерфейс Робокассы, я получаю PHP-шный текст, состоящий из разных параметров.
Записан
Arkadiy
Группа развития
*****

Репутация: +431/-0
Offline Offline

Пол: Мужской
Сообщений: 5315


Крепитесь, други.


« Ответ #1 : 12.10.2015, 09:05:02 »

Возможно дело в коротких открывающих тэгах, их многие хостинги не поддерживают, попробуйте все вхождения <? заменить на <?php
Записан
abrodski
Осваиваюсь на форуме
***

Репутация: +0/-0
Offline Offline

Сообщений: 74


« Ответ #2 : 12.10.2015, 22:50:35 »

Спасибо за ответ!

Да нет, там вообще ничего не должно быть... И править вручную файл не требуется. Всё прописывается в админке.
Хостинг у меня свой в домашнем офисе. И почта, и DNS также.
Знаете, у меня что-то подозрение, что может старая Joomla не очень дружит с PHP 5.5, который у меня стоит на сервере?
Те симптомы, о которых я писал вначале, могут быть как-то с этим связаны?
Записан
evgen777
Завсегдатай
*****

Репутация: +62/-2
Offline Offline

Пол: Мужской
Сообщений: 691

skype:evgeniy8955 mail:office@sevweb.tk


« Ответ #3 : 12.10.2015, 22:53:18 »

Цитировать
не очень дружит с PHP 5.5
Какая необходимость в 5.5? Поставьте 5.3 или даже 5.2
Записан
abrodski
Осваиваюсь на форуме
***

Репутация: +0/-0
Offline Offline

Сообщений: 74


« Ответ #4 : 13.10.2015, 00:44:37 »

Ну, во-первых, когда я устанавливал LAMP в Ubuntu, то я вообще был не в курсе, что возможно у меня возникнет такая проблема.
Во-вторых, по умолчанию Ubuntu устанавливает новую версию PHP (5.5.9).
В третьих, т.к. она уже установлена, то мне не совсем ясно как это теперь безболезненно переиграть. Там ведь еще и связка с MySQL и Apache.
Я не спец в Линуксе, честно говоря. Поэтому я предпочитаю идти простым и проверенным путем (без лишних экспериментов).
Тут не форум по Линуксу. Может не всё так и драматично. Убрать PHP 5.5 и установить PHP 5.3
Не знаю, если всё равно время терять и силы, так может это лучше вложить в установку J2.5 с VirtueMart 2...?
Записан
voland
Профи
********

Репутация: +487/-86
Online Online

Пол: Мужской
Сообщений: 8712


любит наш народ всякое гавно...


« Ответ #5 : 13.10.2015, 00:50:35 »

На секунду, уже конец 2015 года.
Актуальна 3.4, 2.5 - старьё, ну про 1.5 все уже забыли когда успели её забыть.
Записан
abrodski
Осваиваюсь на форуме
***

Репутация: +0/-0
Offline Offline

Сообщений: 74


« Ответ #6 : 13.10.2015, 04:49:51 »

Короче говоря, я решил не искать черную кошку в темной комнате. Сделал upgrade сайта до версии Joomla 2.5.28 (последней в версии 2.5) при помощи JUpgrade'a. Нашел тот же шаблон, только под J2.5 и установил его. После этого установил VirtueMart 2.6.20 (последнюю версию второго Virtuemart'a). Буду, с Божьей помощью, осваивать всё это.
Да, видимо J1.5 -- это немного перебор, когда уже J3.5 не за горами..

voland Я с Вами могу согласиться по поводу J1.5, но не согласен про J2.5
Я вообще не пользуюсь версиями не LTS, так что, как минимум, до выхода 3.5, J2.5. еще супер актуальна!
И потом, даже когда она выйдет (3.5)... пока опробируют, пока баги исправят, пока видео уроки сделают... Еще года 2 пройдет (судя по VirtueMart 2).
Записан
voland
Профи
********

Репутация: +487/-86
Online Online

Пол: Мужской
Сообщений: 8712


любит наш народ всякое гавно...


« Ответ #7 : 13.10.2015, 11:43:20 »

3.5 не будет LTS, LTS больше не будет вообще.
Политика версий изменилась, теперь все они равноценны.
Записан
altvvc
Завсегдатай
*****

Репутация: +22/-0
Offline Offline

Пол: Мужской
Сообщений: 505



« Ответ #8 : 13.10.2015, 23:56:43 »

Сайт что в профиле работает на на РНР 5.5.22. Бд 5.5.42-MariaDB. Joomla старенькая полторашка. Вроде нет таких проблем как у вас.
Записан
abrodski
Осваиваюсь на форуме
***

Репутация: +0/-0
Offline Offline

Сообщений: 74


« Ответ #9 : 14.10.2015, 06:50:50 »

Сайт что в профиле работает на на РНР 5.5.22. Бд 5.5.42-MariaDB. Joomla старенькая полторашка. Вроде нет таких проблем как у вас.

У меня проблемы не с сайтом, а с модулем оплаты ROBOKASSA. Всё остальное настроил вполне нормально.
Думаю, что если сильно постараться -- и эта проблема решаема так или иначе. Но я для себя решил попробовать всё же перейти на более новые версии. Тем паче, что Joomla 2.5 и VirtueMart 2 уже, мягко говоря, не сырые беты.
Записан
Страниц: [1]   Вверх
  Добавить закладку  |  Печать  
 
Перейти в:  

Powered by SMF 1.1.21 | SMF © 2006, Simple Machines

Joomlaforum.ru is not affiliated with or endorsed by the Joomla! Project or Open Source Matters.
The Joomla! name and logo is used under a limited license granted by Open Source Matters
the trademark holder in the United States and other countries.

LiveInternet