Форум русской поддержки Joomla!® CMS
10.12.2016, 05:10:48 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
   
   Начало   Поиск Joomla 3.0 FAQ Joomla 2.5 FAQ Joomla 1.5 FAQ Правила форума Новости Joomla Реклама Войти Регистрация Помощь  
Страниц: [1]   Вниз
  Добавить закладку  |  Печать  
Автор

При отправке сообщения через плагин - сообщения приходят два раза

 (Прочитано 293 раз)
0 Пользователей и 1 Гость смотрят эту тему.
Sergey2
Завсегдатай
*****

Репутация: +15/-1
Offline Offline

Сообщений: 660


« : 14.10.2015, 14:55:35 »

На сайте стоит CommunityBuilder (или как там правильно). В нем установлен плагин для отправки сообщения пользователю из его профиля  (Private Message System). Если отправлять сообщения через этот плагин -  получаются дубли. Если через uddeIM отправлять - все нормально. В логах вот что:

Код:
193.201.227.199 - - [13/Oct/2015:20:32:31 +0300] "POST /profile/pluginclass?plugin=pms.mypmspro&id=151 HTTP/1.0" 303 0 "/profile/userprofile/admin" "Mozilla/5.0 (Windows NT 10.0; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0"
193.201.227.199 - - [13/Oct/2015:20:32:32 +0300] "GET /profile/userprofile/admin?tab=getmypmsproTab HTTP/1.0" 200 128607 "/profile/userprofile/admin?tab=getmypmsproTab" "Mozilla/5.0 (Windows NT 10.0; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0"
то есть я так понимаю - происходит отправка сообщения через плагин, но в ответ вместо кода 200, что все ОК, выдается код 303, на сам uddeIM, который еще раз шлет сообщения. Как это пофиксить?
Записан
Страниц: [1]   Вверх
  Добавить закладку  |  Печать  
 
Перейти в:  

Powered by SMF 1.1.21 | SMF © 2006, Simple Machines

Joomlaforum.ru is not affiliated with or endorsed by the Joomla! Project or Open Source Matters.
The Joomla! name and logo is used under a limited license granted by Open Source Matters
the trademark holder in the United States and other countries.

LiveInternet