Форум русской поддержки Joomla!® CMS
11.12.2016, 10:10:38 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
   
   Начало   Поиск Joomla 3.0 FAQ Joomla 2.5 FAQ Joomla 1.5 FAQ Правила форума Новости Joomla Реклама Войти Регистрация Помощь  
Страниц: [1]   Вниз
  Добавить закладку  |  Печать  
Автор

JCE - неработающая панель управления с синим прогрессбаром

 (Прочитано 478 раз)
0 Пользователей и 1 Гость смотрят эту тему.
Vzx
Захожу иногда
**

Репутация: +3/-0
Offline Offline

Пол: Мужской
Сообщений: 19


« : 09.01.2016, 00:23:04 »

В связи с миграцией на J!3.4.8 обновил JCE до актуальной версии (пробовал 2.5.12 и 2.4.6).
В итоге в админке панель управления JCE открывается, но при переходе в любой из разделов "Общие настройки", "Профили редактора" или "Установка дополнений" отображается страница с синей полосой "Загрузка" и на этом всё заканчивается (см. картинку).
Показать текстовый блок
Отключил уже все посторонние модули-компоненты с id от 10000, но это не помогло.
Шаблон админки - стандартный Isis.

Может, кто-то уже сталкивался с подобным и успешно поборол?

P.S. Тестируется всё на локалхосте под WampServer'ом, если это имеет значение.
Записан
Vzx
Захожу иногда
**

Репутация: +3/-0
Offline Offline

Пол: Мужской
Сообщений: 19


« Ответ #1 : 09.01.2016, 13:18:43 »

Немного свежей информации о данной проблеме.
В то время, когда наблюдаем синий бар, в консоли JS фиксируются ошибки, связанные со стандартным скриптом "\media\system\js\mootools-more.js".
Например:
SyntaxError: missing } after property list1 mootools-more.js:7043:32
При просмотре исходника через консоль Firefox (view-source:http://site2/media/system/js/mootools-more.js), виден фрагмент кода с подсвеченной строкой:
Показать текстовый блок
Однако если открыть непосредственно сам файл, то там в этой части кода содержимое другое:
Показать текстовый блок
И самое непонятное (для меня) то, что если немного модифицировать исходник скрипта (отбить табами, например), потом почистить кэш и перезагрузить страницу, то всё может великолепно заработать. Но после следующей чистки кэша/обновления страницы -- уже снова ошибка с "подменой" кода.

Кто-нибудь может прояснить, что происходит такое? Нормально ли, что будто происходит замена кода?

Рядом на виртуальном хосте поднял 3.4.8 "с нуля" из дистрибутива и установил JCE -- такая же ерунда…
Записан
Vzx
Захожу иногда
**

Репутация: +3/-0
Offline Offline

Пол: Мужской
Сообщений: 19


« Ответ #2 : 09.01.2016, 15:04:43 »

Похоже, что проблема разрешилась. Smiley
Установил FireBug, через него вышел на скрипт main.js, который был инъектирован в код сайта и принадлежал Kaspersky Internet Security.
Отключение защиты через настройки Касперского на этот скрипт не повлияло. Помогла только полная выгрузка программы.
В итоге ошибки пропали, всё заработало нормально. У меня не самая актуальная версия Касперского, возможно, в более новых проблема отсутствует.
Проверил на JCE 2.4.6, потом обновил до 2.5.12 -- всё в порядке.
Надеюсь, этот опыт кому-нибудь в будущем пригодится! drink
Записан
Страниц: [1]   Вверх
  Добавить закладку  |  Печать  
 
Перейти в:  

Powered by SMF 1.1.21 | SMF © 2006, Simple Machines

Joomlaforum.ru is not affiliated with or endorsed by the Joomla! Project or Open Source Matters.
The Joomla! name and logo is used under a limited license granted by Open Source Matters
the trademark holder in the United States and other countries.

LiveInternet