Дублируем модуль html-код (дубликат не появляется при создании нового модуля)

  • 4 Ответов
  • 414 Просмотров

0 Пользователей и 1 Гость просматривают эту тему.

*

Оффлайн goga_pgasovav

  • ***
  • 182
  • [+]0 / [-]0
  • Внимательный джумловод
    • Просмотр профиля
Понадобилось дублировать стандартный модуль для вывода HTML-кода.
Скопировал папку, всё и везде переименовал (вместо mod_custom – mod_mymod).
Установка проходит успешно. Плагин опубликован. Но при попытке создать новый модуль такого типа я просто не нахожу его название в списке доступных модулей.
Собственно вопрос: что нужно сделать, чтобы можно было создавать модули такого типа?

*

Оффлайн Shustry

  • *****
  • 6707
  • [+]736 / [-]3
  • Рисую дизайны
    • Просмотр профиля
    • Примеры работ
А просто альтернативный шаблон создать не проще было?
Бесплатно консультирую по дизайну и вёрстке (только в icq и личку сердечно прошу не стучать). Платно делаю дизайн, вёрстку и темплейты для Joomla. Работаю только за деньги. За большие. И долго. Но качественно.
---------------------------------------------------------
xmpp:joomla@conference.jabber.ru - наша конфа!

*

Оффлайн goga_pgasovav

  • ***
  • 182
  • [+]0 / [-]0
  • Внимательный джумловод
    • Просмотр профиля
Shustry, да я туда несколько доп. полей добавил, а они немного раздражают, когда модуль применяется в других сферах...

*

Онлайн dmitry_stas

признаться, именно mod_custom ни разу не переделывал, но чисто технически - не вижу, чтобы он чем то отличался от любых других модулей. соответственно, вероятно все таки что-то не изменили
Тут дарят бакс просто за регистрацию! Успей получить!
Все советы на форуме раздаю бесплатно, то есть даром. Индивидуально бесплатно консультирую только по вопросам стоимости индивидуальных консультаций

*

Оффлайн goga_pgasovav

  • ***
  • 182
  • [+]0 / [-]0
  • Внимательный джумловод
    • Просмотр профиля
признаться, именно mod_custom ни разу не переделывал, но чисто технически - не вижу, чтобы он чем то отличался от любых других модулей. соответственно, вероятно все таки что-то не изменили

Попробую ещё раз внимательно все файлы пересмотреть... Просто подумал, вдруг что-то надо дополнительно.
Я скопировал mod_custom из уже установленной Joomla, подкорректировал файлики и упаковал в zip.
Его и устанавливаю.