Форум русской поддержки Joomla!® CMS
11.12.2016, 06:10:51 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
   
   Начало   Поиск Joomla 3.0 FAQ Joomla 2.5 FAQ Joomla 1.5 FAQ Правила форума Новости Joomla Реклама Войти Регистрация Помощь  
Страниц: [1]   Вниз
  Добавить закладку  |  Печать  
Автор

Fatal error: Class 'Joomla\String\Stringer' not found как её устранить?

 (Прочитано 333 раз)
0 Пользователей и 1 Гость смотрят эту тему.
emilt612
Новичок
*

Репутация: +0/-0
Offline Offline

Сообщений: 2


« : 05.05.2016, 22:26:06 »

Помогите устранить данную ошибку.
Fatal error: Class 'Joomla\String\StringHelper' not found in W:\home\localhost\www\City-center\language\ru-RU\ru-RU.localise.php on line 565

Когда добавляю новый материал на английской версии, никаких ошибок не выводит. Данная ошибка появляется при добавлении материала на русской  версии.
Записан
SmokerMan
Профи
********

Репутация: +694/-25
Offline Offline

Пол: Мужской
Сообщений: 5225



« Ответ #1 : 06.05.2016, 00:41:06 »

локализацию не пробовали обновить?
Записан
voland
Профи
********

Репутация: +488/-86
Offline Offline

Пол: Мужской
Сообщений: 8736


любит наш народ всякое гавно...


« Ответ #2 : 06.05.2016, 02:08:03 »

версии движка, локализации и PHP какие?
Записан
Arkadiy
Группа развития
*****

Репутация: +432/-0
Offline Offline

Пол: Мужской
Сообщений: 5317


Крепитесь, други.


« Ответ #3 : 06.05.2016, 06:46:13 »

StringHelper появился в 3.5 или 3.5.1 для совместимости с php 7 (старый класс String попал в зарезервированные имена). Если у вас Joomla ниже чем эти версии, а язык установили самый свежий - это неправильное решение.
Записан
emilt612
Новичок
*

Репутация: +0/-0
Offline Offline

Сообщений: 2


« Ответ #4 : 06.05.2016, 18:37:13 »

StringHelper появился в 3.5 или 3.5.1 для совместимости с php 7 (старый класс String попал в зарезервированные имена). Если у вас Joomla ниже чем эти версии, а язык установили самый свежий - это неправильное решение.

Да, Вы правы. У меня стоит версия 3.4.5. Так как быть, обновить до 3.5.1?
Записан
SmokerMan
Профи
********

Репутация: +694/-25
Offline Offline

Пол: Мужской
Сообщений: 5225



« Ответ #5 : 07.05.2016, 04:35:35 »

Да, Вы правы. У меня стоит версия 3.4.5. Так как быть, обновить до 3.5.1?
нужно обновить
Записан
Страниц: [1]   Вверх
  Добавить закладку  |  Печать  
 
Перейти в:  

Powered by SMF 1.1.21 | SMF © 2006, Simple Machines

Joomlaforum.ru is not affiliated with or endorsed by the Joomla! Project or Open Source Matters.
The Joomla! name and logo is used under a limited license granted by Open Source Matters
the trademark holder in the United States and other countries.

LiveInternet