После обновления до версии VirtueMart 3.0.x пропали картинки

  • 13 Ответов
  • 509 Просмотров

0 Пользователей и 1 Гость просматривают эту тему.

*

Оффлайн fred

  • ***
  • 135
  • [+]13 / [-]0
  • Прошлое лишено смысла
    • Просмотр профиля
    • fred-design
После обновления до версии VirtueMart 3.0.x пропали картинки у всех модулей, в чем может быть проблема, подскажите?
В самом каталоге в товарах есть, а вот у модулей VirtueMart нету ни одной картинки, что в категорий что в товарах
спасибо
Прошлое лишено смысла

*

Оффлайн fred

  • ***
  • 135
  • [+]13 / [-]0
  • Прошлое лишено смысла
    • Просмотр профиля
    • fred-design
так же не отображаются дополнительные картинки в товара, пишет просто "thumb", но когда нажимаешь то есть картинки большая
подскажите как исправить( в версии 3.0.6 все было нормально а обновил до 3.0.18 и вот так вот случилось
Прошлое лишено смысла

*

Оффлайн fred

  • ***
  • 135
  • [+]13 / [-]0
  • Прошлое лишено смысла
    • Просмотр профиля
    • fred-design
Подскажите народ хоть где смотреть то
Прошлое лишено смысла

*

Оффлайн fsv

Подскажите народ хоть где смотреть то
путь к картинке
Заказать разработку:    расширения Joomla  |   интерфейсы на javascript(jQuery)  |  мобильные приложения

*

Оффлайн fred

  • ***
  • 135
  • [+]13 / [-]0
  • Прошлое лишено смысла
    • Просмотр профиля
    • fred-design
путь к картинке
вот главная допустим, у всех модулей нету картинок http://venger.fred.com.ua/
а вот каталог http://venger.fred.com.ua/index.php/shop-store тут все картинки присутсвуют
так же нету доп картинок в товара http://venger.fred.com.ua/index.php/shop-store/watches/lorem-ipsum-dolor-1-detail
пробовал уже несколько раз ставить, и разные шаблоны, все так же, при обновлении магазина до версии 3.0.18 точно такая же беда
Прошлое лишено смысла

*

Оффлайн fsv

вот главная допустим, у всех модулей нету картинок
Потому что там путь к картинке - "/".
Открыть модуль и посмотреть код, формирующий картинку, это сложно?
Заказать разработку:    расширения Joomla  |   интерфейсы на javascript(jQuery)  |  мобильные приложения

*

Оффлайн fred

  • ***
  • 135
  • [+]13 / [-]0
  • Прошлое лишено смысла
    • Просмотр профиля
    • fred-design
Потому что там путь к картинке - "/".
Открыть модуль и посмотреть код, формирующий картинку, это сложно?
Подскажите где рыть, ато я сам дизайнер, в коде не очень разбираюсь
Спасибо
Прошлое лишено смысла

*

Оффлайн SeBun

Попробуйте открыть карточку товара и сохранить ее.
Оказываю услуги по Joomla | Миграция на Joomla 3.x | Администрирование
Ник занят | По личным вопросам не консультирую

*

Оффлайн fred

  • ***
  • 135
  • [+]13 / [-]0
  • Прошлое лишено смысла
    • Просмотр профиля
    • fred-design
Попробуйте открыть карточку товара и сохранить ее.
пробовал, даже пробовал перезаливать картинку в товаре, ниче не помогло
Прошлое лишено смысла

*

Оффлайн SeBun

пробовал, даже пробовал перезаливать картинку в товаре, ниче не помогло
Да нет, перезаливать нет смысла, проблема там со сбившимися путями. Я когда проводил миграцию этого компонента, сталкивался с похожей проблемой. Вроде все на месте, но картинок нет. Детально не разбирался, просто пересохранил все карточки товара, и вопрос решился. Вам нужно выяснить причину такого поведения. Попробуйте создать новый товар и посмотрите, будут ли картинки. Если нет - проблема либо в путях, либо даже затрудняюсь с ходу сказать, в чем. Если картинки будут, лезем в базу данных и смотрим, чем отличается созданная запись от предыдущей (образно, там несколько связанных таблиц).
Оказываю услуги по Joomla | Миграция на Joomla 3.x | Администрирование
Ник занят | По личным вопросам не консультирую

*

Оффлайн fred

  • ***
  • 135
  • [+]13 / [-]0
  • Прошлое лишено смысла
    • Просмотр профиля
    • fred-design
Да нет, перезаливать нет смысла, проблема там со сбившимися путями. Я когда проводил миграцию этого компонента, сталкивался с похожей проблемой. Вроде все на месте, но картинок нет. Детально не разбирался, просто пересохранил все карточки товара, и вопрос решился. Вам нужно выяснить причину такого поведения. Попробуйте создать новый товар и посмотрите, будут ли картинки. Если нет - проблема либо в путях, либо даже затрудняюсь с ходу сказать, в чем. Если картинки будут, лезем в базу данных и смотрим, чем отличается созданная запись от предыдущей (образно, там несколько связанных таблиц).
Создал новый и ничего не получилось
Прошлое лишено смысла

*

Оффлайн SeBun

Создал новый и ничего не получилось
Ну значит включайте отображение ошибок, смотрите логи. Либо у вас что то с базой (допустим, нет каких то таблиц), либо проблема в настройках (пути и т.д.). Как вариант, можно поставить на локалку VM 3, перенести папки изображений и попробовать сделать импорт базы из бекапа. Сразу увидите, где у вас расхождения.
Оказываю услуги по Joomla | Миграция на Joomla 3.x | Администрирование
Ник занят | По личным вопросам не консультирую

*

Оффлайн fred

  • ***
  • 135
  • [+]13 / [-]0
  • Прошлое лишено смысла
    • Просмотр профиля
    • fred-design
Это скорей всего что то с модулями, но как исправить я не знаю(
Прошлое лишено смысла

*

Оффлайн fred

  • ***
  • 135
  • [+]13 / [-]0
  • Прошлое лишено смысла
    • Просмотр профиля
    • fred-design
народ подскажите где исправить данную проблему((
Прошлое лишено смысла