Форум русской поддержки Joomla!® CMS
08.12.2016, 04:17:34 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
   
   Начало   Поиск Joomla 3.0 FAQ Joomla 2.5 FAQ Joomla 1.5 FAQ Правила форума Новости Joomla Реклама Войти Регистрация Помощь  
Страниц: [1]   Вниз
  Добавить закладку  |  Печать  
Автор

В Денвере ошибка при установки шаблона Joomla

 (Прочитано 150 раз)
0 Пользователей и 1 Гость смотрят эту тему.
vitalkun
Новичок
*

Репутация: +0/-0
Offline Offline

Сообщений: 8


« : 06.11.2016, 13:43:35 »

Может кто знает как настроить или исправить проблему!  Angry
После загрузки шаблона в Joomla, при дополнений шаблона демо-данными (модулями шаблона) "Install Sample Data".

Выскакивает сообщение:

"This feature requires openssl extension for php in order to work. Please enable openssl extension using php.ini or contact your server administrator for detail."

Кто подскажет, как мне загрузить демо-данные ?
Записан
KKAAZZOO
Практически профи
*******

Репутация: +102/-9
Offline Offline

Сообщений: 2087


« Ответ #1 : 06.11.2016, 13:51:22 »

Что такое Денвер?
Записан
vitalkun
Новичок
*

Репутация: +0/-0
Offline Offline

Сообщений: 8


« Ответ #2 : 06.11.2016, 13:58:31 »

Localhost
Записан
dmitry_stas
Профи
********

Репутация: +798/-4
Offline Offline

Сообщений: 7774



« Ответ #3 : 06.11.2016, 14:00:48 »

вы не можете перевести текст ошибки? там все четко описано, почему это происходит, и что нужно сделать
Записан
Lemady
Осваиваюсь на форуме
***

Репутация: +3/-0
Offline Offline

Пол: Женский
Сообщений: 60



« Ответ #4 : 06.11.2016, 14:29:24 »

Кто подскажет, как мне загрузить демо-данные ?

Эта функция для работы требует расширения OpenSSL для PHP. Пожалуйста, включите расширение OpenSSL с помощью php.ini или обратитесь к администратору сервера.

Что такое Денвер?
Любовь некрофила. Угадала?
Записан
vitalkun
Новичок
*

Репутация: +0/-0
Offline Offline

Сообщений: 8


« Ответ #5 : 06.11.2016, 14:52:22 »

а как его включить! Я установил модуль PHP 5.5 в LocalServer. но это не помогло. А как включить расширения OpenSSL не понимаю!
Записан
Lemady
Осваиваюсь на форуме
***

Репутация: +3/-0
Offline Offline

Пол: Женский
Сообщений: 60



« Ответ #6 : 06.11.2016, 14:57:12 »

А как включить расширения OpenSSL не понимаю!
в php.ini раскомментировать строчку
;extension=php_openssl.dll
Записан
vitalkun
Новичок
*

Репутация: +0/-0
Offline Offline

Сообщений: 8


« Ответ #7 : 06.11.2016, 15:02:54 »

что нужно изменить в этой строчке? как её расскоментировать ?
Записан
SeBun
Практически профи
*******

Репутация: +134/-3
Offline Offline

Пол: Мужской
Сообщений: 2286



« Ответ #8 : 06.11.2016, 15:15:12 »

что нужно изменить в этой строчке? как её расскоментировать ?
Убрать перед строкой точку с запятой - ;
Но это справедливо, если у вас стоит php_openssl.dll, иначе получите ошибку. Я не знаю, есть ли эта библиотека в денвере, т.к. там старые расширения. Если вы сами поставили PHP 5.5, то эта библиотека должна быть в комплекте.
« Последнее редактирование: 06.11.2016, 15:20:19 от SeBun » Записан
vitalkun
Новичок
*

Репутация: +0/-0
Offline Offline

Сообщений: 8


« Ответ #9 : 06.11.2016, 16:09:58 »

...
« Последнее редактирование: 06.11.2016, 16:17:48 от vitalkun » Записан
vitalkun
Новичок
*

Репутация: +0/-0
Offline Offline

Сообщений: 8


« Ответ #10 : 06.11.2016, 16:17:09 »

новая ошибка выскочила "Ваш хост должен использовать PHP 5.3.10 или выше, чтобы запустить эту версию Joomla!"
Записан
AlexeyGal
Давно я тут
****

Репутация: +25/-8
Offline Offline

Пол: Мужской
Сообщений: 259



« Ответ #11 : 06.11.2016, 16:25:35 »

не используй денвер, он устарел давным давно.
Joomla на нем работать не будет.
Записан
vitalkun
Новичок
*

Репутация: +0/-0
Offline Offline

Сообщений: 8


« Ответ #12 : 06.11.2016, 16:29:17 »

А что использовать ? !
Записан
AlexeyGal
Давно я тут
****

Репутация: +25/-8
Offline Offline

Пол: Мужской
Сообщений: 259



« Ответ #13 : 06.11.2016, 16:33:11 »

Вариантов много:
1. берешь apache, прикручиваешь к нему php и MySQL последних версий.
2. openserver http://open-server.ru
3. ставишь на виртуальную машину ubuntu server https://www.ubuntu.com/download/server
4. ставишь Linux и затем LAMP
Записан
vitalkun
Новичок
*

Репутация: +0/-0
Offline Offline

Сообщений: 8


« Ответ #14 : 06.11.2016, 19:31:43 »

Спасибо Вам за ответы!!
Записан
SeBun
Практически профи
*******

Репутация: +134/-3
Offline Offline

Пол: Мужской
Сообщений: 2286



« Ответ #15 : 07.11.2016, 01:00:37 »

2. openserver http://open-server.ru
vitalkun, вам подойдет пункт №2
Записан
Страниц: [1]   Вверх
  Добавить закладку  |  Печать  
 
Перейти в:  

Powered by SMF 1.1.21 | SMF © 2006, Simple Machines

Joomlaforum.ru is not affiliated with or endorsed by the Joomla! Project or Open Source Matters.
The Joomla! name and logo is used under a limited license granted by Open Source Matters
the trademark holder in the United States and other countries.

LiveInternet