Smart Search Zoo не работает

  • 1 Ответов
  • 249 Просмотров

0 Пользователей и 1 Гость просматривают эту тему.

*

Оффлайн newvideo

Smart Search Zoo не работает
« : 07.01.2017, 22:29:49 »
Я пошел по пути "умного" поиска. Настроил модуль умного поиска, включил стандартные плагины, включил плагин Smart Search Zoo.
Выбрал я его за возможность добавить фильтр, который настраивается в Joomla>Компонент>Умный поиск>Фильтры поиска>Создать и о чудо, там есть каталоги Zoo при чем без деления на Приложения, т.е. все категории.

Результат выводится даже с выключенным плагином Smart Search Zoo.
А с включенным - никаких изменений. шаблон Smart Search не выводится.
НО Умный поиск Joomla выводит список найденных материалов Zoo просто списком без номеров, дат и любых полей, только заголовок в виде ссылки.

Простой поиск работает: Заполняем шаблон Search полями "Анонс" и "Картинка".
Нажимаем поиск в модуле Поиск (не умный, а простой).
В итоге отображается содержимого текстового анонса, но без элемента Image. Также тут в поиске отображается:
 "Порядковый номер", "титл-ссылка", "Дата создания" - но они формируются то ли компонентом поиска, то ли плагином, потому что в шаблоне я их не создавал.
Даты отключаются в общих настройках поиска Joomla. А вот порядковый номер и титл-ссылка скрыты где-то внутри PHP.

Кто-нибудь разобрался с этим плагином? Как его подключить? Спасибо!
----------------------------------------------------
Joomla: 3.6.0 | Zoo: 3.3.23
« Последнее редактирование: 09.01.2017, 22:42:49 от newvideo »
кто не работает, тот ест

*

Оффлайн newvideo

Re: Smart Search Zoo не работает
« Ответ #1 : 09.01.2017, 16:42:03 »
На официальном сайте от YooTheme несколько вопросов по этому плагину, но саппорт упорно молчит. Также замечены проблемы у некоторых пользователей при поиске импортных данных. Похоже проблема совместимости Smart Search Zoo с Joomla 3. В одном ответе техподдержка рекомендовала платный filter от ZooLanders.

Прописал в файле плагина абракадабру. Ошибок нет. Поиск работает как обычно. Похоже, что плагин вообще не подключен к Joomla.

Ошибка появилась спустя время, когда я добавил статью. Плагин имеет функцию автодобавления в индекс, чтобы не индексировать каждый раз всю базу.

Получается, что плагин работает только как автоиндекс, а при выдаче поиска не принимает участия.
« Последнее редактирование: 09.01.2017, 18:38:00 от newvideo »
кто не работает, тот ест