Форум русской поддержки Joomla!® CMS
17.08.2017, 03:43:58 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
   
   Начало   Поиск Joomla 3.0 FAQ Joomla 2.5 FAQ Joomla 1.5 FAQ Правила форума Новости Joomla Реклама Войти Регистрация Помощь  
Основной курс по Joomla
Страниц: [1]   Вниз
  Добавить закладку  |  Печать  
Автор

Не получается установить стандартную кап

 (Прочитано 79 раз)
0 Пользователей и 1 Гость смотрят эту тему.
phpCoder
Новичок
*

Репутация: +0/-0
Offline Offline

Сообщений: 9


« : 07.02.2017, 16:02:13 »

Написал свой компонент. В нем есть форма для отправки сообщения с сайта. Хочу добавить в эту форму стандартную капчу.

1. Включил плагин.
2. Прописал в нем необходимые ключи с Google.
3. В XML файле с описанием формы добавил

Код:
<field name="captcha" type="captcha" validate="captcha"
           label="COM_CONTACT_CAPTCHA_LABEL"
           description="COM_CONTACT_CAPTCHA_DESC" >
</field>

4. В блок head в шаблоне добавил <script src='https://www.google.com/recaptcha/api.js'></script>
5. В общих настройках тоже включил.

Капча появляется и вроде как проходит проверка(по крайней мере после выбора нужных изображений, появляется зеленая галочка). Но после отправки формы в момент ее валидации выкидывает ошибку:
TPL_WHITESQUARE_ERROR
0 No transport driver available.

Подскажите, в чем может быть дело? Что я делаю не так?

Нужно ли писать свой обработчик проверки правильности заполнения CAPTCHA на стороне сервера(в XML файле прописано validate="captcha"), или этот обработчик штатный?
Записан
Страниц: [1]   Вверх
  Добавить закладку  |  Печать  
 
Перейти в:  

Powered by SMF 1.1.21 | SMF © 2006, Simple Machines

Joomlaforum.ru is not affiliated with or endorsed by the Joomla! Project or Open Source Matters.
The Joomla! name and logo is used under a limited license granted by Open Source Matters
the trademark holder in the United States and other countries.

LiveInternet