Проблема при переезде на https

  • 4 Ответов
  • 183 Просмотров

0 Пользователей и 1 Гость просматривают эту тему.

Коллеги, помогите решить проблему!

Перевожу сайт на https.
После выполнения всех рекомендаций с настройками в configuration.php и .htaccess (https://alex-kurteev.ru/blog/full/1342-osobennosti-ustanovki-ssl-sertifikata-na-joomla.html) протокол установился, ошибок не выдает. Но уехали стили!
Нашел, что в 2-х файлах шаблона (Zoka от Shape5) vertex/compression/top_css_and_js_compression.php и vertex/compression/bottom_css_and_js_compression.php прописан http://.
Сделал просто //.
Стили вернулись, но пропали выпадающий список в Главном меню и содержимое модуля с отзывами, и в табах немножко текст съехал. Вообщем вот пациент https://vega-impex.com

Подскажите, где и что теперь надо доделать?! Может кто сталкивался с подобным?
« Последнее редактирование: 01.04.2017, 17:29:31 от pilgrim_ua »


Re: Проблема при переезде на https
« Ответ #2 : 01.04.2017, 22:07:05 »
Выпадающий список у меня работает ваш. Если бы на оригинал глянуть, как было еще.

Спасибо за отклик!

Да, уже работает. Нашел на форуме давнее обсуждение и воспользовался одним из советов.
После реализации этого совета http://joomlaforum.ru/index.php/topic,318327.msg1585420.html#msg1585420 заработало.
Вообщем, вот что мне помогло https://github.com/joomla/joomla-cms/pull/7902/files
Правда теперь на http иконки пропали, но это уже не критично.

*

Оффлайн flat

Re: Проблема при переезде на https
« Ответ #3 : 04.04.2017, 13:31:46 »
что бы тем не плодить.
Тоже проблема с SSL.
Пристегнул SSL к домену. В .htaccess добавил код (выдан хостером)
RewriteEngine On
RewriteCond %{SERVER_PORT} !^443$
RewriteCond %{HTTPS} off
RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1 [R=301,L]

В Joomle включил SSL.
Теперь при входе в админку вижу что соединение защищено, а вот на самом сайте нет. Куда копать?

Re: Проблема при переезде на https
« Ответ #4 : 04.04.2017, 17:24:51 »
В консоль браузера Ctrl+Shift+I смотреть