Форум русской поддержки Joomla!® CMS
17.08.2017, 23:25:12 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
   
   Начало   Поиск Joomla 3.0 FAQ Joomla 2.5 FAQ Joomla 1.5 FAQ Правила форума Новости Joomla Реклама Войти Регистрация Помощь  
Основной курс по Joomla
Страниц: [1]   Вниз
  Добавить закладку  |  Печать  
Автор

Joomla 3, Wamp и ImageMagick

 (Прочитано 96 раз)
0 Пользователей и 1 Гость смотрят эту тему.
mickymouse
Осваиваюсь на форуме
***

Репутация: +8/-1
Offline Offline

Пол: Мужской
Сообщений: 123


Ушел в нирвану буду скоро!


« : 31.05.2017, 14:02:18 »

Немного лирики, стоит у меня windows server 2008, на котором крутился Wamp 2.2, со старым пхм, всё работало но тормазило на Joomla 3 (ресурс ещё работал с ветки 1.5~2). Так как это продолжаться больше не могло, всё таки php 7 уже давно тут, а после последних обновлений алерт окошко о окончание поддержки старых версий PHP, решился на обновление Wamp сервера до последней версии с поддержкой php 7.0.10. Вспоминая свои предыдущие грабли (когда речь шла о переносе сайта с 1.5 до 2 ветки, а затем до 3) сделал два бекапа, один с помощью phpMyAdmin второй средствами Akeeba Backup. Всю инфу брал с инета, форумов и тд и тп. Сделал бекапы wampa (на всякий случай). Затем снёс старый wamp так как обновить по верх не получиться ))))) Поставил новый Wamp, и как ожидал начались игры с бубном, (основная проблема это не проставлялся процесс апача, и не запускался) с процессом Мускула проблем не было. В инете инфы много, но немного другая специфика но суть одна. Р) Вообщем седых волос стало немного больше но решение нашёл, с нёс для начала все до этого проставленные Microsoft Visual  C++ Redistributable, скачал и проставил новые и для своей платформы (x86). Ура сервер поднялся,  немного по колдовал с настройками апача и PHP, что бы Joomla чувствовала себя хорошо )))) Немногу тупанул с настройками виртуальный хостов, так как в новых версиях wampa это происходит по другому. Вроде всё чики пуки, всё должно работать но, вот тут меня ждал обломс когда я начал через пхпмайадмин из бекапа восстанавливать базу, всё вроде хорошо но таймауту он меня выкидывл (есть фишка что можно продолжить восстанавливать базу с места где настиг его таймаут, но тут опять облом, пока он просчитает то количество знаков с которых надо продолжить восстанавливать, наступит следующий таймаут), так как знаний у меня с гулькин нос и сделать через телнет прямой запрос не хватает знаний, решил закончить попытки вытащить из sql фаилика бекап. Обратился ко второму бекапу, сразу оговорюсь тут всё прошло на ура. с пол пинка, главное понять что от тебя просят ))))) Всё заработало, радуюсь как ребёнок, но есть одно но, то с чем я ещё не разобрался, поэтому прошу хелпа. Стоит у меня RSMediaGallery которому для работы необходим ImageMagick, на старой версии wampa не было больших проблем как его поставить, а вот на новой как то мудрённо. Может кто ткнёт в нормальный мануал или из практики по полочкам разложит, что где когда, пока что максимум достиг ошибок в PHP логах  Unable to load dynamic library 'D:/wamp/bin/php/php7.0.10/ext/php_imagick.dll' 0 The specified module could not be found. on line 0

Заранее благодарен за дельные советы!
Записан
Страниц: [1]   Вверх
  Добавить закладку  |  Печать  
 
Перейти в:  

Powered by SMF 1.1.21 | SMF © 2006, Simple Machines

Joomlaforum.ru is not affiliated with or endorsed by the Joomla! Project or Open Source Matters.
The Joomla! name and logo is used under a limited license granted by Open Source Matters
the trademark holder in the United States and other countries.

LiveInternet