Форум русской поддержки Joomla!® CMS
26.06.2017, 07:47:36 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
   
   Начало   Поиск Joomla 3.0 FAQ Joomla 2.5 FAQ Joomla 1.5 FAQ Правила форума Новости Joomla Реклама Войти Регистрация Помощь  
Страниц: [1]   Вниз
  Добавить закладку  |  Печать  
Автор

Проблема с PHP 7 7.1

 (Прочитано 154 раз)
0 Пользователей и 1 Гость смотрят эту тему.
lexxbry
Осваиваюсь на форуме
***

Репутация: +5/-0
Offline Offline

Пол: Мужской
Сообщений: 110



« : 19.06.2017, 11:12:44 »

есть сайт на J 2.5.28
на данный момент версия php 5.6

на этом же хостинге висит еще пара сайтов и там необходим php 7

при включении в админке хостинга php 7
все сайты на J 3.7 работают нормально

а вот сайт на J 2.5.28
выдает вот такое:

Database connection error (1): The MySQL adapter 'mysql' is not available.
Warning: session_write_close(): Cannot call session save handler in a recursive manner in /var/www/u******/data/www/***.ru/libraries/joomla/session/session.php on line 681

Warning: session_write_close(): Failed to write session data using user defined save handler. (session.save_path: /tmp/u*****) in /var/www/u*******/data/www/******.ru/libraries/joomla/session/session.php on line 681


подскажите куда копнуть

код с 681 строкой из session.php
Код:
public function close()
{
session_write_close();
}
Записан
dlealudei
Новичок
*

Репутация: +1/-0
Offline Offline

Пол: Мужской
Сообщений: 5



« Ответ #1 : 19.06.2017, 11:22:47 »

В точно такой же ситуации мне пришлось заводить на хостинге новый аккаунт. На Joomla 2.5 оставил версию PHP - 5.4. Мой хостер объяснил, что иначе сделать не получится...
Записан
lexxbry
Осваиваюсь на форуме
***

Репутация: +5/-0
Offline Offline

Пол: Мужской
Сообщений: 110



« Ответ #2 : 19.06.2017, 11:24:24 »

В точно такой же ситуации мне пришлось заводить на хостинге новый аккаунт. На Joomla 2.5 оставил версию PHP - 5.4. Мой хостер объяснил, что иначе сделать не получится...
эх беда печаль
ну в принципе сайты с J3.7 они чисто тестовые
в дальнейшем будут переноситься
печально что придумать ничего нельзя
Записан
draff
Практически профи
*******

Репутация: +169/-5
Offline Offline

Пол: Мужской
Сообщений: 2769


step by step


« Ответ #3 : 19.06.2017, 11:43:25 »

Код:
public $dbtype = 'mysqli'
Не помогает ?
Записан
dmitry_stas
Профи
********

Репутация: +916/-6
Offline Offline

Сообщений: 9537



« Ответ #4 : 19.06.2017, 11:47:48 »

думается мне что это будет наверняка только первая из проблем. судя по описанию 2.5 под php7 совсем же не адаптирована, не только драйвер базы. хотя я откровенно говоря сам не пробовал поднять 2.5 на 7-ке, не было нужды. может и не все так печально, как пишут.
Записан
lexxbry
Осваиваюсь на форуме
***

Репутация: +5/-0
Offline Offline

Пол: Мужской
Сообщений: 110



« Ответ #5 : 19.06.2017, 11:58:18 »

Код:
public $dbtype = 'mysqli'
Не помогает ?
увы точно не поможет так как база не mysqli
а именно MySQL
Записан
lexxbry
Осваиваюсь на форуме
***

Репутация: +5/-0
Offline Offline

Пол: Мужской
Сообщений: 110



« Ответ #6 : 19.06.2017, 11:59:30 »

думается мне что это будет наверняка только первая из проблем. судя по описанию 2.5 под php7 совсем же не адаптирована, не только драйвер базы. хотя я откровенно говоря сам не пробовал поднять 2.5 на 7-ке, не было нужды. может и не все так печально, как пишут.
ну думаю попробую миграцию провести на 3.7
а там если получится то хорошо а если нет то и черт с ней
буду тестовые на другом гости гонять
Записан
draff
Практически профи
*******

Репутация: +169/-5
Offline Offline

Пол: Мужской
Сообщений: 2769


step by step


« Ответ #7 : 19.06.2017, 12:27:05 »

увы точно не поможет так как база не mysqli
а именно MySQL
Ну так тогда
Код:
public $dbtype = 'mysql'
Записан
lexxbry
Осваиваюсь на форуме
***

Репутация: +5/-0
Offline Offline

Пол: Мужской
Сообщений: 110



« Ответ #8 : 19.06.2017, 12:29:56 »

Ну так тогда
Код:
public $dbtype = 'mysql'
да так то оно и стоит
я ж говорю на 5.6 работает как надо
при переключении на 7 или 7.1 лес
Записан
yuri-it
Живу я здесь
******

Репутация: +40/-3
Offline Offline

Сообщений: 1064


« Ответ #9 : 19.06.2017, 12:41:54 »

да так то оно и стоит
я ж говорю на 5.6 работает как надо
при переключении на 7 или 7.1 лес
PHP 7 поддерживает только Joomla 3 версии.
Записан
lexxbry
Осваиваюсь на форуме
***

Репутация: +5/-0
Offline Offline

Пол: Мужской
Сообщений: 110



« Ответ #10 : 19.06.2017, 13:00:48 »

PHP 7 поддерживает только Joomla 3 версии.
да теперь то уже понятно..просто думал что где то сам накосячил
Записан
dmitry_stas
Профи
********

Репутация: +916/-6
Offline Offline

Сообщений: 9537



« Ответ #11 : 19.06.2017, 13:04:17 »

еще и не все 3 версии, а по-моему только после 3.6. хотя на более ранние обновляться в принципе смысла нет, если уже обновлять, то обновлять до последней на данный момент 3.7.2. так что можно пожелать удачи в этом нелегком бою Azn
Записан
lexxbry
Осваиваюсь на форуме
***

Репутация: +5/-0
Offline Offline

Пол: Мужской
Сообщений: 110



« Ответ #12 : 19.06.2017, 13:06:42 »

еще и не все 3 версии, а по-моему только после 3.6. хотя на более ранние обновляться в принципе смысла нет, если уже обновлять, то обновлять до последней на данный момент 3.7.2. так что можно пожелать удачи в этом нелегком бою Azn
ну удача не помешает
сегодня попробую копию перегнать с 2.5 на 3.7
получится-хорошо, а нет так нет будет жить на 2.5
Записан
Страниц: [1]   Вверх
  Добавить закладку  |  Печать  
 
Перейти в:  

Powered by SMF 1.1.21 | SMF © 2006, Simple Machines

Joomlaforum.ru is not affiliated with or endorsed by the Joomla! Project or Open Source Matters.
The Joomla! name and logo is used under a limited license granted by Open Source Matters
the trademark holder in the United States and other countries.

LiveInternet