Форум русской поддержки Joomla!® CMS
10.12.2016, 18:42:28 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
   
   Начало   Поиск Joomla 3.0 FAQ Joomla 2.5 FAQ Joomla 1.5 FAQ Правила форума Новости Joomla Реклама Войти Регистрация Помощь  
Голосование
Вопрос: Какая версия PHP установлена на вашем сайте (сервере хостера)?
PHP 4 (ниже 4.2.0) - 2 (1.1%)
PHP 4.2.x - 1 (0.5%)
PHP 4.3.x - 7 (3.7%)
PHP 4.4.x - 16 (8.5%)
PHP 5.x - 86 (45.7%)
PHP 5.0.x - 1 (0.5%)
PHP 5.1.x - 1 (0.5%)
PHP 5.2.x - 34 (18.1%)
PHP 5.3.x - 32 (17%)
PHP 5.4.x - 6 (3.2%)
PHP 6.x - 2 (1.1%)
Всего голосов: 151

Страниц: [1] 2 3  Все   Вниз
  Добавить закладку  |  Печать  
Автор

Какая версия PHP установлена на вашем сайте (сервере хостера)?

 (Прочитано 40771 раз)
0 Пользователей и 1 Гость смотрят эту тему.
smart
Администратор
*******

Репутация: +1308/-14
Offline Offline

Пол: Мужской
Сообщений: 6850


снова дома...


« : 13.06.2008, 13:08:14 »

Вот общались мы сейчас с boston'ом и возник вопрос, как много нынче используется PHP4, и стоит ли поддерживать эту версию в настоящее время, или уже пора переписывать все, на PHP5, что позволит повысить и скорость, и качество кода.

Официальная поддержка PHP 4 закончилась 31 декабря 2007 года, а обновления по безопасности для этой версии будут выпускаться только до 8 августа 2008 года. После этой даты, в принципе, можно говорить, что версия 4 уже ушла в прошлое. Многие хостеры еще прошлой осенью начали миграцию на PHP5, но как показывает практика еще не все перешли.

Посему и опрос... В параметрах опроса, я разрешил оставлять по 5 голосов на пользователя, на тот случай, если у вас несколько площадок, с разными параметрами.
Записан
 
Daglus
Осваиваюсь на форуме
***

Репутация: +6/-0
Offline Offline

Сообщений: 87


« Ответ #1 : 13.06.2008, 14:31:03 »

у меня на одном стоит     5.2.1 а на другом  5.2.6 )  почти везде где есть хостинг уже перевелись на 5-ю линейку
Записан
Physicist
Support Team
*****

Репутация: +185/-0
Offline Offline

Пол: Мужской
Сообщений: 962


Рябов Денис


« Ответ #2 : 13.06.2008, 14:36:31 »

Во многих случаях установлена как 4.4.x, так и 5.2.x, а выбрать нужную можно либо в панели управления аккаунтом, либо в .htaccess. Я стараюсь использовать PHP5 за исключением ситуаций, когда memory_limit сильно ограничен (до 32Мб, а порой и ниже; это не позволяет, например, сделать парсинг WURFL в PHP5), т.к. PHP5 требует примерно в два раза больше памяти, чем PHP4.
Записан
smart
Администратор
*******

Репутация: +1308/-14
Offline Offline

Пол: Мужской
Сообщений: 6850


снова дома...


« Ответ #3 : 20.06.2008, 17:10:29 »

Ребятки, уделите немного времени - оставьте свой голос, ну интересно же...
Записан
VETERINAR
Живу я здесь
******

Репутация: +165/-14
Offline Offline

Пол: Мужской
Сообщений: 868


Kiss my shiny metal ass!


« Ответ #4 : 23.06.2008, 12:28:04 »

Отличная тема. Я сам недавно задавался таким вопросом. Я считаю, что PHP 5 очень вкусный, в главную очередь, за счет улучшения ООП. Когда попробовал, уже не хочется ничего писать для PHP 4 Azn

На самом деле давно уже не видел хостера у которого версия PHP меньше 5-й. Думаю, что действительно нужно про неё забыть.
Записан
smart
Администратор
*******

Репутация: +1308/-14
Offline Offline

Пол: Мужской
Сообщений: 6850


снова дома...


« Ответ #5 : 23.06.2008, 12:30:11 »

PHP 5 очень вкусный, в главную очередь, за счет улучшения ООП
мало того, что вкусный, так еще зараза и быстрый... и конечно, намного более красивый и эффективный код в нем можно писать... поэтому и решил я устроить опрос...
Записан
Александр Фёдоров
Осваиваюсь на форуме
***

Репутация: +26/-4
Offline Offline

Пол: Мужской
Сообщений: 151


Жизнь - удивительная штука


« Ответ #6 : 23.06.2008, 12:55:04 »

У меня все старые проекты крутятся на 4.4..., но хостер говорит, что у него давно стоят сервера с php 5 и он готов в любой момент перевести любого пользователя на пятую версию.
Записан
Full_crazy
Давно я тут
****

Репутация: +48/-0
Offline Offline

Пол: Мужской
Сообщений: 264


Иногда думаю ...


« Ответ #7 : 23.06.2008, 23:26:49 »

У меня только пара проектов на 4.4, но они на канадском хостинге Azn. А на VDS у меня 5.2.6
Записан
newleax
Давно я тут
****

Репутация: +23/-0
Offline Offline

Пол: Женский
Сообщений: 234



« Ответ #8 : 27.06.2008, 23:03:31 »

5.2.6. недавно что-то полезла как раз смотреть из-за Коппермайна.
Записан
b2z
Support Team
*****

Репутация: +710/-0
Offline Offline

Пол: Мужской
Сообщений: 7538


Разраблю понемногу


« Ответ #9 : 28.06.2008, 02:35:46 »

5.2.1
Записан
Sedoy
Support Team
*****

Репутация: +86/-10
Offline Offline

Пол: Мужской
Сообщений: 910


Интересно,в какой кодировке пишут врачи?


« Ответ #10 : 28.06.2008, 12:01:33 »

стоят и 4 и 5 у хостера, выбираешь сам на какой ставить
судя по тому что у многих движки еще на 4 ее убирать с хоста не собираются
что же касается всего нового то однозначно нужно все уже делать под 5
Записан
PaLyCH
Живу я здесь
******

Репутация: +146/-19
Offline Offline

Пол: Мужской
Сообщений: 974


Архитектор сайтов


« Ответ #11 : 13.07.2008, 01:21:01 »

Так же как и у Седого и 4 и 5 стоит у хостеров. Приходится пользоваться чаще 4, так как под ней нет проблем с установкой расширений.
Записан
smart
Администратор
*******

Репутация: +1308/-14
Offline Offline

Пол: Мужской
Сообщений: 6850


снова дома...


« Ответ #12 : 15.07.2008, 00:45:02 »

Приходится пользоваться чаще 4, так как под ней нет проблем с установкой расширений.
т.е. упираемся в криворукость разработчиков, которые не могут правильный, валидный xml к расширению приложить? или какие-то иные ошибки установки?
Записан
PaLyCH
Живу я здесь
******

Репутация: +146/-19
Offline Offline

Пол: Мужской
Сообщений: 974


Архитектор сайтов


« Ответ #13 : 15.07.2008, 10:47:14 »

Не, проблема не в криворукости изготовителей, так как и сам могу подправить XML. Пробема с путями, а именно с двумя слешами (ошибка в Php 5)/ На форуме уже обсуждалось
Записан
chemerzaev
Завсегдатай
*****

Репутация: +80/-3
Offline Offline

Пол: Мужской
Сообщений: 580


Надо мыслить. Меня, например, кормят идеи.


« Ответ #14 : 15.07.2008, 11:17:06 »

Если не ошибаюсь 5.2.6
Записан
vanadik
Захожу иногда
**

Репутация: +3/-0
Offline Offline

Пол: Мужской
Сообщений: 22



« Ответ #15 : 15.07.2008, 11:25:47 »

5.2.6 не всё гладко работает на этой версии, приходится в коде движка постоянно что-то ковырять(((
Записан
smart
Администратор
*******

Репутация: +1308/-14
Offline Offline

Пол: Мужской
Сообщений: 6850


снова дома...


« Ответ #16 : 22.07.2008, 23:02:50 »

Интересная получается картинка, из 34 опрошенных, у 31 на сервере уже доступна 5.х, т.е. все-таки большинство перешло на 5-ку...
Записан
PaLyCH
Живу я здесь
******

Репутация: +146/-19
Offline Offline

Пол: Мужской
Сообщений: 974


Архитектор сайтов


« Ответ #17 : 22.07.2008, 23:11:29 »

Видимо из-за хостера. Вот у меня сейчас Mastak. У них стоит только 5, и 4 не ставят (заразы). Еще одна проблема обнаружилась. На этот раз с MosetsTree. Как раз в пятерке. Вот она.
Записан
smart
Администратор
*******

Репутация: +1308/-14
Offline Offline

Пол: Мужской
Сообщений: 6850


снова дома...


« Ответ #18 : 22.07.2008, 23:15:47 »

Еще одна проблема обнаружилась. На этот раз с MosetsTree. Как раз в пятерке. Вот url=http://joomlaforum.ru/index.php/topic,37810.new/topicseen.html]она[/url].
ну если быть объективным, это не твоя проблема, и не проблема 5-ки, это проблема программистов Mosets, и они ее должны устранять (раз уж продукт продают, должны и править)...

Т.е. проблемы связанные с тем, что разработчики не утруждают себя тестированием продуктов на актуальных версиях php, я особыми проблемами не считаю. Другое дело, если бы в 5-ке был изначально какой-то серьезный баг, из-за которого корректно написанные скрипты не работали бы. А так, если внимательно смотреть - почти в каждом случае проблема оказыватеся в разработчике, а значит решаема.
Записан
PaLyCH
Живу я здесь
******

Репутация: +146/-19
Offline Offline

Пол: Мужской
Сообщений: 974


Архитектор сайтов


« Ответ #19 : 22.07.2008, 23:19:17 »

НУ да. А баг с установкой компонентов в joomla на версии php 5 так до сих пор не решен. Я не против 5. Но надо пинать кончено разработчиков компонентов.
Записан
VETERINAR
Живу я здесь
******

Репутация: +165/-14
Offline Offline

Пол: Мужской
Сообщений: 868


Kiss my shiny metal ass!


« Ответ #20 : 22.07.2008, 23:20:33 »

НУ да. А баг с установкой компонентов в joomla на версии php 5 так до сих пор не решен.

Что-то я сколько ставлю, ни одного бага не заметил...
Записан
smart
Администратор
*******

Репутация: +1308/-14
Offline Offline

Пол: Мужской
Сообщений: 6850


снова дома...


« Ответ #21 : 22.07.2008, 23:21:15 »

Что-то я сколько ставлю, ни одного бага не заметил...
есть, есть... с двойным слешем в пути, насколько я помню...
Записан
PaLyCH
Живу я здесь
******

Репутация: +146/-19
Offline Offline

Пол: Мужской
Сообщений: 974


Архитектор сайтов


« Ответ #22 : 22.07.2008, 23:22:49 »

есть, есть... с двойным слешем в пути, насколько я помню...
Именно оно
Записан
VETERINAR
Живу я здесь
******

Репутация: +165/-14
Offline Offline

Пол: Мужской
Сообщений: 868


Kiss my shiny metal ass!


« Ответ #23 : 22.07.2008, 23:24:07 »

Клянусь уже около года ни одного расширения на php 4 не ставил Azn И ни разу баг не встретил Sad

Но я 12-й (а потом 15-й) лаврой пользуюсь. Может в ней этого бага нет?
Записан
smart
Администратор
*******

Репутация: +1308/-14
Offline Offline

Пол: Мужской
Сообщений: 6850


снова дома...


« Ответ #24 : 22.07.2008, 23:31:37 »

Но я 12-й (а потом 15-й) лаврой пользуюсь. Может в ней этого бага нет?
скорее всего AndyR исправил его в процессе тестирования сборки
Записан
Aleks_El_Dia
JComments Tester
*

Репутация: +353/-0
Offline Offline

Пол: Мужской
Сообщений: 3739


AEDStudio Joomla! Direction


« Ответ #25 : 23.07.2008, 23:01:27 »

5.2.5 - в основном мелкие проблемы с установкой из за xml. А так все гуд)
Записан
newleax
Давно я тут
****

Репутация: +23/-0
Offline Offline

Пол: Женский
Сообщений: 234



« Ответ #26 : 24.07.2008, 20:02:34 »

Ничего себе я проголосовала здесь по старому хостингу 5.2.6 , на новом хостинге у меня 4.3.9
 Sad это плохо?
Записан
VETERINAR
Живу я здесь
******

Репутация: +165/-14
Offline Offline

Пол: Мужской
Сообщений: 868


Kiss my shiny metal ass!


« Ответ #27 : 24.07.2008, 20:04:25 »

Ничего себе я проголосовала здесь по старому хостингу 5.2.6 , на новом хостинге у меня 4.3.9

Странно как-то Вы переезжаете. Где ж Вы хостинг с 4-кой-то нашли?
Записан
VETERINAR
Живу я здесь
******

Репутация: +165/-14
Offline Offline

Пол: Мужской
Сообщений: 868


Kiss my shiny metal ass!


« Ответ #28 : 24.07.2008, 20:06:51 »

Я считаю все проблемы с php 5 просто ошибками разработчиков. Если что-то не встаёт, то это можно исправить. PHP 5 на много луше круче и перспективнее 4-ки. Только в этой версии появилась достойное ООП. Работать всё стало быстрее. Последнее моё мнение в этой теме будет таково, что уже можно и давно пора выпускать расширения с пометкой PHP 5 >=.
Записан
PaLyCH
Живу я здесь
******

Репутация: +146/-19
Offline Offline

Пол: Мужской
Сообщений: 974


Архитектор сайтов


« Ответ #29 : 25.07.2008, 14:43:51 »

Я не против. Но сейчас снова столкнулся с проблемой установкой компонента ArtioSef 2.2.8 на Joostina 1.1.3 с PHP 5.1.6. Ошибка известная "Не верный XML файл" Кодировки указывал как надо
Записан
Страниц: [1] 2 3  Все   Вверх
  Добавить закладку  |  Печать  
 
Перейти в:  

Powered by SMF 1.1.21 | SMF © 2006, Simple Machines

Joomlaforum.ru is not affiliated with or endorsed by the Joomla! Project or Open Source Matters.
The Joomla! name and logo is used under a limited license granted by Open Source Matters
the trademark holder in the United States and other countries.

LiveInternet