LiveInternetMail.ru
Форум русской поддержки Joomla!® CMS
20.12.2014, 18:20:49 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
   
   Начало   Поиск Joomla 3.0 FAQ Joomla 2.5 FAQ Joomla 1.5 FAQ Правила форума Новости Joomla Войти Регистрация Помощь  
Страниц: [1] 2  Все   Вниз
  Добавить закладку  |  Печать  
Автор Тема: JomSocial и плагин Zend Framework  (Прочитано 15963 раз)
0 Пользователей и 1 Гость смотрят эту тему.
Игорь Матвеев
Осваиваюсь на форуме
***

Репутация: +3/-1
Offline Offline

Сообщений: 74


« : 01.07.2010, 22:47:37 »

Установил JomSocial + плагины всё работало отлично. Перенёс на хостинг выдаёт ошибку  CC Zend PLUGIN PACK MISSING и CC Zend PLUGIN PACK MISSING INSTRUCTION
что делать не знаю, в чём проблема может кто знает?
Записан
Solven
Осваиваюсь на форуме
***

Репутация: +3/-0
Offline Offline

Пол: Мужской
Сообщений: 82



« Ответ #1 : 02.07.2010, 00:23:50 »

После переноса почему то портиться плагин Zendа.
Нужно скачать пак из 7 установок, установить, далее в плагинах его включить...
Только что второй раз натыкаюсь на такое...
Записан
Игорь Матвеев
Осваиваюсь на форуме
***

Репутация: +3/-1
Offline Offline

Сообщений: 74


« Ответ #2 : 02.07.2010, 00:40:50 »

После переноса почему то портиться плагин Zendа.
Нужно скачать пак из 7 установок, установить, далее в плагинах его включить...
Только что второй раз натыкаюсь на такое...

Благодарю за помощь! Устанавливал 10 плагинов оказались не те теперь установил 7 с официального сайта и всё заработало.
Записан
socker
Новичок
*

Репутация: +0/-0
Offline Offline

Сообщений: 6


« Ответ #3 : 08.07.2010, 11:50:34 »

Привет всем!

Подскажите для каких целей в данном компоненте используется Zend Framework?
И для чего нужен плагин plg_zend?

Возможно он используется для написания различных расширений, но я не уверен в этом.
Большая просьба кто в курсе или знает что по поводу данной темы поделитесь знаниями.
Записан
Romeo
Осваиваюсь на форуме
***

Репутация: +3/-0
Offline Offline

Сообщений: 45



« Ответ #4 : 10.07.2010, 09:07:22 »

Привет всем!

Подскажите для каких целей в данном компоненте используется Zend Framework?
И для чего нужен плагин plg_zend?

Возможно он используется для написания различных расширений, но я не уверен в этом.
Большая просьба кто в курсе или знает что по поводу данной темы поделитесь знаниями.
гугл и вики знают все))
http://ru.wikipedia.org/wiki/Zend_Framework
Записан
socker
Новичок
*

Репутация: +0/-0
Offline Offline

Сообщений: 6


« Ответ #5 : 10.07.2010, 11:00:42 »

Что такое Zend Framework я знаю, вопрос в том что его возможности не используются в самом компоненте, хотя его обязательно необходимо ставить?
Записан
sergei123
Осваиваюсь на форуме
***

Репутация: +1/-0
Offline Offline

Сообщений: 44


« Ответ #6 : 11.07.2010, 03:27:40 »

А как найти у них на сайте именно эти 7 плагинов? Что-то не нашёл ничего насчёт Joomla.
Записан
Игорь Матвеев
Осваиваюсь на форуме
***

Репутация: +3/-1
Offline Offline

Сообщений: 74


« Ответ #7 : 11.07.2010, 21:40:59 »

А как найти у них на сайте именно эти 7 плагинов? Что-то не нашёл ничего насчёт Joomla.

Давай скину тебе ссылки на плагины?
Записан
sergei123
Осваиваюсь на форуме
***

Репутация: +1/-0
Offline Offline

Сообщений: 44


« Ответ #8 : 11.07.2010, 22:50:29 »

Ну скинь, конечно, в чём проблемы? а что здесь нельзя показать?
Записан
Игорь Матвеев
Осваиваюсь на форуме
***

Репутация: +3/-1
Offline Offline

Сообщений: 74


« Ответ #9 : 12.07.2010, 21:32:52 »

Ну скинь, конечно, в чём проблемы? а что здесь нельзя показать?

А у тебя есть русификатор путёвый? версия 1.8.3?
http://www.jomsocial.com/Zend/plugins/plg_zend_pack_1.tar.gz
http://www.jomsocial.com/Zend/plugins/plg_zend_pack_2.tar.gz
http://www.jomsocial.com/Zend/plugins/plg_zend_pack_3.tar.gz
http://www.jomsocial.com/Zend/plugins/plg_zend_pack_4.tar.gz
http://www.jomsocial.com/Zend/plugins/plg_zend_pack_5.tar.gz
http://www.jomsocial.com/Zend/plugins/plg_zend_pack_6.tar.gz
http://www.jomsocial.com/Zend/plugins/plg_zend_pack_7.tar.gz
Записан
burkinman
Захожу иногда
**

Репутация: +0/-0
Offline Offline

Сообщений: 10


« Ответ #10 : 10.08.2010, 14:52:20 »

Пытаюсь установить эти плагины, но Joomla мне говорит "Невозможно подключиться к серверу, failed to open stream: no suitable wrapper could be found Некорректный URL"
Устанавливать пытался и скачав файлы к себе и напрямую с удаленного сервера.
Как быть?
Записан
kuzik
Гость
« Ответ #11 : 18.09.2010, 18:36:11 »

Пожалуйста подскажите как устанавливать эти плагины?  Всё спасибо разобрался!
« Последнее редактирование: 18.09.2010, 23:21:26 от kuzik » Записан
haker777
Захожу иногда
**

Репутация: +0/-0
Offline Offline

Сообщений: 17


« Ответ #12 : 27.09.2010, 11:34:26 »

и все таки как их устанавливать... уже пробовал и вручную и автоматом.
выдает:

        * Не удалось соединиться с удаленным сервером, failed to open stream: php_network_getaddresses: getaddrinfo failed: ���� ���� ����������.
        * Неправильный URL

Записан
kharol
Moderator
*****

Репутация: +216/-0
Offline Offline

Пол: Мужской
Сообщений: 1723



« Ответ #13 : 27.09.2010, 11:42:41 »

Плагины для ручной установки возьмите отсюда
Что прячется за символами ���� ���� ����������.? Что с кодировкой? В какой строке ошибка?
Записан
haker777
Захожу иногда
**

Репутация: +0/-0
Offline Offline

Сообщений: 17


« Ответ #14 : 30.09.2010, 11:56:34 »

У меня тоже проблема с этим плагином... не могу установить. а без него выъодит ошибка "Неверный JomSocial Zend Plugin Pack 2." первый ПАК вроде как то поставился... а со второго по 7 не хочет... уже и инет подключил чтобы он оттуда подтянул но все равно не устанавливается. в че м может быть проблема? может есть какие то другие паки которые не требуют выхода в интернет?
Записан
tench
Осваиваюсь на форуме
***

Репутация: +1/-0
Offline Offline

Пол: Мужской
Сообщений: 60


Путник


« Ответ #15 : 04.11.2010, 18:32:13 »

Пожалуйста подскажите как устанавливать эти плагины?  Всё спасибо разобрался!
Подскажите как разобрались
Записан
kharol
Moderator
*****

Репутация: +216/-0
Offline Offline

Пол: Мужской
Сообщений: 1723



« Ответ #16 : 04.11.2010, 18:35:56 »

Возьмите отсюда, и установите один за другим.
Записан
systema-91
Новичок
*

Репутация: +0/-0
Offline Offline

Пол: Мужской
Сообщений: 5



« Ответ #17 : 27.12.2010, 23:27:27 »

Всем доброго времени суток!
Подскажите как решить следующую проблему:
создаю сайт на локальном сервере, использую пакет "Денвер + старый PHP 5.2 + Zend Optimizer" устанавливаю com_community_pro_2.0.3.zip
система сообщает об успешной установке.
на сайте в главном меню появляется пункт меню JomSocial жму его и вылазит следующая ошибка:
Неверный JomSocial Zend Plugin Pack 1.
Ваш инсталяционный Zend plugin, по-видимому имеет ошибочный номер пакета 1. Вам нужно будет установить недостающий пакет для того, чтобы компонент JomSocial работал без ошибок. Этот плагин можно скачать здесь www.jomsocial.com

где искать ошибку, не знаю. во время установки скачиваются из инета и успешно устанавливаются все десять паков Zend'а.

Как исправить эту ошибку?
p.s.: Ссылку на сайт удалю после исправления ошибки (сказано - сделано)
« Последнее редактирование: 28.12.2010, 00:45:36 от systema-91 » Записан
Wassup
Осваиваюсь на форуме
***

Репутация: +2/-0
Offline Offline

Сообщений: 66



« Ответ #18 : 27.12.2010, 23:55:49 »

Всем доброго времени суток!
Подскажите как решить следующую проблему:
создаю сайт на локальном сервере, использую пакет "Денвер + старый PHP 5.2 + Zend Optimizer" устанавливаю com_community_pro_2.0.3.zip
система сообщает об успешной установке.
на сайте в главном меню появляется пункт меню JomSocial жму его и вылазит следующая ошибка:
Неверный JomSocial Zend Plugin Pack 1.
Ваш инсталяционный Zend plugin, по-видимому имеет ошибочный номер пакета 1. Вам нужно будет установить недостающий пакет для того, чтобы компонент JomSocial работал без ошибок. Этот плагин можно скачать здесь www.jomsocial.com

где искать ошибку, не знаю. во время установки скачиваются из инета и успешно устанавливаются все десять паков Zend'а.

Например - http://osip.by/index.php?option=com_community&view=search&task=browse&sort=latest&Itemid=38

Как исправить эту ошибку?
p.s.: Ссылку на сайт удалю после исправления ошибки
Я скачал плагины поодиночке и установил все 10 штук, так как при установке вместе с JomSoсial выдавала ошибку
http://zend4joomla.googlecode.com/files/plg_zend_1.11.0a_pack_1.zip
На ссылках просто меняй последнюю цифру там всего 10 пакетов, устанавливай по одному...
Записан
systema-91
Новичок
*

Репутация: +0/-0
Offline Offline

Пол: Мужской
Сообщений: 5



« Ответ #19 : 28.12.2010, 00:24:57 »

Я скачал плагины поодиночке и установил все 10 штук, так как при установке вместе с JomSoсial выдавала ошибку
http://zend4joomla.googlecode.com/files/plg_zend_1.11.0a_pack_1.zip
На ссылках просто меняй последнюю цифру там всего 10 пакетов, устанавливай по одному...

Установил теперь вот это - Неверный JomSocial Zend Plugin Pack 2
Изменнено - Сорри все понял!
Для всех:
http://zend4joomla.googlecode.com/files/plg_zend_1.11.0a_pack_1.zip
http://zend4joomla.googlecode.com/files/plg_zend_1.11.0a_pack_2.zip
http://zend4joomla.googlecode.com/files/plg_zend_1.11.0a_pack_3.zip
http://zend4joomla.googlecode.com/files/plg_zend_1.11.0a_pack_4.zip
http://zend4joomla.googlecode.com/files/plg_zend_1.11.0a_pack_5.zip
http://zend4joomla.googlecode.com/files/plg_zend_1.11.0a_pack_6.zip
http://zend4joomla.googlecode.com/files/plg_zend_1.11.0a_pack_7.zip
http://zend4joomla.googlecode.com/files/plg_zend_1.11.0a_pack_8.zip
http://zend4joomla.googlecode.com/files/plg_zend_1.11.0a_pack_9.zip
http://zend4joomla.googlecode.com/files/plg_zend_1.11.0a_pack_10.zip
« Последнее редактирование: 28.12.2010, 00:29:03 от systema-91 » Записан
Wassup
Осваиваюсь на форуме
***

Репутация: +2/-0
Offline Offline

Сообщений: 66



« Ответ #20 : 28.12.2010, 00:27:12 »

теперь http://zend4joomla.googlecode.com/files/plg_zend_1.11.0a_pack_2.zip
и так 10 штук, в ссылке надо менять последнею цифру))
Записан
etoja
Новичок
*

Репутация: +0/-0
Offline Offline

Сообщений: 3


« Ответ #21 : 02.02.2011, 17:08:49 »

все кроме 3го устанавливаются, при установке 3го выдает ошибку :

JFolder::files: Путь не указывает на правильную папку или папка была удалена
JFolder::folder: Путь не указывает на правильную папку или папка была удалена
JFolder::files: Путь не указывает на правильную папку или папка была удалена
Ошибка! Не найден XML-файл установки Joomla!

в чем может быть дело ?
Joomla 1.5 ru
Jomsocial 2.0.2
Записан
kharol
Moderator
*****

Репутация: +216/-0
Offline Offline

Пол: Мужской
Сообщений: 1723



« Ответ #22 : 02.02.2011, 17:35:43 »

Зачем нужно устанавливать 2.0.2?
Записан
etoja
Новичок
*

Репутация: +0/-0
Offline Offline

Сообщений: 3


« Ответ #23 : 02.02.2011, 17:41:13 »

я пробовал и на 1.8 - все тоже самое =(
перечитал все ваши темы - но ничего не помогло пока
при всех возможных вариациях именно 3 пакет Zendа не устанавливается и выдает ошибку приведенную выше

забыл уточнить что при установке не русифицированной версии JomSocial такого не происходит 
« Последнее редактирование: 02.02.2011, 18:00:30 от etoja » Записан
kharol
Moderator
*****

Репутация: +216/-0
Offline Offline

Пол: Мужской
Сообщений: 1723



« Ответ #24 : 02.02.2011, 19:13:23 »

Вообще то русификация не затрагивает Zend.
Я не понимаю, зачем Вам устанавливать версию 2.0.2 полную ошибок, вместо того чтобы установить 2.0.4
Попробуйте следующее:
Возьмите скопируйте папку:
plugins/system/Zend
и 2 файла
plugins/system/zend.php
plugins/system/zend.xml
из установленной нерусифицированной версии.
Удалите компонент, удалите плагины:
Azrul System Mambot
System - JomSocial Update
System - Zend Lib

Скопируйте сохраненные файлы и папку на свое место.
Установите компонент снова.
Записан
etoja
Новичок
*

Репутация: +0/-0
Offline Offline

Сообщений: 3


« Ответ #25 : 03.02.2011, 15:00:03 »

спасибо за развернутый ответ
мне вчера помогла загрузка пакетов от сюда http://code.google.com/p/zend4joomla/downloads/list
при чем самое смешное что после установки 3го пака - Joomla начала ругаться что беда с 6тым
после чего я перепробовал все пакеты из списка и какой-то из них утановилься =)
пока все ок
еще вопрос при сносе кампонента и установки новой версии -пользователи и группы теряються ?
Записан
kharol
Moderator
*****

Репутация: +216/-0
Offline Offline

Пол: Мужской
Сообщений: 1723



« Ответ #26 : 03.02.2011, 15:04:48 »

еще вопрос при сносе кампонента и установки новой версии -пользователи и группы теряються ?
Нет
Записан
tepmehatop
Захожу иногда
**

Репутация: +0/-0
Offline Offline

Сообщений: 14


« Ответ #27 : 25.06.2011, 15:14:44 »

Добрый день, коллеги,

Возникла проблема при установки JomSocial на пункте 9 : Installing Plugins

Fatal error: Call to a member function data() on a non-object in /var/www/******/data/www/*****.ru/administrator/components/com_community/installer.helper.php on line 987

Так же при логине в админку пишет: COM_COMMUNITY_ZEND_PLUGIN_DISABLED
Хотя я зашёл в Плагины и включил его , всёравно ошибка осталась. С влюченым Zend и выключеным всёравно пункт 9 не проходит.

Версия Joomla: 1.6.3

Версия JomSocial 2.2

PHP Version 5.2.6-1+lenny9

Подскажите куда глядеть? что не так.
заранее благодарен  drink

 
Записан
tepmehatop
Захожу иногда
**

Репутация: +0/-0
Offline Offline

Сообщений: 14


« Ответ #28 : 25.06.2011, 15:40:30 »

сейчас удалил Zend и перезапустил установку.

Доходя до установки Zend третий пак выдаёт вот это:

Цитировать
JFolder: :files: Path is not a folder. Path: /var/www/*****/data/www//*****/.ru/tmp/install_4e05c201acdf6
JFolder: :folder: Path is not a folder. Path: /var/www//*****//data/www//*****/.ru/tmp/install_4e05c201acdf6
JFolder: :files: Path is not a folder. Path: /var/www//*****//data/www//*****/.ru/tmp/install_4e05c201acdf6
JInstaller: :Install: Cannot find Joomla XML setup file
Install path does not exist
И чуть ниже ещё куча ошибок:

Цитировать
Warning: array_merge() [function.array-merge]: Argument #1 is not an array in /var/www/*****/data/www/*****.ru/libraries/joomla/installer/helper.php on line 144

Warning: array_merge() [function.array-merge]: Argument #2 is not an array in /var/www/*****/data/www/*****.ru/libraries/joomla/installer/helper.php on line 144

Warning: Invalid argument supplied for foreach() in /var/www/*****/data/www/*****.ru/libraries/joomla/installer/helper.php on line 191

Хотя ниже пишет что всё успешно скачано и установлено

Цитировать
Installing Zend Framework
Please wait. The process may takes several minutes.
Installing from http://zend4joomla.googlecode.com/files/plg_zend_1.11.4_pack_3.zip
.....
Выполнено

И уже потом переходит на страницу
Цитировать
Fatal error: Call to a member function data() on a non-object in /var/www/******/data/www/*****.ru/administrator/components/com_community/installer.helper.php on line 987
Записан
tepmehatop
Захожу иногда
**

Репутация: +0/-0
Offline Offline

Сообщений: 14


« Ответ #29 : 25.06.2011, 15:58:31 »

Всё проблема решена, оказалось паки 3 и 6 повреждены на офф сайте.
Нарыл исправленые паки.

plg_zend_1.11.4_pack_3
plg_zend_1.11.4_pack_6
Записан
Страниц: [1] 2  Все   Вверх
  Добавить закладку  |  Печать  
 
Перейти в:  

Рейтинг@Mail.ru Rambler Top100 Powered by SMF 1.1.20 | SMF © 2006, Simple Machines

Joomlaforum.ru is not affiliated with or endorsed by the Joomla! Project or Open Source Matters.
The Joomla! name and logo is used under a limited license granted by Open Source Matters
the trademark holder in the United States and other countries.

LiveInternet