Форум русской поддержки Joomla!® CMS
25.04.2017, 20:30:50 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
   
   Начало   Поиск Joomla 3.0 FAQ Joomla 2.5 FAQ Joomla 1.5 FAQ Правила форума Новости Joomla Реклама Войти Регистрация Помощь  
Страниц: [1] 2 3  Все   Вниз
  Добавить закладку  |  Печать  
Автор

Ошибка при инсталляции 1.5: В вашем вэб-браузере выключены cookie [Решения]

 (Прочитано 81105 раз)
0 Пользователей и 1 Гость смотрят эту тему.
tavodi
Осваиваюсь на форуме
***

Репутация: +0/-0
Offline Offline

Сообщений: 25



« : 24.01.2008, 17:03:32 »

При попытке поставить joomla! 1.5 выдает: "Похоже, что в вашем вэб-браузере выключены cookie. Вы не сможете установить приложения, если эта функция будет выключена."

куки разрешены
выдает и в FF и в IE

кто сталкивался?
« Последнее редактирование: 18.02.2008, 23:08:43 от Greycat » Записан
 
Greycat
Давно я тут
****

Репутация: +63/-0
Offline Offline

Пол: Мужской
Сообщений: 379



« Ответ #1 : 24.01.2008, 17:14:33 »

Было такое. Решилось перезагрузкой компьютера.
Записан
tavodi
Осваиваюсь на форуме
***

Репутация: +0/-0
Offline Offline

Сообщений: 25



« Ответ #2 : 24.01.2008, 18:31:08 »

мне перезагрузка не помогла Sad
Записан
Klshk
Гость
« Ответ #3 : 26.01.2008, 23:23:07 »

+1  Sad
Записан
sova
Осваиваюсь на форуме
***

Репутация: +22/-1
Offline Offline

Сообщений: 138



« Ответ #4 : 27.01.2008, 00:05:32 »

Перезагрузка не помагает. Пытался на пяти разных машинах - все тоже  Angry
Записан
Greycat
Давно я тут
****

Репутация: +63/-0
Offline Offline

Пол: Мужской
Сообщений: 379



« Ответ #5 : 27.01.2008, 01:30:22 »

Перезагрузка не помагает. Пытался на пяти разных машинах - все тоже  Angry

Приведите параметры серверной части.
Записан
Klshk
Гость
« Ответ #6 : 27.01.2008, 01:33:49 »

у меня на хостинге,не канает
Записан
Greycat
Давно я тут
****

Репутация: +63/-0
Offline Offline

Пол: Мужской
Сообщений: 379



« Ответ #7 : 27.01.2008, 01:42:07 »

у меня на хостинге,не канает

Только на хостинге? На локальной машине такого нет?

Всё равно, приведите параметры серверной части: версии Apach, PHP, MySQL.


Перезагрузка не помагает. Пытался на пяти разных машинах - все тоже  Angry

sova, на всех машинах одинаковые PHP и прочее? Какие?


P.S.

Кстати, люди, у вас случайно не Каспер 7 в качестве антивируса?
Записан
Klshk
Гость
« Ответ #8 : 27.01.2008, 01:49:32 »

на этом,http://www.litehosting.ru/
Записан
Greycat
Давно я тут
****

Репутация: +63/-0
Offline Offline

Пол: Мужской
Сообщений: 379



« Ответ #9 : 27.01.2008, 01:56:37 »

на этом,http://www.litehosting.ru/


Вы дистрибутив уже залили? Дайте ссылку, посмотрю скажет ли он такое моему браузеру.
Записан
sova
Осваиваюсь на форуме
***

Репутация: +22/-1
Offline Offline

Сообщений: 138



« Ответ #10 : 27.01.2008, 02:12:19 »

Система:       Linux server4.jino-net.ru
Версия PHP:       5.2.0
Веб-сервер:    Apache
Интерфейс между веб-сервером и PHP:    apache2handler

Антивирус NOD32 и без него
FireWallPro  и без него

IE 6.0
Firefox 2.0.0.11

Да тут такой нюанс - на этой конфигурации Joomla 1,5 RC4 стала и стояла без проблем.
« Последнее редактирование: 27.01.2008, 02:23:12 от sova » Записан
tavodi
Осваиваюсь на форуме
***

Репутация: +0/-0
Offline Offline

Сообщений: 25



« Ответ #11 : 27.01.2008, 16:41:19 »

 tavodi . kiev . ua

Система:      FreeBSD 5.4-RELEASE-p22
Версия базы данных:    4.1.22-log
Версия PHP:    5.2.3
Веб-сервер:    Apache
Интерфейс между веб-сервером и PHP:    apache2handler

File Uploads:    ON    
Session auto start:    OFF    
Short Open Tags:    ON    
Output Buffering:    OFF    
Display Errors:    OFF
XML enabled:    Yes
Zlib enabled:    Yes
Disabled Functions:    system, exec, shell_exec, passthru, escapeshellarg, escapeshellcmd, proc_close, proc_get_status, proc_nice, proc_open, proc_terminate
Записан
Klshk
Гость
« Ответ #12 : 27.01.2008, 17:13:00 »

Вы дистрибутив уже залили? Дайте ссылку, посмотрю скажет ли он такое моему браузеру.
http://f50team.litehosting.ru/index.php
Записан
Greycat
Давно я тут
****

Репутация: +63/-0
Offline Offline

Пол: Мужской
Сообщений: 379



« Ответ #13 : 27.01.2008, 17:46:40 »

http://f50team.litehosting.ru/index.php

Текс... С меня тоже куки потребовали после первого шага! Значит проблема где-то со стороны сервера.

Я ставил по несколько копий на Denwer 3, на XAMP и даже на IIS+PHP. Такое сообщение было при первой установке на Денвер, но после перезагрузки машины установка прошла без проблем. Правда, всё это под Windows (2000 и XP).

Пойду на форум к оргам, может там что-то подобное обнаруживали.
Записан
Klshk
Гость
« Ответ #14 : 27.01.2008, 18:24:52 »

узнаете что-либо,сообщите,буду очень признателен
Записан
Greycat
Давно я тут
****

Репутация: +63/-0
Offline Offline

Пол: Мужской
Сообщений: 379



« Ответ #15 : 27.01.2008, 21:03:55 »

Итак, кое что выясняется. На форуме joomla.org такая тема нашлась:

http://forum.joomla.org/index.php/topic,256816.0.html

Если кэш действительно включен и ритуальный танец в виде очистки кэша браузера, и традиционной перезагрузки компьютера, не помог, придётся брать в руки бубен. Cool

Цитирую последний пост:

Цитировать
It may be that you have the wrong temp folder specified.  When I used a server with vDeck 1 control panel, the /tmp folder was the default.  The new server I am on uses vDeck 3 (a huge improvement), but it requires a full address (which vDeck 3 provides) as shown in the posting below that put me on the right track.<br>
Quote from: smlie4 on August 11, 2007, 04:41:36 AM
I had same problem with "cookies not enabled message" using powweb as host & all my cookies were enabled, i uploaded joomla 1.5 to a different host and the problem disappeared. The PROBLEM: The php.ini file needs modifying.

The SOLUTION: Go to your PHP page in the CGI panel - http://members.powweb.com/member/cgiManagement/PHPplus.bml, you will find "Edit your php.ini file for PHP" search for "session.save_path = /var/php_sessions" and change to the ServerRoot: /home/users/web/b1074/pow.xxxxx/htdocs (verify your server root = home directory looks similar to this one)
 
 So it looks Like this....
   
"session.save_path = /home/users/web/b1074/pow.xxxxx/htdocs/tmp" (change the xxxxs's to your powweb username)


**Note that you also have to create a "tmp" Directory in your htdocs directory with the rig th permission "chmod 755".



Видимо дело в указании пути к папке для временных файлов. Часто путь в PHP.ini указывается относительно: "/tmp".

Для решения проблемы рекомендуют указать в PHP.ini полный путь к этой папке, например:

Код:
session.save_path = /home/users/username/domanename/htdocs/tmp

(путь, конечно, может отличаться на каждом конкретном сервере).

Поскольку доступа к PHP.ini на хостинге скорее всего не будет. Вероятно, путь к папке для хранения сессий придётся переопределить в файле .htaccess, например так :

Код:
php_value session.save_path /home/users/username/domanename/htdocs/tmp

В случае Windows  путь должен начинаться от диска, например:

Код:
c:/temp


Надеюсь, это поможет Smiley .
« Последнее редактирование: 27.01.2008, 21:07:19 от Greycat » Записан
sova
Осваиваюсь на форуме
***

Репутация: +22/-1
Offline Offline

Сообщений: 138



« Ответ #16 : 27.01.2008, 22:15:25 »

Помогло 
 
php_value session.save_path /tmp

в файле  .htaccess

    Smiley Grin Smiley
Записан
Greycat
Давно я тут
****

Репутация: +63/-0
Offline Offline

Пол: Мужской
Сообщений: 379



« Ответ #17 : 28.01.2008, 00:13:33 »

В общем, как я понял из других тем на форумах joomla.org, это чистейшей воды баг. Разработчики о нём знают и уже готовят патч Smiley .
Записан
Klshk
Гость
« Ответ #18 : 28.01.2008, 00:58:46 »

Блин доступа к пхп ини нету(
на хосте же
Записан
Greycat
Давно я тут
****

Репутация: +63/-0
Offline Offline

Пол: Мужской
Сообщений: 379



« Ответ #19 : 28.01.2008, 16:15:14 »

Блин доступа к пхп ини нету(
на хосте же

Попытайтесь положить в корень сайта файл ".htaccess" (можно взять файл в "htaccess.txt" в дистрибутиве Joomla и переименовать) и внесите в него параметр "php_value session.save_path", как указано выше.

Хотя, на бесплатном хостинге работа с этими файлами может быть заблокирована.
Записан
pinkponk
Гость
« Ответ #20 : 29.01.2008, 20:45:35 »

как назло, вчера установил джумлу безпроблем, но по одной причине пришлось удалить, а сегодня при установке пишет про эти куки
Записан
Greycat
Давно я тут
****

Репутация: +63/-0
Offline Offline

Пол: Мужской
Сообщений: 379



« Ответ #21 : 29.01.2008, 21:02:00 »

как назло, вчера установил джумлу безпроблем, но по одной причине пришлось удалить, а сегодня при установке пишет про эти куки

Возможо остались файлы сессий во временном каталоге (если PHP складывал их не в каталоге Joomla). Если так, можно попытаться их удалить вручную.
Записан
TheGrayWolf
Гость
« Ответ #22 : 18.02.2008, 16:10:50 »

Тоже была проблема с cookie,
дело оказалось в настройках ПХП,
решается она примерно так:

1) переменная session.save_path должна указывать на каталог с правами записи, если стоит винда, то примерно так: session.save_path = "C:\Program Files\PHP\session". ВНИМАНИЕ, каталог должен существовать!!!

2) переменная session.use_cookies = 1, тоже важно.

3) переменная session.cookie_path должна быть ПУСТОЙ!!! В ней то и заключался весь сыр-бор, т.е. должна выглядеть вот так "session.cookie_path =", и всё!

Надеюсь поможет, мне помогло.
Записан
Pix
Гость
« Ответ #23 : 22.02.2008, 21:59:51 »

в ФФ помогло вручную прописав куки к данному сайту и разрешив их, куда ставится J!
Записан
Lord IRS
Новичок
*

Репутация: +2/-0
Offline Offline

Сообщений: 6


« Ответ #24 : 29.04.2008, 12:38:40 »

Из бесполезных новшеств версии 1.5.2 и 1.5.3 отмечу дурацкую проверку на имя базы данных в инсталляторе. Что изменится от того, что первой будет цифра? Или имя БД используется в качестве переменной? У меня хостер  1gb.ru дает базу
1gb_имя_базы. При инсталляции, естесственно, вылезает ошибка при проверке. Вариантов решения 3:

1)ПРОГРАММЕРСКИЙ: Редактировать файлы javascript из папки install и удалить/подправить регулярные выражения проверки на правильность. (Я так сделал. Долго, зато весело! И получаете полное моральное удовлетворение Grin)

2)ЮЗЕРСКИЙ: Не использовать web-установку, а просто все скопировать и прописать все настройки в configuration.php (Эффективно, но довольно сложно для новичков. Cool)

3)ЛАМЕРСКИЙ: Имея backup базы(!) просто поставить CMS более старой версии (1.5.0. или 1.5.1) и импортировать базу, после чего апдейтить сайт до более позней версии. Wink
Записан
Карибас
Гость
« Ответ #25 : 21.05.2009, 17:28:23 »

Это вылазит вверху - как лечить ?

Warning: session_start() [function.session-start]: open(/var/www/tmp//sess_8267a26krr1uljki9metagtq36, O_RDWR) failed: No such file or directory (2) in /htdocs/libraries/joomla/session/session.php on line 423

Может попробовать удалить все сессии в папке  tmp? Или перепроверить session.save_path, что в ней прописанно?
Записан
vlad275
Захожу иногда
**

Репутация: +1/-5
Offline Offline

Сообщений: 14



« Ответ #26 : 14.06.2009, 01:34:54 »

У меня на хостинге  проблема.

Цитировать
Warning: ini_set() has been disabled for security reasons in /www/uuuq.com/m/o/t/motoremzona/htdocs/libraries/joomla/session/session.php on line 102

Warning: ini_set() has been disabled for security reasons in /www/uuuq.com/m/o/t/motoremzona/htdocs/libraries/joomla/session/session.php on line 105

Warning: ini_set() has been disabled for security reasons in /www/uuuq.com/m/o/t/motoremzona/htdocs/libraries/joomla/session/session.php on line 682

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /www/uuuq.com/m/o/t/motoremzona/htdocs/libraries/joomla/session/session.php:102) in /www/uuuq.com/m/o/t/motoremzona/htdocs/libraries/joomla/session/session.php on line 423

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /www/uuuq.com/m/o/t/motoremzona/htdocs/libraries/joomla/session/session.php:102) in /www/uuuq.com/m/o/t/motoremzona/htdocs/libraries/joomla/session/session.php on line 423

Warning: Cannot modify header information - headers already sent by (output started at /www/uuuq.com/m/o/t/motoremzona/htdocs/libraries/joomla/session/session.php:102) in /www/uuuq.com/m/o/t/motoremzona/htdocs/libraries/joomla/session/session.php on line 426


Похоже, что в вашем вэб-браузере выключены cookie. Вы не сможете установить приложения, если эта функция будет выключена.

Добавил в .htaccess.txt строку
php_value session.save_path /tmp

Ничего не изменилось. Что делать?
Записан
Egor
Новичок
*

Репутация: +0/-0
Offline Offline

Сообщений: 6


« Ответ #27 : 15.06.2009, 21:48:51 »

У меня на бесплатном хостинге, тоже самое - пишет "Укажитете папку пакета" На лакалке, все оК...
А как этот хостинг работает, есть проблемы???   www.komtet.ru
Сегодня зарегился у них = пришел ответ почти сразу 600р. за domen. Жалко будет, если такие-же проблеммы будут!
Бесплатный хост у меня 6te.net 500metrov дают... мой site www.onego.freeoda.com - не пугайтесь я на нем еще учусь...  
« Последнее редактирование: 15.06.2009, 22:18:01 от Egor » Записан
Walrus
Гость
« Ответ #28 : 24.07.2009, 10:21:29 »

Столкнулся с аналогичной проблемой. Немного помучившись, полазив по форуму и покопавшись в мозгах, нашел решение.
Поскольку этимология была ясна - проблема РНР с записью во временную папку, посмотрел логи ошибок сессий на хостинге.
Там ясным по чёрному было написано, КУДА конкретно он не может произвести запись! Соответственно, у меня он не мог записать в несуществующую папку. Как оказалось, мой РНР хотел, что бы была папка tmp внутри директории cgi-bin. Вот и всё. Сделал папку, поставил права - всё заработало! В данном случае хостер - powweb.com
Записан
chandrasecar
Осваиваюсь на форуме
***

Репутация: +0/-0
Offline Offline

Сообщений: 29


« Ответ #29 : 08.09.2009, 17:10:40 »

Была такая же проблема и с включенными куками в браузере.
1) Может отсутствовать папка "C:\php\tmp".
2) Смените браузер.
Записан
Страниц: [1] 2 3  Все   Вверх
  Добавить закладку  |  Печать  
 
Перейти в:  

Powered by SMF 1.1.21 | SMF © 2006, Simple Machines

Joomlaforum.ru is not affiliated with or endorsed by the Joomla! Project or Open Source Matters.
The Joomla! name and logo is used under a limited license granted by Open Source Matters
the trademark holder in the United States and other countries.

LiveInternet