0 Пользователей и 1 Гость просматривают эту тему.
  • 8 Ответов
  • 2867 Просмотров
*

Влад

  • Захожу иногда
  • 128
  • 2 / 0
Проблема с ID
« : 08.02.2007, 17:14:31 »
Может кто сталкивался?
Перенес с локалки на хостинг сайт (Joomla! 1.0.12Стабильная версия)  ;D
Начал там добавлять новость с установкой на главной, на главную не выкинул, но в разделе Новость расположил.
Естественно я полез править. Ставлю галочку чтоб на главной и применить.
В итоге я получаю ошибку дубликат чего-то там и ID нулевой у моей новости, писал новые статьи говорит что 0 ID  занят.
Полез удалять новость глючную, скинул в корзину, а из корзины не удаляется  :-\ :'(
Тогда полез в MySQL вручную исправил id  у новости на свободный и стало все хорошо! удалилась! Но следующая мною опубликованная статья опять взяла  0 ID  и все заного.
Если вручную менять ID  в базе все хорошо, а иначе глюк
*

smart

  • Администратор
  • 6485
  • 1317 / 15
  • Хочешь сделать хорошо — сделай!
Re: Проблема с ID
« Ответ #1 : 08.02.2007, 17:43:08 »
при переносе базы в экспортном sql не перенеслись значения для autoincrement полей...
*

Влад

  • Захожу иногда
  • 128
  • 2 / 0
Re: Проблема с ID
« Ответ #2 : 08.02.2007, 19:45:38 »
В смысле? тоесть мне надо где-то поставить голочку не равно 0 или что?
Я еще не совсем ас в SQL. Пожалуста.
Но намек понял

Re: Проблема с ID
« Ответ #3 : 23.02.2007, 00:18:31 »
Только сегодня столкнулся с этой проблемой. Решил ее тупо и просто. Залез в phpmyadmin, нашел этот ID 0 и исправил его на тот, которого у меня нет. В данном случае это было 2. И все ок!!!  :D
*

oppo

  • Захожу иногда
  • 367
  • 82 / 8
  • ΨΨΨ я - УКРАЇНЕЦЬ
Re: Проблема с ID
« Ответ #4 : 23.02.2007, 01:17:42 »
Цитировать
И все ок!!! 
это может не одна ошибка .....
перенос базы MySql с версии 4.16 на низшую, например на хост версию MySql  4 при применении экспорта в phpmyadmin для mysql40 - появляется глюк - теряется auto_increment //
При добавлении материала (insert )/ ошибка - так как дублируется запись в одну и туже ячейку с одинаковым ,например id=1
сравнить дампы и править

Re: Проблема с ID
« Ответ #5 : 01.03.2007, 22:44:21 »
Цитировать
это может не одна ошибка .....

Да, действительно так. При создании нового меню у него ID снова 0. Как исправить это??? Если можно, объясните чайнику  >:(
*

iT)ZevS(

  • Захожу иногда
  • 177
  • 31 / 2
Re: Проблема с ID
« Ответ #6 : 04.03.2007, 20:26:07 »
попробуй перезалить базу с полной вставкой в майадмине.
*

Влад

  • Захожу иногда
  • 128
  • 2 / 0
Re: Проблема с ID
« Ответ #7 : 06.03.2007, 19:38:32 »
Я поступил просто!
Залез в phpmyadmin и сравнил свою старую и новую базу, и где надо поставил ключ auto_increment
Тупо, но просто. А сечас постоянно слежу если переношу базу, смотрю, чтобы этот ключ стоял
*

iT)ZevS(

  • Захожу иногда
  • 177
  • 31 / 2
Re: Проблема с ID
« Ответ #8 : 06.03.2007, 20:26:49 »
это гиморно, и ничуть не проще, где нибудь да пропустишь. этот косяк потянется - неразу вылезет.
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Проблема с SSL или с авторизацией... Не знаю с чем.

Автор Aquasonick

Ответов: 10
Просмотров: 27451
Последний ответ 22.04.2014, 15:35:01
от E.S
Проблема с регистрацией на сайте - SSL 2

Автор Shadow

Ответов: 1
Просмотров: 1845
Последний ответ 29.03.2010, 19:39:03
от Shadow
Проблема с меню в админ.панели

Автор SpirITzzz

Ответов: 14
Просмотров: 7962
Последний ответ 08.02.2010, 17:12:37
от lilu
Перенос БД, проблема к кодировкой..

Автор ART-DELI

Ответов: 6
Просмотров: 3708
Последний ответ 01.11.2009, 20:04:22
от miks69
Проблема при установке Joomla, с MySQL..

Автор rikki

Ответов: 4
Просмотров: 2026
Последний ответ 27.05.2009, 15:25:38
от rikki