Основной курс по Joomla
0 Пользователей и 1 Гость просматривают эту тему.
  • 7 Ответов
  • 5962 Просмотров
*

lebedeff

  • Новичок
  • *
  • 2
  • 4
Привет всем!
Проблема, в принципе в сабже, но опишу более подробно.
После заливки с локального на инетовский сервак сайт начал "выделываться" при авторизации/регистрации, а именно:
Цитировать
Ошибка при установлении защищённого соединения
При соединении с youstar.com.ua произошла ошибка.
SSL получило запись, длина которой превышает максимально допустимую.
(Код ошибки: ssl_error_rx_record_too_long)
    *   Страница, которую вы пытаетесь просмотреть, не может быть отображена, так как достоверность полученных данных не может быть проверена.
    *   Пожалуйста свяжитесь с владельцами веб-сайта и проинформируйте их об этой проблеме. В качестве альтернативы вы можете сообщить о некорректно работающем сайте с помощью команды, находящейся в меню «Справка».
Насколько я понимаю + погуглив - можно сделать вывод, что он переходит в защищенное соединение, требуя SSL сертефикат (которого у меня нет и не планируется :) )
Существует ли возможность отключения защищенного соединения?
Force_sll в configuration.php - выключен ("0")
В настройках модуля cb_login (HTTPS (encrypted) login, register and lost password) - стоит "same as page (default)"
Куда пойти, что поковырять?
Заранее спасибо за ответ.
« Последнее редактирование: 27.01.2011, 21:24:27 от lebedeff »
*

lebedeff

  • Новичок
  • *
  • 2
  • 4
Не дождался, конечно ответа.
В общем, решение довольно простое (подглядел в буржуйском нете).
У кого при логине/авторизации в CommunityBuilder путь меняется с http на https — есть решение!

Берем файл /libraries/joomla/methods.php и в строке 80 меняем код ($ssl === 1) на ($ssl === -1).

Вот так все просто оказалось.
*

arshish

  • Осваиваюсь на форуме
  • ***
  • 47
  • 1
Спасибо тебе огромное добры человек и звездочку тебе)))
Там в небесах без любви ЗАМЕРЗАЕТ СОЛНЦЕ
*

Georgiy

  • Осваиваюсь на форуме
  • ***
  • 49
  • 0
Спасибо))
*

Bese~nok

  • Новичок
  • *
  • 1
  • 0
lebedeff, огромное преогромное, Вам спасибо  :D
*

KKat

  • Захожу иногда
  • **
  • 13
  • 0
У меня похожая проблема, но на Joomla 3.3.6 + Kunena 3.0.6. Все странички нормально открываются до тех пор, пока я не пробую авторизироваться. Он тогда сразу пытается пойти через https и никак не могу этот ssl отключить. В библиотеках methods.php нету. Пыталась /libraries/kunena/route/route.php посмотреть, но там ssl=0 (меняла и на -1 - не помогло). Кто-то может подсказать где еще покопать ?
*

CapoH4a

  • Новичок
  • *
  • 1
  • 0
У меня похожая проблема, но на Joomla 3.3.6 + Kunena 3.0.6. Все странички нормально открываются до тех пор, пока я не пробую авторизироваться. Он тогда сразу пытается пойти через https и никак не могу этот ssl отключить. В библиотеках methods.php нету. Пыталась /libraries/kunena/route/route.php посмотреть, но там ssl=0 (меняла и на -1 - не помогло). Кто-то может подсказать где еще покопать ?

Вы не то меняете.
Для Joomla 3.x
Нужный файл: /libraries/joomla/application/route.php, в строке 86, меняем код ($ssl === 1) на ($ssl === -1)
*

Vasilka

  • Новичок
  • *
  • 3
  • 0
Спасибо огромное. Сайт на Joomla 2.5, но без CommunityBuilder. Заработал даже менеджер перенаправлений.