0 Пользователей и 1 Гость просматривают эту тему.
  • 18 Ответов
  • 5363 Просмотров
*

leny

  • Захожу иногда
  • 72
  • 0 / 0
Ситуация такая, имеется шаблон блога категорий, он выводит, в моем случае, 4 материала на странице сайта не так как нужно.
Должен выводить в одну колонку, как указано в настройках этого пункта меню, а выводит следующим образом: первый материал выводит во всю ширину, второй, третий и четвертый - не во всю ширину.
Короче вот скрин:

Вот мои настройки:
Во всю ширину: 10
Вступление: 0
Колонки: 1
Ссылки: 10

Пробовал чистить кэш - не помогает(((
*

0rk

  • Захожу иногда
  • 178
  • 11 / 0
попробуй на время отключить кеширование и пересахронить или изменить настройки вывода.
*

leny

  • Захожу иногда
  • 72
  • 0 / 0
Если управление кэшем производится в сайт -> Общие настройки -> система, то - не помогает и кэширование у меня почему-то уже изначально было выключено :(
*

AlexSF

  • Давно я тут
  • 678
  • 68 / 0
  • В споре истина рождается
А структуре файлов шаблона есть примерно такое:

ваш шаблон/html/com_content/frontpage/default_item.php    ?

ежели есть то его нужно править или удалять(тогда начнёт грузится из стандартного components/com_content/views/frontpage/tmpl/default_item.php).
Задаёте вопрос - не забудьте приложить ссылку на проблемный сайт
При проблеме с CSS рекомендую использовать Mozilla Firefox и её плагин FireBug
И по максимуму изучите, или поставьте в закладки - http://htmlbook.ru/css
Notepad++ поможет почти в любом деле
*

leny

  • Захожу иногда
  • 72
  • 0 / 0
А структуре файлов шаблона есть примерно такое:

ваш шаблон/html/com_content/frontpage/default_item.php    ?

ежели есть то его нужно править или удалять(тогда начнёт грузится из стандартного components/com_content/views/frontpage/tmpl/default_item.php).

Нет, такого нет, есть шаблон/html/mod_login

а так не пробовали?
Во всю ширину: 0
Вступление: 10

Не помогает, даже пробовал колонок делать и 3 и 4 и 5..., всеравно все как было(((
*

leny

  • Захожу иногда
  • 72
  • 0 / 0
Даже когда я в настройках ставлю
Во всю ширину:0     
Вступление: 0     
Колонки: 0     
Ссылки: 0
Все остается без изменений.

Кто-нибудь помогите решить проблему

Может кто-нибудь знает какой файл отвечает за эти настройки, может с ним что-то не так? :D
*

0rk

  • Захожу иногда
  • 178
  • 11 / 0
а если другой пункт меню так вывести попробывать для примера? тоже лихорадит?
*

leny

  • Захожу иногда
  • 72
  • 0 / 0
Сделал новый пункт меню с параметрами 0, 0, 0, 0
Все выводится как и раньше
Вообще ничего непонятно :(

Не может ли это быть из-за компонента JoomSEF, я там в нем что то мудрил после его установки?
Может попробовать его снести и посмотреть что получится?
*

leny

  • Захожу иногда
  • 72
  • 0 / 0
Всем спасибо за поддержку!
Проблема решилась сама собой.
Сначала ради интереса я решил везде поставить нули, потом обновил страницу все осталось как было, потом через какое-то время захожу посмотреть - на странице ни одного материала. Зашел в админку поставил10, 0, 1, 10 и все заработало как нужно.
*

Incognito

  • Новичок
  • 8
  • 0 / 0
И все же, может кто сталкивался с такой проблемой еще? У меня то же самое, и НИЧЕГО не могу сделать...:(((. Уже пробовала все что можно, думаю может принудительно в самом шаблоне поставит вывод одной колонки, но вдруг где-нить понадобиться две...

Подскажите пожалуйста что может быть?
*

0rk

  • Захожу иногда
  • 178
  • 11 / 0
попробуй на время отключить кеширование и пересахронить или изменить настройки вывода.
*

alexj69

  • Захожу иногда
  • 244
  • 28 / 0
  • Думать надо!!!
Тоже столкнулся с этой проблемой. Отключение кеширования, JoomSEF , смена шаблонов не помогает. При любых значениях настроек вывода статей, в блоге отображаются одна статья в ширину, далее в две колонки.
Кто поможет разобраться? Может очередной баг 1.5.22 ?
*

alexj69

  • Захожу иногда
  • 244
  • 28 / 0
  • Думать надо!!!
проблема до сих пор не решена
*

voland

  • Легенда
  • 10554
  • 563 / 111
  • Эта строка съедает место на вашем мониторе
Такого бага не припомню, может JoomSEF мешает?
*

oriol

  • Завсегдатай
  • 1042
  • 100 / 4
зайди в папку HTML вашего шаблона отключи (переименуй) папку com_content
если измениться то копать в этой папке
*

alexj69

  • Захожу иногда
  • 244
  • 28 / 0
  • Думать надо!!!
Artio компонент мешал. Снес его нафиг, теперь все работает
*

a.Lexus

  • Осваиваюсь на форуме
  • 31
  • 3 / 0
Всем здравия желаю! У меня та же проблема - не работают настройки, всё препробовал, помогло только отключение Artio JoomSEF, может кто-то знает как сделать чтобы работало как надо и артио не удалять?
*

alexj69

  • Захожу иногда
  • 244
  • 28 / 0
  • Думать надо!!!
Поставьте вместо Artio sh404SEF. С ним у меня все нормально работает.
*

Скучный мэн

  • Новичок
  • 3
  • 0 / 0
всем привет.
У меня похожая проблема, а точнее у меня картинки в превью отображаются некорректно, то есть выходят за рамку материала и накладываются на другой материал там где 2 колонки, в одну коллонку тоже не хочет отображать, подскажите как сделать так чтобы изображения в статьях масштабировались при отображении под формат статьи? пожалуйстааа ^-^

Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться