0 Пользователей и 1 Гость просматривают эту тему.
  • 10 Ответов
  • 2472 Просмотров
*

BMF

  • Захожу иногда
  • 97
  • 1 / 1
Вчера все было нормально, сегодня вечером проверяю ресурс и обнаруживаю что нет аватаров.
они просто не отображаются. хостер говорит что никаких действий они не производили на сервере, я тоже не делал ничего с настройками... вот что получается:

аватары загруженные пользователями не отображаются в разных броузерах (лиса, хром, ие, опера), аватары которые я положил в папку со стандартными авами комьюнити билдера больше не отображаются ни при регистрации ни у тех, у кого они выбраны (раньше спокойно отображались и gif анимированный и jpg... ) зато отображаются стандартные заглушки для тех, кто не ставил аватары (картинка заменена на свою).
файлы картинок загруженных пользователями для авы спокойно лежат на сервере, они не удалены, но не подхватываются комьюнити билдером почемуто (это видно на скрине).

проверка базы данных комьюнити билдера из админки выдает такое:

Checking CommunityBuilder Datbase:

All CommunityBuilder comprofiler_field_values table fieldid rows all match existing fields.

All CommunityBuilder comprofiler_field_values table rows link to correct fieldtype fields in comprofiler_field table.

All CommunityBuilder fields from comprofiler_fields are present as columns in the comprofiler table.

Checking CommunityBuilder folders:
Avatars and thumbnails folder is Writeable.
All Core CB mandatory basics Database is up to date.

Core CB mandatory basics database checks done. If all lines above are in green, test completed successfully. Otherwise, please take corrective measures proposed in red.
Core CB Database structure differences:
Table #__comprofiler_fields Rows fieldid = 52 : Field profile = 1 instead of 0


это единственная зацепка, но даже после исправления таблицы базы данных fieldid 52 profile 1 на 0 ничего не меняется.

Очень нужна ваша помощь. как реанимировать это дело :((( не могу понять в чем проблема и как так вообще получилось.

пс. откатывался на бекап базы даных - не помогло, аватары так и не отображались.
« Последнее редактирование: 16.02.2011, 15:36:07 от 4webspot »
*

AlexSmirnov

  • Завсегдатай
  • 1862
  • 272 / 16
  • Ищите и найдете
Re: CommunityBuilder 1.2.2 пропали аватары
« Ответ #1 : 15.02.2011, 23:56:54 »
попробуйте полностью запаковать свой сайт с помощью akeebabackup и поиграться с его установкой и тестированием аваторов СВ на других средах, удаленных и/или местных.

стоит также поиграться с обновлением СВ 1.2.2 на версию 1.3.1: распакуйте бэкап в подпапке на Вашем хостинге и установите СВ 1.3.1 поверх 1.2.2.

# Back the fufalo (особенно ту самую столкершу)! #
# ВАЖНО! Кайфую от удаления присланного в личку спама, почти как от любви (особенно по выходным). #
*

BMF

  • Захожу иногда
  • 97
  • 1 / 1
Re: CommunityBuilder 1.2.2 пропали аватары
« Ответ #2 : 16.02.2011, 00:29:57 »
хочу удостовериться что косяк не хостеровский - регистрирую аккаунт на беспланом хостинге, попробую там развернуть свои покунки.
не подскажете где можно скачать cb 1.3.1 ? русифицированный конечно же.
*

AlexSmirnov

  • Завсегдатай
  • 1862
  • 272 / 16
  • Ищите и найдете
Re: CommunityBuilder 1.2.2 пропали аватары
« Ответ #3 : 16.02.2011, 00:38:35 »
если Ваш сайт как есть, на СВ 1.2.2, установится местно, например на домашнем пакете хамрр, то вывод будут очевиден - хостинг не отконфигурирован.

кстати, Вы не пытались заходить на Ваш сайт с другого ПС?

качайте СВ 1.3.1 на официальном сайте на joomlapolis.com. плагин русского языка - по ссылке forge.joomlapolis.com/projects/lan-cb-ru/files (устанавливается с помощью Менеджера плагинов компонента СВ!).
« Последнее редактирование: 01.06.2011, 05:41:15 от AlexSmirnov »
# Back the fufalo (особенно ту самую столкершу)! #
# ВАЖНО! Кайфую от удаления присланного в личку спама, почти как от любви (особенно по выходным). #
*

BMF

  • Захожу иногда
  • 97
  • 1 / 1
Re: CommunityBuilder 1.2.2 пропали аватары
« Ответ #4 : 16.02.2011, 01:21:42 »
на домашнем компе на денвере 3 с php 5.2.2 изменений нет, аваторки не отображаются. пробовал с двух разных компов с разными айпи адресами и разными конфигурациями и разными провайдерами и разными антивирусами... с хостингом другим может завтра разберусь... но думаю результат тот же будет.
на joomlapolish.com релиз CommunityBuilder 1.4 ... я конечно не присматривался, но 1.3.1 не заметил :(

есть еще плагин у меня bk-multithumb. он почему-то отказался сегодня вкручивать ватермарки в картинки статей :( (адрес к ватеру он понимает только как абсолютный )такое было при переносе аккаунта у хостера с одного сервера на другой, кстати с аватарками тоже и в тоже самое время (прошло в течении суток - полутора) только вот я не куда не переезжал вчера... цпанель проверил - сервер не изменился. все таки это хостера косяк скорее всего, и он морозится в тикетах...
« Последнее редактирование: 16.02.2011, 01:30:13 от BMF »
*

AlexSmirnov

  • Завсегдатай
  • 1862
  • 272 / 16
  • Ищите и найдете
Re: CommunityBuilder 1.2.2 пропали аватары
« Ответ #5 : 16.02.2011, 04:52:40 »
официальную CB 1.3.1 скачайте (после регистрации) по этой ссылке http://www.joomlapolis.com/downloads/doc_details/207-cb-131-package
# Back the fufalo (особенно ту самую столкершу)! #
# ВАЖНО! Кайфую от удаления присланного в личку спама, почти как от любви (особенно по выходным). #
*

BMF

  • Захожу иногда
  • 97
  • 1 / 1
Re: CommunityBuilder 1.2.2 пропали аватары
« Ответ #6 : 16.02.2011, 08:12:44 »
я там зарегистрирован давно...
обновил 1.2.2 на 1,4 на денвере - не помогло :(
*

BMF

  • Захожу иногда
  • 97
  • 1 / 1
Re: CommunityBuilder 1.2.2 пропали аватары
« Ответ #7 : 16.02.2011, 12:39:34 »
проблема решена. виной всему был файл .htaccess с кодом
Код
DirectoryIndex index.php 

<FilesMatch "\.(gif|jpg|png)$">


   RewriteEngine On


   RewriteCond %{REQUEST_FILENAME} -f


   RewriteRule ^(.*)$ /watermark/watermark.php [T=application/x-httpd-php,L,QSA]


</FilesMatch>
который лежал в папке "/images". в свое время я его туда положил для работы с одним плагином ватермарков, не помню каким. этим плагином давно не пользуюсь, но хтэксес не стирал. и вот по непонятной причине он выстрелил именно вчера...
кстати после удаления его, ватермарк с другого плагина нормально заработал даже на относительных путях :).

спасибо за участие и помощь. я теперь наверное хоть cb обновлю :)
*

AlexSmirnov

  • Завсегдатай
  • 1862
  • 272 / 16
  • Ищите и найдете
Re: CommunityBuilder 1.2.2 пропали аватары
« Ответ #8 : 16.02.2011, 15:34:50 »
рад слышать  ;)

успехов с сайтом   ;D
# Back the fufalo (особенно ту самую столкершу)! #
# ВАЖНО! Кайфую от удаления присланного в личку спама, почти как от любви (особенно по выходным). #
*

Maya

  • Новичок
  • 1
  • 0 / 0
Здравствуйте! Подскажите пожалуйста как решить проблему с CB : аватары не хотят загружаться в профилях.

Нажимаю - обновить изображение - обзор -  загрузить - и загружается обратно стандартный силуэт из галереи.
Настройки уже все проверила.

Что это может быть?? ;)
*

AlexSmirnov

  • Завсегдатай
  • 1862
  • 272 / 16
  • Ищите и найдете
Здравствуйте! Подскажите пожалуйста как решить проблему с CB : аватары не хотят загружаться в профилях.

Нажимаю - обновить изображение - обзор -  загрузить - и загружается обратно стандартный силуэт из галереи.
Настройки уже все проверила.

Что это может быть?? ;)


на какой версии Joomla! и на какой версии СВ Вы работаете? загружаются ли картинки системой Joomla? загружаются ли аватары СВ в свои папки?

возможно, у Вас включена предварительная административная модерация  загружаемых пользователями аватаров или запрещена их загрузка.

проверьте параметры:
Конфигурация -> Модерация -> Требовать одобрения загрузки аватара
Конфигурация -> Аватары -> Аватар - Да
Конфигурация -> Аватары -> Разрешить загрузку аватара - Да

# Back the fufalo (особенно ту самую столкершу)! #
# ВАЖНО! Кайфую от удаления присланного в личку спама, почти как от любви (особенно по выходным). #
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Как отключить уведомления об обновлениях CommunityBuilder?

Автор ivan.sergeev

Ответов: 3
Просмотров: 1188
Последний ответ 03.06.2020, 19:44:50
от Torchez
Кроссбраузерность профиля CommunityBuilder 2

Автор warlocksp

Ответов: 1
Просмотров: 638
Последний ответ 05.03.2018, 08:15:18
от warlocksp
CommunityBuilder 2.1.2 не приходит email уведомление Администраm

Автор bicka

Ответов: 2
Просмотров: 963
Последний ответ 14.07.2017, 13:34:11
от bicka
Галерея в CommunityBuilder

Автор d13v555

Ответов: 3
Просмотров: 1233
Последний ответ 04.04.2017, 06:35:20
от d13v555
Поле номера телефона в профиле CommunityBuilder

Автор Guran

Ответов: 1
Просмотров: 1283
Последний ответ 13.03.2017, 09:44:36
от Guran