0 Пользователей и 1 Гость просматривают эту тему.
  • 14 Ответов
  • 2195 Просмотров
*

alanbus

  • Захожу иногда
  • 214
  • 0 / 0
не работает смена изображений в K2. При попытке заменить изображение категории или материала, загружается прежнее. причем можно поставить галочк уи сперва удалить прежнее. но при попытке затем в путсое место загрузить новое -  вылезает старое. Что это?!
*

maxis

  • Захожу иногда
  • 117
  • 1 / 0
Re: Не работает смена изображений в K2
« Ответ #1 : 18.11.2012, 15:33:26 »
У меня то же самое... Может банальная тупость, но раньше работало и вдруг бац и не загружает!
Joomla 1.5.26, K2 2.5.4 (2.5.1)
Пробовал и в Explorer и в Opera. Права на папки открыты, пробовал на 2-х разных хостингах. Дело не в браузере и не в хостинге и не в версии (так как на другом сайте работает), а в какой-то хитрой настройке компонента. Если кто встречался - помогите.
Причём пишет "Изменения материала сохранены", размер изображения 200 кило
« Последнее редактирование: 18.11.2012, 15:41:29 от maxis »
*

paternoster

  • Давно я тут
  • 506
  • 24 / 1
Re: Не работает смена изображений в K2
« Ответ #2 : 19.11.2012, 02:17:21 »
А еще может просто дисковое пространство кончиться...но это так..предположение...если реально много статей с изображениями....)))
*

SDKiller

  • Moderator
  • 2706
  • 329 / 5
  • ...ergo sum
Re: Не работает смена изображений в K2
« Ответ #3 : 19.11.2012, 07:18:59 »
Права на папки открыты, пробовал на 2-х разных хостингах.

А вы по ftp не пробовали скачать и открыть файлы - реально то же самое изображение осталось или другое?
Быть может кеширование так работает у вас?
*

maxis

  • Захожу иногда
  • 117
  • 1 / 0
Re: Не работает смена изображений в K2
« Ответ #4 : 19.11.2012, 10:48:43 »
А вы по ftp не пробовали скачать и открыть файлы - реально то же самое изображение осталось или другое?
Быть может кеширование так работает у вас?

Так ведь он и новое изображение загружать не хочет. При загрузке проверял - файлов новых не создаёт (при смене тоже).

Для наглядности:
сайт №1 - J1.5.26+K2 2.5.4 - хостинг№1 = работает
сайт №2 - J1.5.23+K2 2.4.1 - хостинг№1 = не работает (распаковка архива с быстрым стартом шаблона)
сайт №3 - J1.5.26+K2 2.5.4 - хостинг№2 = не работает

Что характерно - загрузить галерею можно без проблем, а изображение материала K2 - нет. Пробовал в разных браузерах на каждом сайте. Думаю дело в настройках компонента, причём именно тупой баг юзера (типа меня), галочка не там стоит, параметр не тот. Подскажите, где можно поискать? Работало, работало, вдруг бац и перестало.

Кэш чистил и в браузере и на сайте, не помогает.
« Последнее редактирование: 19.11.2012, 15:46:57 от maxis »
*

SDKiller

  • Moderator
  • 2706
  • 329 / 5
  • ...ergo sum
Re: Не работает смена изображений в K2
« Ответ #5 : 19.11.2012, 21:44:35 »
При загрузке проверял - файлов новых не создаёт (при смене тоже)

Так я и спрашиваю - как проверяли, скачивали, открывали для просмотра?
Потому что наименования изображений материала формируются одни и те же - они формируются из id материала.

Возможно проблема с владельцами-правами, новые не могут перезаписаться поверх старых.

Прежние, поверх которых пытаетесь перезаписывать как загружали - через К2 или вместе с сайтом заливали?
В новом материале есть проблемы при загрузке нового изображения?

Если есть доступ в панель хостинга - посмотрите владельцев и права при разных вариантах - при создании нового через К2, при заливке по ftp, при распаковке из архива.
*

maxis

  • Захожу иногда
  • 117
  • 1 / 0
Re: Не работает смена изображений в K2
« Ответ #6 : 21.11.2012, 19:56:29 »
Так я и спрашиваю - как проверяли, скачивали, открывали для просмотра?
Потому что наименования изображений материала формируются одни и те же - они формируются из id материала.

Возможно проблема с владельцами-правами, новые не могут перезаписаться поверх старых.

Прежние, поверх которых пытаетесь перезаписывать как загружали - через К2 или вместе с сайтом заливали?
В новом материале есть проблемы при загрузке нового изображения?

Если есть доступ в панель хостинга - посмотрите владельцев и права при разных вариантах - при создании нового через К2, при заливке по ftp, при распаковке из архива.
При заливке всё нормально, при распаковке из архива нормально, НО...
- в новом материале, картинка не сохраняется, но пишет "Материал успешно сохранён"
- при попытки удалить изображение из старого материала выдаёт кучу ошибок, что не может удалить картинки (разного размера которые), само изображение тоже не удаляется.
- There was a problem rendering your image gallery. Please make sure that the folder you are using in the Simple Image Gallery Pro plugin tags exists and contains valid image files. The plugin could not locate the folder: media/k2/galleries/188  - получил сегодня когда зашёл в существующий материал с галереей. Папка есть, картинки в ней есть.
- часть картинок была с шаблоном, устанавливались вместе с ним, а часть сам добавлял, но... это было на другом хостинге вроде. Сейчас не вспомню.

Хочу отдельно заметить - вчера устанавливал через админку компонент AcyMailing последний - встал без проблем. И перестал работать модуль по выводу материалов K2, хотя работал нормально, теперь выдаёт ошибку: Fatal error: Class 'K2HelperUtilities' not found in /home/shkolavo/domains/shkolavokala-nn.ru/public_html/components/com_k2/helpers/route.php on line 65

Пытался обновить K2 пишет "-1 - Возникла ошибка  Невозможно скопировать выбранный файл." в чёрной рамочке на белом экране. Такое первый раз встречаю вообще.
« Последнее редактирование: 21.11.2012, 20:16:12 от maxis »
*

maxis

  • Захожу иногда
  • 117
  • 1 / 0
Re: Не работает смена изображений в K2
« Ответ #7 : 21.11.2012, 20:32:04 »
Вот картинка этой ошибки.http://files.mail.ru/JIQ6L8 Я включил режим отладки и он это выдал.
*

maxis

  • Захожу иногда
  • 117
  • 1 / 0
Re: Не работает смена изображений в K2
« Ответ #8 : 22.11.2012, 20:31:08 »
Хотя бы посоветуйте куда копать. Если это проблема хостинга, то почему через стандартный загрузчик изображения без проблем загружаются (нет проблем с записью).
Если из папок установщика попытаться поверх перезаписать файлы компонента, может помочь?
*

paternoster

  • Давно я тут
  • 506
  • 24 / 1
Re: Не работает смена изображений в K2
« Ответ #9 : 23.11.2012, 12:35:55 »
Тут по отладчику, скорее в самой Joomla вопросы..но не к К2..в логах я там вообще К2 не увидел...
*

maxis

  • Захожу иногда
  • 117
  • 1 / 0
Re: Не работает смена изображений в K2
« Ответ #10 : 23.11.2012, 12:58:26 »
Тут по отладчику, скорее в самой Joomla вопросы..но не к К2..в логах я там вообще К2 не увидел...

Если заново развернуть установочный архив Joomla! ?  С чего начать копать? Хотя бы направление действий. То, что с Joomla! проблема согласен, так как ещё один модуль отвалился ни с того ни с сего. (писал выше ошибку). Она же не может сама вот так вот взять и сломаться?
*

paternoster

  • Давно я тут
  • 506
  • 24 / 1
Re: Не работает смена изображений в K2
« Ответ #11 : 23.11.2012, 14:35:05 »
Увы, все бывает в этой жизни..правило бэкапа еще никто не отменял. Чтобы я попробовал сделать в таком случае...без глубокой хирургии.
1.Попробовать накатить сверху файлы Joomla для начла.НО..БЕЗ УСТАНОВЩИКА.
2.насколько давние есть бэкапаы? Может попробовать восстановиться из них.Хотя бы на локалке для тестирования.Когда и от чего появилась проблема.
3.Выкачал бы по  FTP каталог media м посмотрел бы..а появляются ли там загруженные изображения.
*

maxis

  • Захожу иногда
  • 117
  • 1 / 0
Re: Не работает смена изображений в K2
« Ответ #12 : 26.11.2012, 11:53:59 »
Увы, все бывает в этой жизни..правило бэкапа еще никто не отменял. Чтобы я попробовал сделать в таком случае...без глубокой хирургии.
1.Попробовать накатить сверху файлы Joomla для начла.НО..БЕЗ УСТАНОВЩИКА.
2.насколько давние есть бэкапаы? Может попробовать восстановиться из них.Хотя бы на локалке для тестирования.Когда и от чего появилась проблема.
3.Выкачал бы по  FTP каталог media м посмотрел бы..а появляются ли там загруженные изображения.

3.Изображения реально такие, т.е. не заменяет.

Я попробовал поставить 777 на папки с изображениями и стали загружаться и удаляться! А как до этого работало непонятно. Осталась другая проблема. При попытке загрузить галерею - загружает, но не выводит, а пишет ошибку "using in the Simple Image Gallery Pro plugin tags exists and contains valid image files. The plugin could not locate the folder: media/k2/galleries/256". Папка реально существует.
« Последнее редактирование: 26.11.2012, 12:45:19 от maxis »
*

maxis

  • Захожу иногда
  • 117
  • 1 / 0
Re: Не работает смена изображений в K2
« Ответ #13 : 28.11.2012, 21:25:17 »
Увы, все бывает в этой жизни..правило бэкапа еще никто не отменял. Чтобы я попробовал сделать в таком случае...без глубокой хирургии.
1.Попробовать накатить сверху файлы Joomla для начла.НО..БЕЗ УСТАНОВЩИКА.
2.насколько давние есть бэкапаы? Может попробовать восстановиться из них.Хотя бы на локалке для тестирования.Когда и от чего появилась проблема.
3.Выкачал бы по  FTP каталог media м посмотрел бы..а появляются ли там загруженные изображения.

Конечно понимаю, что припознился, но...
Скорее всего эта ошибка вылезла (как и с категориями) после обновления Joomla! до версии 1.5.26, кто-нибудь сталкивался или уже 1.5 совсем прошлый век?

Fatal error: Class 'K2HelperUtilities' not found in /home/shkolavo/domains/shkolavokala-nn.ru/public_html/components/com_k2/models/item.php on line 1121
А, там вообще ничего  - $params = &K2HelperUtilities::getParams('com_k2'); Ошибка известная, но решения нигде нет. Может направите ссылочкой?
*

maxis

  • Захожу иногда
  • 117
  • 1 / 0
Re: Не работает смена изображений в K2
« Ответ #14 : 19.12.2012, 17:04:04 »
Проблема с изображениями пропала напрочь когда убрал русификатор RSForms. Связь этих двух явлений мне не понятна.

Fatal Error навели на мысль как вылечить вот здесь. http://joomlaforum.ru/index.php/topic,208728.0.html.

Всем спасибо!
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Не работает мультиязычность для материалов К2

Автор Kokshetau

Ответов: 5
Просмотров: 308
Последний ответ 21.11.2020, 23:36:12
от Kokshetau
[Решено] Не работает (не отображается) K2 media manager

Автор raidho

Ответов: 1
Просмотров: 758
Последний ответ 19.07.2019, 22:02:58
от zod3d
Не работает русификация K2 v2.8.0 |

Автор sergspb

Ответов: 5
Просмотров: 5252
Последний ответ 17.05.2019, 21:48:26
от serhy
Не работает функция оценки-рейтинга в статьях в К2

Автор igorsuccess

Ответов: 5
Просмотров: 602
Последний ответ 02.04.2018, 11:36:40
от igorsuccess
Можно ли изменить папку для сохранения изображений в K2?

Автор lolitma3

Ответов: 3
Просмотров: 708
Последний ответ 16.01.2018, 18:04:48
от Akeksandr