Новости Joomla

Вышли релизы безопасности Joomla 6.1.3 и Joomla 5.4.8

Релиз безопасности Joomla 6.1.3 и Joomla 5.4.8

Проект Joomla! рад сообщить о выходе Joomla 6.1.3 и Joomla 5.4.8. Это релизы безопасности и исправления ошибок для серий 5.x и 6.x.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

Joomla 5+ пакет для интеграции с API Почты России: нормализация данных, расчёт доставки, создание отправлений, партии, документы, возвраты, поиск отделений, справочники и SOAP-отслеживание.

v.3.0.0. Что нового?
Это дальнейшее развитие ранее закрытой Joomla-библиотеки для работы с API сервиса Отправка (для бизнеса) Почты России. Поэтому версия не 1.0.0, а 3.0.0.

Сейчас эта библиотека ушла от собственных реализаций и стала Joomla-обёрткой известного PHP SDK от Lapay Group.

Возможности библиотеки.
- получение настроек аккаунта, точек сдачи и текущего остатка запросов к API;
- нормализация адресов, ФИО и телефонов перед созданием отправления;
- расчёт тарифа и срока доставки;
- создание, поиск, изменение, удаление и возврат заказов в состояние «Новые»;
- проверка надёжности получателя;
- создание партий, просмотр партий и заказов внутри партии;
- генерация пакета печатных документов и формы Ф103;
- создание, изменение и удаление возвратных отправлений;
- поиск отделений по индексу, адресу и координатам, получение сервисов отделения;
- локальный список стран;
- SOAP-отслеживание операций по РПО и работа с билетами пакетного трекинга.

👩‍💻 Joomla-возможности.
В пакете библиотеки WT Otpravkapochtaru есть поля Joomla Form для расширений. Они позволяют работать в интерфейсе Joomla с некоторыми типами данных, получаемых по API из вашего личного кабинета в ЛК Почты России для бизнеса.
На данный момент в библиотеке доступны 3 поля списков, которые отображают доступные в аккаунте ОПС, типы и категории отправлений.
Поддерживаются зависимые списки: значение одного поля обновляется при изменении другого.

Системные требования.
Системные требования в основном связаны с системными требованиями апстрима библиотеки - LapayGroup PHP SDK.
- Joomla 5+
- PHP 8.3+
- Расширения PHP:
-- ext-mbstring
-- ext-simplexml
-- ext-soap (опционально, для трекинга)
-- ext-zip

Ссылки:
- Страница расширения
- GitHub библиотеки и документация

@joomlafeed

0 Пользователей и 1 Гость просматривают эту тему.
  • 6 Ответов
  • 11376 Просмотров
*

Anmetov

  • Новичок
  • 4
  • 0 / 0
Извините за повтор темы, но предложенные решения этой ошибки в этой теме
http://joomlaforum.ru/index.php/topic,36190.0.html не помогли!
Я сделал бекап рабочего сайта с помощью FileZilla_3.5.3 и попытался запустить его на локальном сервере denwer, в результате чего появилась эта ошибка! Значение переменных $mosConfig_live_site и $mosConfig_absolute_path я обновил! Не знаю почему, но у меня не было в папке includes файла version.php. может причина в нем, тогда где его взять!?
Подскажите пожалуйста как решить данного рода проблему!
За раннее всем спасибо!
*

danik.html

  • Живу я здесь
  • 2650
  • 353 / 4
что еще за version.php ? У меня его тоже нет. Откуда вы его вообще взяли?
Насчет ошибки - у вас че, прям многоточие и выводится? Помоему там должен выводиться путь к файлу который запрашивается но не найден - вы не пытались проверить этот файл прежде чем создавать тему?
【Мегапак Virtuemart】:
 • метатеги (description,keywords)
 • заголовки (title)
 • красивые алиасы (чпу) без тормозов и дублей!
*

Anmetov

  • Новичок
  • 4
  • 0 / 0
Warning: require_once(Z:/home/localhost/www/includes/version.php) [function.require-once]: failed to open stream: No such file or directory in Z:\home\localhost\www\vpered\includes\joomla.php on line71
Fatal error: require_once() [function.require]: Failed opening required 'Z:/home/localhost/www/includes/version.php' (include_path='.;/usr/local/php5/PEAR') inZ:\home\localhost\www\vpered\includes\joomla.php on line 71

Вот вся выводимая ошибка! Проверить этот файл Joomla.php?
*

danik.html

  • Живу я здесь
  • 2650
  • 353 / 4
В файле Joomla.php всего 7 строк, что за бред?

У вас точно версия 1.5 ?
【Мегапак Virtuemart】:
 • метатеги (description,keywords)
 • заголовки (title)
 • красивые алиасы (чпу) без тормозов и дублей!
*

Anmetov

  • Новичок
  • 4
  • 0 / 0
Наверно нет так как сайт, который я скопировал делали в 2008 или 2009 годах! И в файле Joomla.php 6023 строки!
*

Anmetov

  • Новичок
  • 4
  • 0 / 0
danik.html у вас есть какие нибудь мысли поделитесь пожалуйста мне это сайт для диплома нужен  :(
*

freemaxx

  • Новичок
  • 5
  • 0 / 0
Здравствуйте.
У меня Joomla 1.5.26 недавно была мощная вирусная атака, с этой бедой справился, но вот осталась такая проблема, неотображается раздел контакты на сайте, пишет вот такую ошибку:
Warning: require_once(/home/xtoolte3/public_html/lan-tech/administrator/components/com_facileforms/libraries/crosstec/classes/BFText.php) [function.require-once]: failed to open stream: No such file or directory in /home/xtoolte3/public_html/lan-tech/components/com_facileforms/facileforms.php on line 24

Fatal error: require_once() [function.require]: Failed opening required '/home/xtoolte3/public_html/lan-tech/administrator/components/com_facileforms/libraries/crosstec/classes/BFText.php' (include_path='.:/usr/local/apache22-php5/share/pear') in /home/xtoolte3/public_html/lan-tech/components/com_facileforms/facileforms.php on line 24

В админке все модули отображаются, все ссылки перепроверил, но проблема осталась(((
Помогите пожалуйста, как ее можно исправить?
сайт www.lan-tech.ru раздел контакты и техподдержка
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

simpleform2 ошибка ajax error в Google chrome

Автор safronoff343

Ответов: 1
Просмотров: 4912
Последний ответ 05.06.2020, 20:36:42
от safronoff343
Ошибка #1050 при переносе базы данных на хостинг

Автор Ksen

Ответов: 7
Просмотров: 29330
Последний ответ 16.03.2020, 17:47:29
от Petrovich
При попытке войти в админку 404 ошибка компонента

Автор omezik

Ответов: 4
Просмотров: 8075
Последний ответ 31.08.2019, 22:41:46
от Taatshi
Ошибка в компоненте CKForms

Автор Vas80

Ответов: 9
Просмотров: 4065
Последний ответ 22.04.2019, 13:34:48
от sivers
Ошибка Fatal error: Allowed memory size of 73400320 bytes exhausted

Автор Andre109

Ответов: 1
Просмотров: 4320
Последний ответ 03.12.2018, 01:29:56
от voland