0 Пользователей и 1 Гость просматривают эту тему.
  • 4 Ответов
  • 2005 Просмотров
*

1day

  • Захожу иногда
  • 160
  • 7 / 6
Сразу скажу, что использовал вот инструкцию и делал на своем компе все, денвер с php 5.3 установил.

Обновлял Joomla 1.5.26 при помощи jUpgrade v 2.5.1 и в настройках указал на версию Joomla 1.7, т.к. на версию Joomla 2.5 никак не хотел завершаться процесс миграции, а до версии Joomla 1.7 процесс миграции смог завершиться, лишь с предварительным удалением устаревшего кэша в настройках сайта.

При миграции появляется вот такая ошибка:

Цитировать
Warning: mysqli::ping() [mysqli.ping]: Couldn't fetch mysqli in \home\test1.ru\www\jupgrade\libraries\joomla\database\database\mysqli.php on line 195


Процесс миграции выполняется, после чего появляется внизу ссылку на админку и главную, но вот при переходе на эти 2 страницы я вижу лишь белый экран и надпись:

Цитировать
Table 'demo1.j17_session' doesn't exist SQL=INSERT INTO `j17_session` (`session_id`, `client_id`, `time`) VALUES ('sv1u7ed2nnsg0pv3be51bjfhc2', 0, 1341693989)


После чего я залез в БД сайта, и там не обнаружил ни одного созданного поля с префиксом "j25", был лишь только старый "jos". Как мне побороть ошибку с "mysqli::ping", пожалуйста подскажите.

P.S. Я установил чистый сайт с демо-данными, который попытался обновить.
« Последнее редактирование: 11.07.2012, 16:00:26 от 1day »
*

1day

  • Захожу иногда
  • 160
  • 7 / 6
Кто-нибудь может сказать причину, почему не создаются в БД поля с префиксом "j25"? Потому что все остальное успешно переносится, файлы изображений итд.
*

Taatshi

  • Глобальный модератор
  • 4967
  • 464 / 1
  • Верстаем и немножко кодим. Обращайтесь ;)
Я переносила на 2.5 но с оговорками: Каталог создаем сами, распаковываем Joomla туда сами, в настройках пропускаем закачку и распаковку. И первый пункт - проверка и очистка я тоже пропускала.
*

1day

  • Захожу иногда
  • 160
  • 7 / 6
Я переносила на 2.5 но с оговорками: Каталог создаем сами, распаковываем Joomla туда сами, в настройках пропускаем закачку и распаковку. И первый пункт - проверка и очистка я тоже пропускала.
Вы не поверите, но у меня действительно получилось, как вы написали! Вот в чем дело - новая версия Joomla 2.5.6 не совместима с jUpgrade v 2.5.1 , зато вот версия Joomla 2.5.4, которуя я отдельно скачал и распаковал - на нее все ОК встало и проагрейдилось!
Поставьте эту тему вверх!
*

1day

  • Захожу иногда
  • 160
  • 7 / 6
Вот еще важный момент!
Файл htaccess.txt у Joomla 1.5 так и должен называться, то есть не ".htaccess", в противном случае пользователи и другой контент не перенесется, а лишь создадуться поля в бд чтобы можно было на сайт зайти.
И опять же повторюсь, что обновиться можно только на версию 2.5.4, то есть вручную ее разархивируем в папке!
« Последнее редактирование: 30.07.2012, 21:58:04 от b2z »
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Внимание! Тема для тех у кого не работает JUpgrade. Решение.

Автор Snip

Ответов: 67
Просмотров: 44042
Последний ответ 15.10.2018, 19:51:19
от Physicist
Критическая уязвимость. Joomla 1.7

Автор Juseppe

Ответов: 18
Просмотров: 2047
Последний ответ 25.06.2018, 18:48:32
от vebmaster
Миграция с Joomla 1.5 на Joomla 1.6 с помощью J2XML Importer

Автор Nik

Ответов: 100
Просмотров: 46591
Последний ответ 27.04.2018, 17:02:57
от CrazyPr0ger
ошибка после обновления c Joomla 2.5 до 3

Автор akondr

Ответов: 23
Просмотров: 8773
Последний ответ 02.04.2018, 19:08:36
от SeBun
Не обновляется Joomla 2.5.28

Автор SPMBes

Ответов: 47
Просмотров: 3549
Последний ответ 20.03.2018, 21:44:44
от stendapuss