0 Пользователей и 1 Гость просматривают эту тему.
  • 7 Ответов
  • 3602 Просмотров

На локалке и на серваке разные версии mysql. Как мне полученный файл экспорта оптимиировать под другую версию БД??
Подскажите, пожалуйста.
*

smart

  • Администратор
  • 6485
  • 1317 / 15
  • Хочешь сделать хорошо — сделай!
Re: Несоответствие версий MySQL
« Ответ #1 : 03.05.2006, 00:34:55 »
ну например в phpMyAdmin при экспорте можно указывать для какой версии сервера MySQL делается экспорт

Re: Несоответствие версий MySQL
« Ответ #2 : 03.05.2006, 14:16:27 »
А где это можно указать? Я что-то не найти
*

Павел Зотов

  • Захожу иногда
  • 166
  • 28 / 5
Re: Несоответствие версий MySQL
« Ответ #3 : 03.05.2006, 14:35:33 »
Судя по всему экспортируешь из 4.1+ в 4.0 или ниже.

Можно так делать: заменяешь ENGINE=MyISAM на TYPE=MyISAM и стираешь все DEFAULT CHARSET CP-1251

Re: Несоответствие версий MySQL
« Ответ #4 : 04.05.2006, 15:09:19 »
а если с 4.18-max на 5ую. То что в этом случае  посоветуете?
*

Павел Зотов

  • Захожу иногда
  • 166
  • 28 / 5
Re: Несоответствие версий MySQL
« Ответ #5 : 04.05.2006, 15:16:33 »
4.0.18? или 4.1.8?

В принципе в любом случае проблем не должно возникнуть. Если с 4.0.18 -> 5+ то возможно придется добавить DEFAULT CHARSET CP1251 в CREATE TABLE
*

alter

  • Захожу иногда
  • 57
  • 4 / 1
  • Всегда в тени...
Re: Несоответствие версий MySQL
« Ответ #6 : 17.03.2007, 14:03:20 »
Сервер:
Код
PHP сборка: 	FreeBSD pm14.zenon.net 4.8-STABLE FreeBSD 4.8-STABLE #0: Thu Jan i386 
База данных - версия: 3.23.58
PHP версия: 4.4.4
Web сервер: Apache/1.3.37 (Unix) PHP/4.4.4 AuthMySQL/2.20
WebServer to PHP интерфейс: apache
Версия Mambo: Mambo 4.5.2.3 Stable [ Paranoia - 019 ] 17 августа 2005 00:00 GMT

Локаль:
Код
PHP сборка: 	Windows NT ZAISL 5.1 build 2600
База данных - версия: 4.1.16-max
PHP версия: 4.4.4
Web сервер: Apache/1.3.33 (Win32) PHP/4.4.4
WebServer to PHP интерфейс: apache
Версия Mambo: Mambo 4.5.2.3 Stable [ Paranoia - 019 ] 17 августа 2005 00:00 GMT

При экспорте базы выдает ошибки..
Как победить?
*

memo

  • Захожу иногда
  • 147
  • 1 / 0
Re: Несоответствие версий MySQL
« Ответ #7 : 17.03.2007, 22:56:06 »

База данных - версия:    3.23.58

База данных - версия:    4.1.16-max

При экспорте базы выдает ошибки..
Как победить?

По-моему, надо читать тут:

http://phpclub.ru/faq/wakka.php?wakka=Mysql41Rus&v=7c5

и тут (практически)

http://www.ruscms.ru/forum/showthread.php?t=4763&highlight=iooi


Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Установка версии 1.0.15 без поддержки MYSQL

Автор Смотрящий на луну

Ответов: 2
Просмотров: 3025
Последний ответ 01.02.2010, 20:35:49
от BudoMaster
Проблема при установке Joomla, с MySQL..

Автор rikki

Ответов: 4
Просмотров: 2026
Последний ответ 27.05.2009, 15:25:38
от rikki
С первым шагом установки разобраться не могу(Имя хоста MySQL?,Имя пользователя?,Пароль доступа к БД?

Автор gest

Ответов: 9
Просмотров: 4512
Последний ответ 19.11.2008, 08:20:32
от maix
Не могу подключиться к MySQL-серверу

Автор juli

Ответов: 5
Просмотров: 7324
Последний ответ 23.05.2008, 10:21:40
от juli
Импорт БД MySQL,экспорт БД MySQL.

Автор Shurik2975

Ответов: 2
Просмотров: 3201
Последний ответ 03.05.2008, 06:12:29
от Shurik2975