0 Пользователей и 1 Гость просматривают эту тему.
  • 4 Ответов
  • 1387 Просмотров
*

goga_pgasovav

  • Захожу иногда
  • 197
  • 2 / 0
  • Внимательный джумловод
Руководствуясь старой доброй статьёй http://joomlaforum.ru/index.php/topic,40455.0.html добавил несколько полей в форму добавления материала.
Два обычных, текстовых, и одно textarea
С текстовыми инпутами всё прекрасно: сохраняет в базе, затем отображает данные в админке и на сайте.
А вот с textarea возникли трудности. В phpMyAdmin я вижу что данные, введённые в поле, сохранились, но в админке они не выводятся.
Т.е. я вижу пустое после, хотя на сайте данные так же отображаются.
Если у кого-то есть соображения на этот счет заранее благодарю!

UPD: В ходе работы выяснилось так же, что при последующем редактировании и сохранении материала содержимое переменной, отвечающей за данные этого textarea, обнуляется.
« Последнее редактирование: 19.11.2012, 14:59:28 от goga_pgasovav »
*

goga_pgasovav

  • Захожу иногда
  • 197
  • 2 / 0
  • Внимательный джумловод
Проблема с textarea не решилась, но, погуглив, я нашел способ вставки дополнительных полей редактора (editor).
Теперь всё сохраняется и выводится как следует, за одним исключением... HTML-код не сохраняется из этих полей.
Что-только не пробовал, но при сохранении все HTML-тэги вырезаются.

Может у кого-то есть догадки почему?
*

rusak

  • Захожу иногда
  • 76
  • 4 / 0
*

goga_pgasovav

  • Захожу иногда
  • 197
  • 2 / 0
  • Внимательный джумловод
rusak,
спасибо, но, к счастью, со стандартным полем эдитора всё в порядке. Он отлично сохраняет HTML теги и все такое...
Я же создал дополнительное поле с редактором:
(файл administrator/components/com_content/admin.content.html.php)
Код
<tr>
<td>Краткое<br />описание: </td>
<td><?php $editor =& JFactory::getEditor(); echo $editor->display( 'shortdescr',  $row->shortdescr , '100%', '150', '75', '20', false );?></td>
</tr>

и все, что я сохраняю в этом поле, сохраняется без единого HTML-тэга
это крайне печалит... попробовал разобраться с помощью знатоков со stackoverflow
предложили дописать в administrator/components/com_content/controller.php такие строки:

Код
$post=JRequest::get('post');
$post['shortdescr'] = JRequest::getVar( 'shortdescr', '', 'post', 'string', JREQUEST_ALLOWHTML );

Но это никак не помогло...
*

goga_pgasovav

  • Захожу иногда
  • 197
  • 2 / 0
  • Внимательный джумловод
Тема закрыта.
Решение описываю тут: http://joomlaforum.ru/index.php/topic,238919.new.html
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Изображение-ссылка в материале

Автор Omedius

Ответов: 4
Просмотров: 1207
Последний ответ 02.07.2017, 21:11:10
от vipiusss
Как размещать h1 в header в материале?

Автор kirill-juk

Ответов: 12
Просмотров: 1043
Последний ответ 02.11.2016, 15:56:51
от kirill-juk
Как расширить поле с текстом?

Автор jullizz

Ответов: 2
Просмотров: 672
Последний ответ 09.06.2015, 09:09:26
от jullizz
Фон текста в материале выделен стеклом за которым что то находится

Автор masfisha

Ответов: 3
Просмотров: 746
Последний ответ 20.03.2015, 13:19:18
от umbabaraumba
Как при регистрации сделать поле e-mail не обязательным к заполнению?

Автор Lann

Ответов: 22
Просмотров: 4681
Последний ответ 15.10.2013, 15:56:55
от twister2013