0 Пользователей и 1 Гость просматривают эту тему.
  • 20 Ответов
  • 30739 Просмотров
*

Leisan

  • Новичок
  • 16
  • 0 / 0
Ошибка Your host needs to use PHP 5.3.1
« : 17.10.2012, 15:10:39 »
После обновления не запускается, выходит ошибка "Your host needs to use PHP 5.3.1 or higher to run this version of Joomla!", скачала и заменила на  5.4.5 и тоже самое, не подскажете в чем причина?
*

Apoca1ypto

  • Давно я тут
  • 745
  • 71 / 0
Re: Ошибка Your host needs to use PHP 5.3.1
« Ответ #1 : 17.10.2012, 15:34:25 »
Вы запускали и обновляли на локалке?
Если да, то после обновления php перезагрузите сервер.
Во время спора в Интернете Ваш оппонент приводит неопровержимые доказательства своей точки зрения? Не отчаивайтесь. До...тесь до орфографии.
*

Leisan

  • Новичок
  • 16
  • 0 / 0
Re: Ошибка Your host needs to use PHP 5.3.1
« Ответ #2 : 17.10.2012, 15:44:15 »
Вы запускали и обновляли на локалке?
Если да, то после обновления php перезагрузите сервер.


да, на локалке, сайт только локальный.Пробовала перезагружать, не помагает..непонятно в чем дело(
*

Apoca1ypto

  • Давно я тут
  • 745
  • 71 / 0
Re: Ошибка Your host needs to use PHP 5.3.1
« Ответ #3 : 17.10.2012, 15:49:44 »
Если используется Denwer просто обновите его целиком - http://www.denwer.ru/
Во время спора в Интернете Ваш оппонент приводит неопровержимые доказательства своей точки зрения? Не отчаивайтесь. До...тесь до орфографии.
*

Leisan

  • Новичок
  • 16
  • 0 / 0
Re: Ошибка Your host needs to use PHP 5.3.1
« Ответ #4 : 17.10.2012, 15:56:31 »
Если используется Denwer просто обновите его целиком - http://www.denwer.ru/

нет, стоит apache (AppServ)
*

Apoca1ypto

  • Давно я тут
  • 745
  • 71 / 0
Re: Ошибка Your host needs to use PHP 5.3.1
« Ответ #6 : 17.10.2012, 16:01:00 »
Apache - это HTTP-сервер.
Denwer - это локальный сервер включающий Apache, PHP, MySQL, Perl и т.д., скачайте его по ссылке из поста чуть выше и установите.
Во время спора в Интернете Ваш оппонент приводит неопровержимые доказательства своей точки зрения? Не отчаивайтесь. До...тесь до орфографии.
*

Leisan

  • Новичок
  • 16
  • 0 / 0
Re: Ошибка Your host needs to use PHP 5.3.1
« Ответ #7 : 17.10.2012, 16:01:31 »
И какую он сейчас показывает версию PHP?
извините, а где посмотреть?
*

b2z

  • Глобальный модератор
  • 6961
  • 755 / 0
  • Разраблю понемногу
Re: Ошибка Your host needs to use PHP 5.3.1
« Ответ #8 : 17.10.2012, 16:02:45 »
Не мучайтесь. Установите Denwer, ссылка выше была дана. Ну или WAMP или XAMPP. AppServ не внушает доверия - последняя версия от 2010 года...
*

Leisan

  • Новичок
  • 16
  • 0 / 0
Re: Ошибка Your host needs to use PHP 5.3.1
« Ответ #9 : 17.10.2012, 16:03:09 »
Apache - это HTTP-сервер.
Denwer - это локальный сервер включающий Apache, PHP, MySQL, Perl и т.д., скачайте его по ссылке из поста чуть выше и установите.
ок, я в этом деле начинающий, извиняюсь..но точно не денвер ставила, а  AppServ2.5.10
*

umbabaraumba

  • Живу я здесь
  • 2415
  • 153 / 1
  • если помог можете поставить +
Re: Ошибка Your host needs to use PHP 5.3.1
« Ответ #10 : 17.10.2012, 16:04:54 »
Ставьте wamp .
Он лучше денвера .
Errare humanum est
Ubuntu по-русски
Пишу не сложные модули и компоненты, не дорого но не срочно
*

Leisan

  • Новичок
  • 16
  • 0 / 0
Re: Ошибка Your host needs to use PHP 5.3.1
« Ответ #11 : 17.10.2012, 16:05:24 »
Не мучайтесь. Установите Denwer, ссылка выше была дана. Ну или WAMP или XAMPP. AppServ не внушает доверия - последняя версия от 2010 года...
спасибо Вам за совет, попробую так)
*

Leisan

  • Новичок
  • 16
  • 0 / 0
Re: Ошибка Your host needs to use PHP 5.3.1
« Ответ #12 : 17.10.2012, 16:07:34 »
Ставьте wamp .
Он лучше денвера .
ок, спасибо)
*

zedzeal

  • Захожу иногда
  • 81
  • 0 / 0
Re: Ошибка Your host needs to use PHP 5.3.1
« Ответ #13 : 24.10.2012, 09:56:59 »
Хостинг VPS. Залил скрипт J3.0 на сервер. Выдает ошибку:
Цитировать
Your host needs to use PHP 5.3.1 or higher to run this version of Joomla!
Задал вопрос специалисту тех.поддержки хостинга. Саппорт говорит что "проапргейдиться" до 5.3.1 можно, но в этом случае у вас "могут возникнуть проблемы" с другими проектами на аккаунте.

Как быть? Переезжать на новый сервер?
*

b2z

  • Глобальный модератор
  • 6961
  • 755 / 0
  • Разраблю понемногу
Re: Ошибка Your host needs to use PHP 5.3.1
« Ответ #14 : 24.10.2012, 10:01:18 »
Хостинг VPS. Залил скрипт J3.0 на сервер. Выдает ошибку:Задал вопрос специалисту тех.поддержки хостинга. Саппорт говорит что "проапргейдиться" до 5.3.1 можно, но в этом случае у вас "могут возникнуть проблемы" с другими проектами на аккаунте.

Как быть? Переезжать на новый сервер?
Ну это же Вам решать. Если уверены, что другие проекты не "сломаются", то делайте апгрейд до 5.3.1. Если нет, то ищите хостинг с PHP 5.3+
*

zedzeal

  • Захожу иногда
  • 81
  • 0 / 0
Re: Ошибка Your host needs to use PHP 5.3.1
« Ответ #15 : 24.10.2012, 10:27:24 »
Цитировать
Ну это же Вам решать. Если уверены, что другие проекты не "сломаются", то делайте апгрейд до 5.3.1. Если нет, то ищите хостинг с PHP 5.3+

Саппорт утверждает что "сломаются". На аккуанте скрипты J1,5/2,5 и Wordpress 3x.

Не хочется заниматься переездом, хостинг устраивает. Наверное придется переезжать :( И это всего лишь из разногласий в версиях PHP.  :'(
*

b2z

  • Глобальный модератор
  • 6961
  • 755 / 0
  • Разраблю понемногу
Re: Ошибка Your host needs to use PHP 5.3.1
« Ответ #16 : 24.10.2012, 10:59:57 »
Если есть 1.5, то очень вероятно, что сломаются... Ну не переезжайте полностью, откройте только J3 проект на новом. А хостинг случайно не поддерживает несколько версий PHP? Такое в принципе возможно.
*

zedzeal

  • Захожу иногда
  • 81
  • 0 / 0
Re: Ошибка Your host needs to use PHP 5.3.1
« Ответ #17 : 24.10.2012, 11:21:07 »
Цитировать
Если есть 1.5, то очень вероятно, что сломаются... Ну не переезжайте полностью, откройте только J3 проект на новом. А хостинг случайно не поддерживает несколько версий PHP? Такое в принципе возможно.

Принял решение перевести проекты, планируемые к обновлению на новый хостинг. В данный момент используется VPS от Хостлайф. Полагаю есть хостинги с примерно такими же ценами, но с более высокой производительностью.

2b2z
Понимаю оффтоп, но посоветуйте в личку качественный хостинг для Joomla 3.0. Хочется VPS/VDS с hdd=>10GB, ISPmanager, не в РФ, с дружелюбным саппортом.
*

b2z

  • Глобальный модератор
  • 6961
  • 755 / 0
  • Разраблю понемногу
Re: Ошибка Your host needs to use PHP 5.3.1
« Ответ #18 : 24.10.2012, 11:28:25 »
Точно оффтоп + у меня совета по хостингам не спрашивайте. Я сам себе хостер... Совет дадут тут.
*

Apoca1ypto

  • Давно я тут
  • 745
  • 71 / 0
Re: Ошибка Your host needs to use PHP 5.3.1
« Ответ #19 : 24.10.2012, 14:00:26 »
Joomla 1.5 и WP 3 будут прекрасно работать на 5.3.1 и более поздних версиях.
Единственно, могут возникнуть проблемы с расширениями которые давно не обновлялись.
Во время спора в Интернете Ваш оппонент приводит неопровержимые доказательства своей точки зрения? Не отчаивайтесь. До...тесь до орфографии.
*

zedzeal

  • Захожу иногда
  • 81
  • 0 / 0
Re: Ошибка Your host needs to use PHP 5.3.1
« Ответ #20 : 24.10.2012, 15:54:26 »
Цитировать
Единственно, могут возникнуть проблемы с расширениями которые давно не обновлялись.

Как проверить совместимость расширений с PHP 5.3.1? Спрашивать у разработчиков расширения или вручную протестить на вампе?
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Ошибка: 0 - Using $this when not in object context

Автор Kadimp

Ответов: 39
Просмотров: 1803
Последний ответ 03.12.2018, 06:41:54
от kdn79
[РЕШЕНО] Ошибка 500 в менеджере материалов

Автор RUSchief

Ответов: 24
Просмотров: 792
Последний ответ 23.11.2018, 20:13:36
от dorffman
После установки Joomla 403 ошибка

Автор fireman

Ответов: 1
Просмотров: 186
Последний ответ 23.11.2018, 00:46:54
от voland
Ошибка 500 при добавлении ссылок или изображений в материал

Автор Sergey0606

Ответов: 4
Просмотров: 282
Последний ответ 15.11.2018, 16:00:28
от Sergey0606
Знатоки нужна помощь...Ошибка после перехода версии php

Автор polezniy

Ответов: 19
Просмотров: 817
Последний ответ 14.11.2018, 13:36:06
от Igor2