0 Пользователей и 1 Гость просматривают эту тему.
  • 60 Ответов
  • 14060 Просмотров
*

smart

  • Администратор
  • 6847
  • 1312 / 15
Локализацию можно вообще не обновлять, ибо никаких критичных изменений не было.
*

b2z

  • Support Team
  • 7512
  • 749 / 0
  • Разраблю понемногу
После обновления до 2.5.8 возникла проблема с формой авторизации.
При переходе на страницу с авторизацией выводится белая страница.

Включите отображения ошибок, чтобы понять, где грабли.
*

АНТИКЛАН

  • Новичок
  • 2
  • 0 / 0
Локализацию можно вообще не обновлять, ибо никаких критичных изменений не было.

Так все таки на вопрос ответьте пожалуйста...
*

maGeLan

  • Захожу иногда
  • 10
  • 0 / 0
Может мой опыт пригодится?

Результат моего столкновения. Поскольку я всегда тестирую все действия на виртуалке, а уж потом прикладываюсь к реальному сайту, то...
Из личного опыта, попробуйте обновиться через - Менеджер расширений: Установка, разумеется предварительно скачав сам пакет на комп.

Лично у меня все прокатило на трех живых сайтах без единой ошибки.
*

web3.0

  • Осваиваюсь на форуме
  • 156
  • 2 / 3
Включите отображения ошибок, чтобы понять, где грабли.
Включил отладку - проблема исчезла, форма авторизации появилась и функционирует правильно.
Но ошибки не выводятся. После отключения режима отладки - белая страница.
Что за дела? Кто сталкивался с подобным?
*

Go-destroy

  • Давно я тут
  • 222
  • 4 / 1
Может мой опыт пригодится?

Результат моего столкновения. Поскольку я всегда тестирую все действия на виртуалке, а уж потом прикладываюсь к реальному сайту, то...
Из личного опыта, попробуйте обновиться через - Менеджер расширений: Установка, разумеется предварительно скачав сам пакет на комп.

Лично у меня все прокатило на трех живых сайтах без единой ошибки.
Поддерживаю обновился так на двух!) все норм!
« Последнее редактирование: 29.03.2013, 02:51:15 от Go-destroy »
Рип шаблонов: 5 wmz
*

Guran

  • Давно я тут
  • 291
  • 22 / 0
Файл configuration.php надо вручную обновить. :-) Если не ошибаюсь, он у меня ещё с версии Joomla 1.5 оставался, и поэтому после обновления на версию 2.5.8 выскочила ошибка: "1054 - Unknown column 'alias' in 'where clause' SQL=SELECT id FROM ...._assets WHERE alias = 'root'  . Все прошлые обновления нормально проходили.
Взял из новой установки  configuration.php, вставил в него параметры сервера и поменял файл - ошибка исчезла.
*

smart

  • Администратор
  • 6847
  • 1312 / 15
Скажите пожалуйста. Если обновил локализацию с обсуждаемой ошибкой, нужно делать откат назад или достаточно еще раз обновить локализацию? Пожалуйста ответьте подробно не хочется иметь какой либо мусор на сайте от неправильной установки обновлений.
Никакого мусора не будет - что в первой версии языкового пакета, которая содержала небольшую ошибку, что в текущей - набор файлов один и тот же, и по количеству файлов ничем не отличается от пакета для 2.5.7. Поэтому никакой беды если вы обновитесь повторно не произойдет.
*

Эйнштейн

  • Новичок
  • 1
  • 0 / 0
После обновления до 2.5.8 возникла проблема с формой авторизации.
При переходе на страницу с авторизацией выводится белая страница.

Всем привет. Появилась похожая ситуация только на этот раз белая страница когда захожу в какой-нибудь материал. При этом если пробую зайти в материал сделанный через К2 то он открывается нормально. Кто может помочь?
*

pasha4ur

  • Осваиваюсь на форуме
  • 79
  • 0 / 1
Цитировать
Из личного опыта, попробуйте обновиться через - Менеджер расширений: Установка, разумеется предварительно скачав сам пакет на комп.
А какой файл качать, чтобы так Joomla обновить?

Я никогда еще так не обновлял саму Joomla :)
*

smart

  • Администратор
  • 6847
  • 1312 / 15
А какой файл качать, чтобы так Joomla обновить?
Хм, а почему бы поиском не воспользоваться-то? Для ленивых ссылка: Joomla_2.5.8-Stable-Update_Package.zip
*

pasha4ur

  • Осваиваюсь на форуме
  • 79
  • 0 / 1
Спасибо, но:
Цитировать
Обновить кэш манифеста не удалось: Расширение в настоящее время не установлено.
Обновить кэш манифеста не удалось: Расширение в настоящее время не установлено.

Установка файла успешно завершена.

Система управления сайтом Joomla! 2.5
Ошибка обновления кэша манифеста: (тип, элемент, директория, клиент) = (template, atomic, atomic, 0)
Ошибка обновления кэша манифеста: (тип, элемент, директория, клиент) = (template, beez_20, beez_20, 0)

Стандартные шаблоны у меня удалены.


Откатываться из бэкапа или оставить эту Joomla 2.5.8 и надеяться. что глюков не будет?

*

smart

  • Администратор
  • 6847
  • 1312 / 15
Ну если шаблоны удалены, то волноваться не о чем.
*

pasha4ur

  • Осваиваюсь на форуме
  • 79
  • 0 / 1
Понял. Спс.

Сегодня еще попробую язык обновить
*

studio204

  • Осваиваюсь на форуме
  • 26
  • 0 / 0
По советам англоязычных товарищей обновлялся через Akeeba Admin Tools. Никаких ошибок.
*

G-Vlad

  • Новичок
  • 6
  • 0 / 0
Помогите, кто нибудь. Никак не могу обновить Joomla 2.5.7 на 2.5.8 Пробовал обновит через обновления, и через менеджер установки. Выдаёт одну и туже ошибку " Unknown column 'alias' in 'where clause' SQL=SELECT id FROM s6ej4_assets WHERE alias = 'root'Ошибка базы данных с номером 1054 " Пробовал заменить конфигурационный файл, как советовали. Ошибка не исчезла. Если отключаю сайт, а затем захожу на него под админом, все страницы работают. Стоит включить сайт и выйти из него, получаю туже ошибку. И самое интересное пишет про базу бд, но когда я восстанавливаю только файлы сайта, сайт работает
« Последнее редактирование: 16.11.2012, 12:58:58 от smart »
*

djos

  • Осваиваюсь на форуме
  • 155
  • 0 / 0
  • http://shepetivka.com.ua
та же проблема
*

smart

  • Администратор
  • 6847
  • 1312 / 15
Хм, на буржуйском форуме подобная тема есть: JDatabaseMySQLi::query: 1054 - Unknown column 'alias', но решения пока не нашли. Я обновил до 2.5.8 порядка 15 сайтов, ни с одним такой проблемы не было. Все обновления устанавливал последовательно. Правда надо отметить, что на всех стандартный набор расширений.
*

G-Vlad

  • Новичок
  • 6
  • 0 / 0
Всё, думаю нашёл решение проблемы  :D. Надо чтобы сервер соответствовал рекомендуемым параметрам (это только касается моей ошибки yes!). Почему так решил, потому что на домашнем компе РНР 5.3; MySQL 5.1 и обновилось без проблем, и никаких ошибок. А на сервере у провайдера PHP 5.2.6; MySQL 5.0.26 Попросил их обновить сервер. Обновлюсь, отпишусь. Посмотрите у себя параметры на сервере. *DRINK*
« Последнее редактирование: 17.11.2012, 16:23:53 от G-Vlad »
*

djos

  • Осваиваюсь на форуме
  • 155
  • 0 / 0
  • http://shepetivka.com.ua
Дело точно не в сервере. И точно не в файле конфигурации.
Пройдитесь по таблице ohb3x_assets и убедитесь что parent_id = 0 только у рута....
*

G-Vlad

  • Новичок
  • 6
  • 0 / 0
Дело точно не в сервере. И точно не в файле конфигурации.
Пройдитесь по таблице ohb3x_assets и убедитесь что parent_id = 0 только у рута....

Да, точно дело не в сервере  :(, обновили, но ошибка не исчезла >:(. Пробежался по таблице, parent_id = 0 только у root.1 Сравнивал таблицу до обновления и после, изменений нет. Подскажите какой файл отвечает за таблицу assets, думаю надо копать его, потому что восстанавливая файлы из бэкапа (кроме базы MySQL), сайт начинает работать 
*

Takusik

  • Осваиваюсь на форуме
  • 45
  • 3 / 0
Помогите пжл разобраться хотя бы где искать проблему...

1. установила Joomla quickstart с шаблоном от официального разработчика
в администраторе пишет, что версия 2.5.7 (хотя, в другом шаблоне от этого же разработчика в пакете quickstart ставится 2.5.8  )
2. скачала joomla_2.5.8-stable_update_package.zip
3. через update не показывает, что есть новая версия
4. обновляю на 2.5.8 через менеджер расширений
очень долго думает. в статус-строке пишет "ожидает имясайта.ru"
И потом выдаёт 502 bad gateway.

Обратилась в службу поддержки хостинга. Они первым делом послали к разработчикам Joomla, типа это проблема в приложении, а не в сервере. Но после некоторого нажима с моей стороны всё-таки мне сказали, что можно проверить настройки сервера.
Попробовала установить всякие параметры типа время ожидания сервера, время выполнения скрипта и т.д. по максимуму. Не помогло.

В чём может быть дело? Где копать? Дело в сервере или где?
*

Takusik

  • Осваиваюсь на форуме
  • 45
  • 3 / 0
После долгих разбирательств выяснилось, в чём именно проблема. Попробую объяснить своими словами (не ругайтесь пжл громко, если что не так сказала).
Проблема на стороне хостинга. На моём хостинге и моём тарифе между клиентом и Apache (?) работают целых 2 nginx, один - это мой личный, а второй - это внешний, один для всех хостингов.
Так вот. Ошибку 502 bad gateway выдавал мой личный nginx. Дело было в таймауте выполнения скриптов. Те настройки, которые я могла задать через панель управления хостингом не спасали (там максимум 3 минуты). В службе поддержки мне увеличили эти лимиты, и ошибка пропала.
Но появилась другая: 413 Request Entity Too Large. Стали разбираться дальше. Дошли до того, что вообще отключили мой личный nginx. И получилось, что эту ошибку выдаёт внешний nginx. А настроить его на моём тарифе нельзя.
Выход: или переходить на другой тариф или... Обновить сайт на локальном компьютере, что я и сделала практически без проблем.
Правда, при первой попытке выдалось "Невозможно загрузить файл на сервер". Покопалась в инете (или здесь, уже не помню) и нашла, что нужно изменить параметр в php.ini: upload_max_filesize = 100М (было 2М). После этого всё загрузилось и обновилось.

Вот теперь думаю. Может быть, нужно было этот же параметр изменить для моего php на хостинге? Там было 32М. А ошибка 413 Request Entity Too Large как-то не намекает на этот параметр. И в службе поддержки явно сказали, что эту ошибку выдаёт внешний nginx. Поэтому, может это и не помогло бы.

Но пробовать не буду. После таких танцев экспериментировать с хостингом уже не хочу. Рассказала это просто для других, если у кого те же проблемы будут.
*

shweew

  • Осваиваюсь на форуме
  • 36
  • 0 / 0
Пробовал обновить 2.5.6 через обновления, пишет что новее нет, через менеджер установки тоже не пошло.
Тупо распаковал Joomla_2.5.8-Stable-Update_Package.zip с заменой и в менеджере расширений: Проверка базы данных нажал "Исправить", т.к. матюкалось на несоответствие чего то там.
Вроде всё работает.

Можно так делать или чревато ошибками?
*

voland

  • Профи
  • 9871
  • 536 / 105
  • Эта строка съедает место на вашем мониторе
*

Go-destroy

  • Давно я тут
  • 222
  • 4 / 1
Пробовал обновить 2.5.6 через обновления, пишет что новее нет, через менеджер установки тоже не пошло.
Тупо распаковал Joomla_2.5.8-Stable-Update_Package.zip с заменой и в менеджере расширений: Проверка базы данных нажал "Исправить", т.к. матюкалось на несоответствие чего то там.
Вроде всё работает.

Можно так делать или чревато ошибками?
Попробуй обновиться через установку расширений.
Рип шаблонов: 5 wmz
*

Zhendosss

  • Захожу иногда
  • 11
  • 0 / 0
Я так обновлял: щелкаем правой кнопкой мыши на файл configuration.php снимаем галочку "только чтение", обновляемся, ставим галку обратно.
*

Bright

  • Осваиваюсь на форуме
  • 174
  • 2 / 2
Я так обновлял: щелкаем правой кнопкой мыши на файл configuration.php снимаем галочку "только чтение", обновляемся, ставим галку обратно.
У меня и не стояло "только чтение", но уже не первое обновление версии Joomla проходит так:
Обновить кэш манифеста не удалось: Расширение в настоящее время не установлено.
Это сообщение 8 (восемь!) раз,
но далее "Ваш сайт был успешно обновлен. Версия Joomla 2.5.14. ".
И ниже: "Joomla! 2.5.14 Stable [ Ember ] 01-August-2013 14:00 GMT"

После этого обновил 2 расширения (русский язык и G-комментс) - оба прошли без ошибок, а обновление Joomla уже несколько версий подряд... см. выше.

Нашел несколько веток по этому вопросу, проблема тянется давно - неужели до сих пор нет решения?
*

zikkuratvk

  • Профи
  • 4224
  • 286 / 2
  • Разрабатываем для Joomla
Bright такие вещи обычно лечатся через ремонт базы:
Заходите в менеджер расширений => база данных => кнопка исправить.
Хочется уникальное расширение? ===>>>> JoomLine - Разрабатываем расширения под заказ.
Использую хостинг TimeWeb и Reg
*

Bright

  • Осваиваюсь на форуме
  • 174
  • 2 / 2
Заходите в менеджер расширений => база данных => кнопка исправить.
Вот спасибо! +1
Заглянул, а там...
Цитировать
Внимание: База данных устарела!
Обнаружено 25 ошибок базы данных
Вроде исправил, бум посмотреть что будет дальше.
« Последнее редактирование: 04.08.2013, 22:03:51 от Bright »
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

ошибка после обновления c Joomla 2.5 до 3

Автор akondr

Ответов: 0
Просмотров: 99
Последний ответ 21.11.2017, 16:20:49
от akondr
Сайт на Joomla 2.5 взломан.

Автор Likur

Ответов: 14
Просмотров: 529
Последний ответ 21.08.2017, 21:49:28
от ProtectYourSite
Не обновляется Joomla 2.5.28

Автор SPMBes

Ответов: 45
Просмотров: 1610
Последний ответ 02.08.2017, 13:11:34
от lexxbry
Установка Joomla 2.5.28

Автор Alazi

Ответов: 3
Просмотров: 360
Последний ответ 17.05.2017, 14:10:22
от SeBun
Joomla 2.5 нужна помощь

Автор bog

Ответов: 1
Просмотров: 542
Последний ответ 31.03.2017, 15:19:12
от voland