Новости Joomla

Вышли релизы безопасности Joomla 6.1.3 и Joomla 5.4.8

Релиз безопасности Joomla 6.1.3 и Joomla 5.4.8

Проект Joomla! рад сообщить о выходе Joomla 6.1.3 и Joomla 5.4.8. Это релизы безопасности и исправления ошибок для серий 5.x и 6.x.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

Joomla 5+ пакет для интеграции с API Почты России: нормализация данных, расчёт доставки, создание отправлений, партии, документы, возвраты, поиск отделений, справочники и SOAP-отслеживание.

v.3.0.0. Что нового?
Это дальнейшее развитие ранее закрытой Joomla-библиотеки для работы с API сервиса Отправка (для бизнеса) Почты России. Поэтому версия не 1.0.0, а 3.0.0.

Сейчас эта библиотека ушла от собственных реализаций и стала Joomla-обёрткой известного PHP SDK от Lapay Group.

Возможности библиотеки.
- получение настроек аккаунта, точек сдачи и текущего остатка запросов к API;
- нормализация адресов, ФИО и телефонов перед созданием отправления;
- расчёт тарифа и срока доставки;
- создание, поиск, изменение, удаление и возврат заказов в состояние «Новые»;
- проверка надёжности получателя;
- создание партий, просмотр партий и заказов внутри партии;
- генерация пакета печатных документов и формы Ф103;
- создание, изменение и удаление возвратных отправлений;
- поиск отделений по индексу, адресу и координатам, получение сервисов отделения;
- локальный список стран;
- SOAP-отслеживание операций по РПО и работа с билетами пакетного трекинга.

👩‍💻 Joomla-возможности.
В пакете библиотеки WT Otpravkapochtaru есть поля Joomla Form для расширений. Они позволяют работать в интерфейсе Joomla с некоторыми типами данных, получаемых по API из вашего личного кабинета в ЛК Почты России для бизнеса.
На данный момент в библиотеке доступны 3 поля списков, которые отображают доступные в аккаунте ОПС, типы и категории отправлений.
Поддерживаются зависимые списки: значение одного поля обновляется при изменении другого.

Системные требования.
Системные требования в основном связаны с системными требованиями апстрима библиотеки - LapayGroup PHP SDK.
- Joomla 5+
- PHP 8.3+
- Расширения PHP:
-- ext-mbstring
-- ext-simplexml
-- ext-soap (опционально, для трекинга)
-- ext-zip

Ссылки:
- Страница расширения
- GitHub библиотеки и документация

@joomlafeed

0 Пользователей и 1 Гость просматривают эту тему.
  • 1 Ответов
  • 1240 Просмотров
*

skarabey

  • Новичок
  • 9
  • 0 / 0
Fatal error: Unable to load smilies.\nDB
« : 17.11.2012, 16:17:34 »
Здравствуйте, сайт на Joomla 1.5 когда залогиневаешься стал выдавать ошибку: Fatal error: Unable to load smilies.\nDB function failed with error number 2006
MySQL server has gone away SQL=SELECT VERSION() AS mysql_version
Полный текст
Спойлер
[свернуть]
Отписался в службу поддержки они сказали что у них все в порядке только автоматически обновляется версия MySQL.
Сам я тоже ничего на сайте не обновлял. Еще в четверг все работало, - в пятнице зашел и уже залогинится не могу. В админку нормально могу зайти, но ужастно тормозить стало. Ни один форум теперь не работает Kunena, fireboard...
Подскажите что можно сделать.
Системная информация
Спойлер
[свернуть]
*

rusak

  • Захожу иногда
  • 76
  • 4 / 0
Re: Fatal error: Unable to load smilies.\nDB
« Ответ #1 : 17.11.2012, 16:32:44 »
Installed version: Kunena 1.5.3 | UNKNOWN | 0000 [ NOT INSTALLED ] | php 5.2.17 | MySQL unknown
Говорит что неизвестна MySQL и у вам в тех потдержке сказали что MySQL обновляли. Может версию Kunena попробовать обновить? Или попросить хостера вернуть MySQL на старую версию.
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Не могу распаковать jpa архив сайта Akeeba backup. ajax error

Автор smadkz

Ответов: 4
Просмотров: 15425
Последний ответ 26.12.2020, 15:15:15
от stendapuss
Fatal error: Class 'JDocument' not found

Автор gabiboi

Ответов: 2
Просмотров: 4389
Последний ответ 04.09.2020, 14:39:07
от svetka_777
simpleform2 ошибка ajax error в Google chrome

Автор safronoff343

Ответов: 1
Просмотров: 4914
Последний ответ 05.06.2020, 20:36:42
от safronoff343
Ошибка Fatal error: Allowed memory size of 73400320 bytes exhausted

Автор Andre109

Ответов: 1
Просмотров: 4322
Последний ответ 03.12.2018, 01:29:56
от voland
Ошибка 500 Internal Server Error. Что это такое и как это решить

Автор sargiusz

Ответов: 4
Просмотров: 6682
Последний ответ 20.03.2017, 14:30:33
от flyingspook