0 Пользователей и 1 Гость просматривают эту тему.
  • 342 Ответов
  • 156648 Просмотров
*

vel232

  • Новичок
  • 7
  • 0 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #150 : 09.11.2009, 21:05:10 »
Здравствуйте!
Прошу помощи! Поставил Joomla 1.5.14, настроил, все работает на локальном сервере.
Установил новый шаблон. Все работает. Закачал на сервер, и началось: именно с этим шаблоном весь русский текст отображается кракозябрами. Ставлю по умолчанию другой шаблон - все хорошо. Всю голову сломал. Пожалуйста, помогите. Файл .htaccess поправил, но ничего не дало.
*

vital_s1

  • Захожу иногда
  • 267
  • 26 / 0
  • Joomla магия
Re: Проблемы с кодировкой в 1.5
« Ответ #151 : 09.11.2009, 21:49:38 »
надо смотреть, что тут скажешь .... киньте ссылку, приведите .htaccess, какой хостер .... для начала.
может что и будет видно по первым симптомам -)) нет так нужно будет уже  по глубже анализировать проблему.
Не бойся спрашивать, без этого ни как! -)
*

vel232

  • Новичок
  • 7
  • 0 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #152 : 09.11.2009, 22:00:12 »
.htaccess вписал строчку AddDefaultCharset UTF-8 и все. Я правильно понимаю, файл  .htaccess находится в корне сайта?
Я думаю проблема в шаблоне, но какая никак понять не могу.

Хостинг Версия сервера: 5.1.36-log
Версия протокола: 10
Сервер: altigen.mysql via TCP/IP
Пользователь: altigen_mysql@194.85.89.4
MySQL-кодировка: UTF-8 Unicode (utf8)
Версия MySQL-клиента: 5.1.16-beta
Используется расширение PHP: mysql

 
*

vital_s1

  • Захожу иногда
  • 267
  • 26 / 0
  • Joomla магия
Re: Проблемы с кодировкой в 1.5
« Ответ #153 : 09.11.2009, 22:03:15 »
.htaccess вписал строчку AddDefaultCharset UTF-8 и все. Я правильно понимаю, файл  .htaccess находится в корне сайта?
нет в корне самого хостинга, т.е. в корне самой Joomla !
поправлюсь ...  не в корне самого шаблона!
Не бойся спрашивать, без этого ни как! -)
*

vital_s1

  • Захожу иногда
  • 267
  • 26 / 0
  • Joomla магия
Re: Проблемы с кодировкой в 1.5
« Ответ #154 : 09.11.2009, 22:07:21 »
посмотрите такие строчки в файле .htaccess ?
Код
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !^/index.php
RewriteCond %{REQUEST_URI} (/|\.php|\.html|\.htm|\.feed|\.pdf|\.raw|/[^.]*)$  [NC]
RewriteRule (.*) index.php
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
AddDefaultCharset utf-8
модуль mod_rewrite включен?
Не бойся спрашивать, без этого ни как! -)
*

vel232

  • Новичок
  • 7
  • 0 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #155 : 09.11.2009, 22:14:34 »
да, все так
*

vel232

  • Новичок
  • 7
  • 0 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #156 : 09.11.2009, 22:20:00 »
Модуль ReWrite включен
*

vital_s1

  • Захожу иногда
  • 267
  • 26 / 0
  • Joomla магия
Re: Проблемы с кодировкой в 1.5
« Ответ #157 : 09.11.2009, 22:23:49 »
на одном из сайтов мне помог вот такой метод:
к стандартным строчкам добавлены такие:
конечно не все нужны для исправления кодировки но именно так и работает -)
Код
AddDefaultCharset utf-8
CharsetSourceEnc utf-8
RewriteEngine On
RewriteCond %{HTTP_HOST} ^mysite\.ru
RewriteRule ^(.*)$ http://www.mysite.ru/$1 [R=permanent,L]
Не бойся спрашивать, без этого ни как! -)
*

vel232

  • Новичок
  • 7
  • 0 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #158 : 09.11.2009, 22:35:00 »
пробовал,когда другие строчки прописываю, то сайт слетает  :(
*

vital_s1

  • Захожу иногда
  • 267
  • 26 / 0
  • Joomla магия
Re: Проблемы с кодировкой в 1.5
« Ответ #159 : 09.11.2009, 22:54:08 »
Единственное, что могу сказать, по итогам всей темы, - изложено практически все что возможно, и если методы описанные в теме не помогают, прокачивайте вопрос у хостера!!

P.S. для тех кто читает темы с конца.
Если вы все испробовали и не помогло ни чего, то см. выше! В данном посте есть все что может помочь. По моему даже новый вопрос уже нельзя придумать, на все есть ответы.

Так что читайте все сообщения.
« Последнее редактирование: 09.11.2009, 22:57:58 от vital_s1 »
Не бойся спрашивать, без этого ни как! -)
*

vital_s1

  • Захожу иногда
  • 267
  • 26 / 0
  • Joomla магия
Re: Проблемы с кодировкой в 1.5
« Ответ #160 : 10.11.2009, 01:04:57 »
vital_s1:

помучьте его подольше - покопайтесь в его шаблоне :-)
мне кажется овчинка выделки стоит - что-то с его шаблоном не в порядке

думаете вот это? .... ну я думаю, тут все нормально  -))  ссылку так ведь и не дали посмотреть!
Код
<?xml version="1.0" encoding="utf-8"?>


Не бойся спрашивать, без этого ни как! -)
*

AlexSmirnov

  • Завсегдатай
  • 1862
  • 272 / 16
  • Ищите и найдете
Re: Проблемы с кодировкой в 1.5
« Ответ #161 : 10.11.2009, 02:24:05 »
загляните напоследок наверх его шаблоновского index.php, а именно в эту часть:

<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="<?php echo $this->language; ?>" lang="<?php echo $this->language; ?>" >

не прописан ли там вместо этого английский по умолчанию? типа xml:lang="en" lang="en"
# Back the fufalo (особенно ту самую столкершу)! #
# ВАЖНО! Кайфую от удаления присланного в личку спама, почти как от любви (особенно по выходным). #

Re: Проблемы с кодировкой в 1.5
« Ответ #162 : 14.11.2009, 22:57:36 »
Попробовал установить joomlu на сайт mygoodwork.ru Что получилось можно посмотреть. Что делать, как быть? Буду признателен если поможете.
*

vital_s1

  • Захожу иногда
  • 267
  • 26 / 0
  • Joomla магия
Re: Проблемы с кодировкой в 1.5
« Ответ #163 : 14.11.2009, 23:10:58 »
Читали ли вы тему полностью?
Что еще сделано вами  кроме установки Joomla ?
Не бойся спрашивать, без этого ни как! -)
*

Energetik

  • Осваиваюсь на форуме
  • 48
  • 0 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #164 : 26.11.2009, 17:11:58 »
Прочитал всю тему, вопрос про кодировку интересный... На локалке кеш не врубаем будут крякозябры 100% и всякие серверные штуки тоже нафиг надо, только на хостинге этим занимаемся. У меня все работает итак (без строчек в htaccess, без конверта конфинга), даже phpmailer работает без кряков)  (но все равно сделал как советовали в faq)

Самое главное перед установкой создать базу, установить для нее кодировку (!) (или проверить при создании правильная ли кодировка) и сопоставить с мускулом в нужной кодировке, все это можно сделать в phpmyadmin, после установки проследить что все таблице создаются в нужной кодировке, если нет перекодировать и дать по шапке хостеру.

В большинстве случаев с кодировкой виноват криворукий хостер.

У меня только один вопрос про кодировку сервера, нужно ли ее ставить? Чем это может помочь? (ну там может есть сервисы которые по кодировке сервера определяют кодировку и тп) И чем может навредить? Ведь поставив для сервера utf если там есть файлы другой кодировки то кердык им, а если как в случае с Joomla ANSI ? Кстати я вобще не понимаю перевели Движок на utf8 а файлы не конвертировали... (как к примеру wordpress)

P.S. более конкретный вопрос, нужно ли проставлять кодировку сервера когда все работает итак (а может что-то и не так хз я ж параноик =))) )?
*

vital_s1

  • Захожу иногда
  • 267
  • 26 / 0
  • Joomla магия
Re: Проблемы с кодировкой в 1.5
« Ответ #165 : 26.11.2009, 17:25:18 »
Кодировку нужно выставлять только для конкретного сайта! Сервер потому сервером и зовется, что на нем можно для разных приложений и проектов сделать индивидуальные настройки. Нельзя все унифицировать.
Не бойся спрашивать, без этого ни как! -)
*

Energetik

  • Осваиваюсь на форуме
  • 48
  • 0 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #166 : 26.11.2009, 17:30:59 »
Ну я и имею виду понятие узкое в плане сайта... то есть не meta тег а htaccess
*

Echo

  • Новичок
  • 22
  • 0 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #167 : 28.11.2009, 01:54:49 »
Спасибо!! Работает!! Только я не вставлял в код <?php include "date.php" ?> - это вобще зачем?
*

7Rei

  • Захожу иногда
  • 134
  • 20 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #168 : 03.12.2009, 14:26:43 »
Добрый день.
Переношу сайт на J!1.5 с хостинга на mysql 5, на хостинг с MySQL 4.0.26-log и phpMyAdmin 2.5.4.
После переноса базы, весь текст на русском пошел закарючками :(
Как выяснил, у базы кодировка cp1251.

При этом у данной версии phpMyAdmin нету возможности сменить кодировку бд на utf8 "вручную".
С помощью какой команды это можно сделать?

Спасибо.

Re: Проблемы с кодировкой в 1.5
« Ответ #169 : 03.12.2009, 17:22:37 »
Здравствуйте. Во время новой установки Joomla 1.5.14 на сервер valuehost все русские буквы отображаются закорючками. Вот данные по PHP и MySQL:
PHP 5.2.0
mysql Ver 14.12 Distrib 5.0.27
Как было посоветовано выше в настройках сервера изменил значения "Кодировка по умолчанию, в которой будут открываться страницы посетителей сайта." и "Кодировка, в которой хранятся файлы на диске ftp-сервера." на "disabled". Не помогло.
*

vital_s1

  • Захожу иногда
  • 267
  • 26 / 0
  • Joomla магия
Re: Проблемы с кодировкой в 1.5
« Ответ #170 : 03.12.2009, 17:36:49 »
На этой же странице я описывал, что нужно вставить в файл .htaccess ...... пробовали?
Все рецепты из темы испробованы, если да то как и что делали?
Не бойся спрашивать, без этого ни как! -)
*

7Rei

  • Захожу иногда
  • 134
  • 20 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #171 : 03.12.2009, 18:41:04 »
На этой же странице я описывал, что нужно вставить в файл .htaccess ...... пробовали?
Все рецепты из темы испробованы, если да то как и что делали?
Да, спасибо, "CharsetSourceEnc utf-8" помогло.
ТОлько ничего страшного, если в системной информации написано: "Сравнение БД:cp1251_general_ci"?
*

vital_s1

  • Захожу иногда
  • 267
  • 26 / 0
  • Joomla магия
Re: Проблемы с кодировкой в 1.5
« Ответ #172 : 03.12.2009, 22:08:32 »
ну я бы все равно сделал по правильному -))) добивай хостера, пусть доступ дает.
Не бойся спрашивать, без этого ни как! -)
*

7Rei

  • Захожу иногда
  • 134
  • 20 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #173 : 06.12.2009, 22:11:48 »
ну я бы все равно сделал по правильному -))) добивай хостера, пусть доступ дает.
Хостер оказался очень даже дружелюбным и перенес меня на mysql 5.1.38.
Правда phpMyAdmin остался 2.5.4, и в нем нет кнопки переключить кодировку сравнения (
Каким запросом, это можно сделать вручную?
*

evlebedev

  • Захожу иногда
  • 56
  • 3 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #174 : 06.12.2009, 23:03:28 »
Примерно так:
 «Сравнение»(кодирование) для базы (MyBase) в utf8_general_ci
ALTER DATABASE `MyBase` DEFAULT CHARACTER SET utf8 COLLATE utf8_general_ci;
«Сравнение»(кодирование) для таблицы (MyTable):
ALTER TABLE `MyTable` DEFAULT CHARACTER SET utf8 COLLATE utf8_general_ci;
 «Сравнение»(кодирование) для каждого поля (Field1):
ALTER TABLE `MyTable` CHANGE `Field1` `Field1` CHAR(20) CHARACTER SET utf8 COLLATE utf8_general_ci NOT NULL;
ALTER TABLE `MyTable` CHANGE `Field2` `Field2` CHAR(10) CHARACTER SET utf8 COLLATE utf8_general_ci NOT NULL;
На всякий случай Бекап не забудьте!
*

7Rei

  • Захожу иногда
  • 134
  • 20 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #175 : 06.12.2009, 23:58:15 »
Сделал так:
ALTER DATABASE `база` DEFAULT CHARACTER SET utf8 COLLATE utf8_general_ci;
Запрос выполнен успешно, но в админке все равно осталось "Сравнение БД: cp1251_general_ci" :(
*

Marksheider

  • Новичок
  • 12
  • 0 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #176 : 07.12.2009, 11:14:21 »
абсолютно всегда, когда компонент при установке выдает караказябры, иду в папку language, ищу файл ini который относится к этому компоненту, пересохраняю в UTF-8, перезаливаю на сервер и все становится прекрасно:) все на русском...
*

evlebedev

  • Захожу иногда
  • 56
  • 3 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #177 : 07.12.2009, 18:45:21 »
Сделал так:
ALTER DATABASE `база` DEFAULT CHARACTER SET utf8 COLLATE utf8_general_ci;
Запрос выполнен успешно, но в админке все равно осталось "Сравнение БД: cp1251_general_ci" :(
Дык все выше приведенные запросы выполнили?
А то БД будет utf8, а таблицы cp1251.
А то может быть что и БД и таблицы utf8, а текстовые колонки cp1251
*

7Rei

  • Захожу иногда
  • 134
  • 20 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #178 : 08.12.2009, 21:28:48 »
Дык все выше приведенные запросы выполнили?
А то БД будет utf8, а таблицы cp1251.
А то может быть что и БД и таблицы utf8, а текстовые колонки cp1251
нет, только строчку с БД.

ALTER DATABASE `MyBase` DEFAULT CHARACTER SET utf8 COLLATE utf8_general_ci;
ALTER TABLE `MyTable` DEFAULT CHARACTER SET utf8 COLLATE utf8_general_ci;
ALTER TABLE `MyTable` CHANGE `Field1` `Field1` CHAR(20) CHARACTER SET utf8 COLLATE utf8_general_ci NOT NULL;
ALTER TABLE `MyTable` CHANGE `Field2` `Field2` CHAR(10) CHARACTER SET utf8 COLLATE utf8_general_ci NOT NULL;
Вместо MyTable, свои таблицы нужно прописывать?
*

romans13

  • Захожу иногда
  • 122
  • 4 / 0
  • Присоединяюсь к вышеВЫсказанному
Re: Проблемы с кодировкой в 1.5
« Ответ #179 : 09.12.2009, 14:22:26 »
перечитал ветку, ночь не спал, сидел мучился кодировками, заливками всякими. У меня ошибки вылезали всякие и кодировка гадкая. Исправилось после сохрания config в UTF-8   и простановки на все папки и файлы КЭША - 777 !
может кому пригодиться
Мучаю SEYRET , 404SEF и CB на родненьком www.tamadenok.ru

А времени все нет и уже не хочется...
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Проблемы после переноса с хостинга на денвер

Автор qweqweqwe

Ответов: 6
Просмотров: 2506
Последний ответ 17.07.2014, 09:28:38
от AlekVolsk
Частичная проблема с кодировкой после переноса на новый хостинг

Автор Lem625

Ответов: 0
Просмотров: 1026
Последний ответ 01.07.2014, 12:42:44
от Lem625
Проблемы с загрузкой файлов в RS MediaGallery

Автор AnastaSea

Ответов: 0
Просмотров: 1111
Последний ответ 12.02.2014, 13:07:14
от AnastaSea
Требуется помощь, проблемы с доступом на сайт после установки на хостинг

Автор lekraft

Ответов: 1
Просмотров: 847
Последний ответ 22.10.2013, 10:53:11
от lekraft
Проблемы с Joomla 1,5,22 и PHP 5,3,3....

Автор Spics

Ответов: 10
Просмотров: 7880
Последний ответ 27.12.2012, 12:02:00
от gluck1966