0 Пользователей и 1 Гость просматривают эту тему.
  • 342 Ответов
  • 157169 Просмотров
*

evlebedev

  • Захожу иногда
  • 56
  • 3 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #180 : 09.12.2009, 20:29:53 »
нет, только строчку с БД.
Вместо MyTable, свои таблицы нужно прописывать?
Да вместо MyTable свои таблицы, вместо Field1 свои поля (столбцы)
*

el_principo

  • Новичок
  • 3
  • 1 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #181 : 22.12.2009, 09:59:45 »
cлучайно обнаружил что сайт плохо отображается в разных браузерах, в Опере все нормально ,а в ИИ и Мозилле вот это: С?РѕСѓ-бизнес,политика,СЃРїРѕСЂС  ,до этого была проблема кодировки и кэширования ,3 недели мучился ,решил ,думал на этом все.
База в UTF-8,может стоит переделать её в windows-1251?
*

evlebedev

  • Захожу иногда
  • 56
  • 3 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #182 : 28.12.2009, 18:08:49 »
в windows-1251 точно не стоит. У вас определенно в настройках апача дефолтная кодировка  windows-1251 изменяйте в UTF-8.
Не получается самому - терроризируйте хостера
*

el_principo

  • Новичок
  • 3
  • 1 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #183 : 04.01.2010, 14:40:55 »
evlebedev
Спасибо за совет, помучил хостера вопросами, вроде все устранилось, надеюсь навсегда.
*

rx7

  • Осваиваюсь на форуме
  • 40
  • 1 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #184 : 04.01.2010, 16:58:30 »
Попробуйте отключить в менеджере плагинов System - Cache, скорее всего в большинстве случаев из-за него вся нервотрепка с кодировкой. счастье есть - его не может не быть )   *DRINK*
*

evlebedev

  • Захожу иногда
  • 56
  • 3 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #185 : 07.01.2010, 10:30:32 »
Проблемы с систем кеш у меня решились добавлением файла .htaccess с единственной строчкой AddDefaultCharset utf-8
в папку cache
*

el_principo

  • Новичок
  • 3
  • 1 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #186 : 09.01.2010, 09:03:38 »
мне помогло вот это:(цитирую ответ хостера)

Панель управления хостингом - Веб-сервер - Управление модулями - PHP x.x.x -
Перейти к настройкам модуля PHP - Кодировка по-умолчанию - измените на UTF-8
*

AlexAl

  • Захожу иногда
  • 309
  • 13 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #187 : 09.01.2010, 16:19:16 »
Та же проблема что у многих, при включении кеша, сайт в лисе показывает каждую страницу нормально только один раз, после этого отображает кракозябры.

При отключенном плагине System Cache или в другом браузере работает нормально. Нужен ли вообще этот плагин? Если да, то какие есть решения?

Кто нашел на этот вопрос решения? Заранее спасибо.

Joomla 1.5.12 VM 1.1.3
*

katrey

  • Захожу иногда
  • 102
  • 6 / 1
Re: Проблемы с кодировкой в 1.5
« Ответ #188 : 15.01.2010, 22:49:32 »
Доброго времени суток. Помогите, пожалуйста, разрулить проблему с кодировками. Разработал сайт на последнем Денвере, экспортировал дамп базы и перекодировал его в utf-8 без bom и залил в базу на сервер. Файлы перекинул, загрузил главную, и не поверил глазам - всё выглядит также как и на локале. Но ликовал я недолго... Начал проверять функционал сайта и столкнулся с такой проблемой. Я вношу данные в базу через сторонние формы страниц, загруженных в wrapperе. После первого внесения данных - в базе кракозябры :( Я проверил кодировку страницы с формой - ACII. Я уже было обрадовался, поменял кодировку страницы на utf-8 без bom и повторил внесение данных... В базе опять кракозябры, только они немного отличаются от первых :( Менял кодировку в браузере - буквами кракозябры не становятся.

Вопрос: какая должна быть кодировка страницы с формой, чтобы в базу внеслись нормальные данные?
Спасибо.
*

evlebedev

  • Захожу иногда
  • 56
  • 3 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #189 : 16.01.2010, 00:06:26 »
База, таблицы и колонки таблиц в utf-8?
Кодировка страниц (php скриптов?) с формой явно должна быть такой же utf-8.
А ежели всместо "вношу данные в базу через сторонние формы страниц, загруженных в wrapperе" воспользоваться для создания формы компонентом фабрик http://joomlaforum.ru/index.php/board,269.0.html например?
*

katrey

  • Захожу иногда
  • 102
  • 6 / 1
Re: Проблемы с кодировкой в 1.5
« Ответ #190 : 16.01.2010, 02:04:09 »
Скрипты точно в UTF-8. Пробовал с БУМом и без. Результат один и тот же: Ð�азвание - Это слово "Название" так выглядит после добавления в базу. Когда были в ANSI - Íàçâàíèå. Испробовал конвертацию в Unix и Mac-форматы - результат тот же...
Может действительно у меня база на хостинге не в UTF-8? У меня на денвере база была в ANSI UNIX, я переконвертировал её дамп в Notepad++ в UTF-8 без Bom (ANSI as UTF-8) UNIX.
В столбцах (полях) стоит сравнение utf8_general_ci.

В дампе после каждой таблицы стоит:
ENGINE=MyISAM AUTO_INCREMENT=5 DEFAULT CHARSET=utf8 AUTO_INCREMENT=5 ;


Где я могу посмотреть в какой кодировке база и таблицы? Может сама база не в UTF-8? Пересоздать базу не могу - её создаёт хостер. Может есть способ изменить кодировку базы, не удаляя её?

Провел такой эксперимент: скрипт с формой в UTF-8 - добавляю в базу через форму: "Добавить - книгу". В базе - Добавить - книгу. Но если эти кракозябры вытащить на НЕджумловскую страницу в UTF-8, то получится - "Добавить - книгу".
Блин, чувствую, что я уже где-то близко, тока своих мозгов пока не хватает  crazy!

[вложение удалено Администратором]
« Последнее редактирование: 16.01.2010, 14:28:57 от katrey »
*

evlebedev

  • Захожу иногда
  • 56
  • 3 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #191 : 18.01.2010, 20:56:31 »
О том как изменить кодировку базы я писал в этом же топике на 6 странице.
И еще посмотрите модуль iconv в Php включен?
« Последнее редактирование: 18.01.2010, 21:00:00 от evlebedev »
*

katrey

  • Захожу иногда
  • 102
  • 6 / 1
Re: Проблемы с кодировкой в 1.5
« Ответ #192 : 18.01.2010, 21:28:42 »
Проблему решил, но к сожалению не таким путём как хотел - сменил хостера...
*

Justgosu

  • Осваиваюсь на форуме
  • 45
  • 0 / 0
  • Learning PHP
Re: Проблемы с кодировкой в 1.5
« Ответ #193 : 01.02.2010, 01:08:35 »
У меня проблема пропала когда я кодировку файла index.php шаблона сменил на UTF-8(без BOM), даже в Комюнити Билдере начала правильно отображатся.(хотя до этого отображалась везде нормально кроме КомунитиБилдера и регистрации)

Re: Проблемы с кодировкой в 1.5
« Ответ #194 : 04.02.2010, 16:38:57 »
Народ всем привет! Перелопатил кучу форумов, что только не перепробовал ничего не помогает, проблема такая:
модуль регистрации не корректно отображает русский язык, причем меняю название модуля, через админ панель Joomla, все нормально, а для того чтобы поменять название полей Username и Password на Логин и Пароль я изменил этот текст в файле default.php который лежал в папке самого модуля. В итоге получаются вопросики вместо текста. Помогите пожалуйста, если можно пошагово объясните потому что я начинающий в этом деле. ! ! !
*

katrey

  • Захожу иногда
  • 102
  • 6 / 1
Re: Проблемы с кодировкой в 1.5
« Ответ #195 : 04.02.2010, 22:12:38 »
Попробуй загрузить сайт на другой хостинг, и посмотри что получится.
*

AlexSmirnov

  • Завсегдатай
  • 1862
  • 272 / 16
  • Ищите и найдете
Re: Проблемы с кодировкой в 1.5
« Ответ #196 : 06.02.2010, 18:55:55 »
Народ всем привет! Перелопатил кучу форумов, что только не перепробовал ничего не помогает, проблема такая:
модуль регистрации не корректно отображает русский язык, причем меняю название модуля, через админ панель Joomla, все нормально, а для того чтобы поменять название полей Username и Password на Логин и Пароль я изменил этот текст в файле default.php который лежал в папке самого модуля. В итоге получаются вопросики вместо текста. Помогите пожалуйста, если можно пошагово объясните потому что я начинающий в этом деле. ! ! !

установите русский язык (два языковых расширения). ломать ядро системы нет необходимости.

все что я делаю, это ставлю английскую 15-ую с официального сайта и устанавливаю в менеджере расширений два расширения языка, один для сайта, другой для администратора. результат - смотрите мой приложенный скриншот.

[вложение удалено Администратором]
# Back the fufalo (особенно ту самую столкершу)! #
# ВАЖНО! Кайфую от удаления присланного в личку спама, почти как от любви (особенно по выходным). #

Re: Проблемы с кодировкой в 1.5
« Ответ #197 : 19.02.2010, 14:08:44 »
Здравствуйте!
При установки Joomla проблемы с отображением русских букв!Ставлю на Девер 3!Захожу в  оперу а там иероглифы!В експлорере всё норм!Подскажити пожалуйста решение проблемы!
*

evlebedev

  • Захожу иногда
  • 56
  • 3 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #198 : 22.02.2010, 21:48:07 »
Могно и так. Просто повозившись с Joomla - начинаешь искать возможности её ускорения - А кеш, хоть немного но помогает в этом.

Re: Проблемы с кодировкой в 1.5
« Ответ #199 : 25.02.2010, 14:24:42 »
Добрый день,
решил я познакомиться с Joomla, поставил денвер, более менее  разобрался в Joomla, стряпал сайтик, все отлично и красиво получилось, был доволен что слон, заранее узнал у хостера какие версии PHP и sql у него стоят, сравнил со своими  - то же самое, думал, что теперь все ок, залил базу .... -  русский не отображается вобще, разве что пункты меню и кнопки в админке, текста нет нигде, только латиница, база в утф8, куда копать, что ковырять?
*

Shuu

  • Новичок
  • 6
  • 0 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #200 : 28.02.2010, 16:34:18 »
Та же проблема! Русского (все то, что в БД-контент, заголовки, пункты меню, названия модулей... вообще нет, т.е. пустота на его месте) нет. Файлы и БД в UTF-8
*

AlexSmirnov

  • Завсегдатай
  • 1862
  • 272 / 16
  • Ищите и найдете
Re: Проблемы с кодировкой в 1.5
« Ответ #201 : 28.02.2010, 17:47:02 »
Добрый день,
решил я познакомиться с Joomla, поставил денвер, более менее  разобрался в Joomla, стряпал сайтик, все отлично и красиво получилось, был доволен что слон, заранее узнал у хостера какие версии PHP и sql у него стоят, сравнил со своими  - то же самое, думал, что теперь все ок, залил базу .... -  русский не отображается вобще, разве что пункты меню и кнопки в админке, текста нет нигде, только латиница, база в утф8, куда копать, что ковырять?

если установили два пакета русских языков и назначили русский язык быть языком сайта по умолчанию, свяжитесь с хостером.
# Back the fufalo (особенно ту самую столкершу)! #
# ВАЖНО! Кайфую от удаления присланного в личку спама, почти как от любви (особенно по выходным). #
*

Shuu

  • Новичок
  • 6
  • 0 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #202 : 28.02.2010, 19:57:06 »
Смысл в том, что в админке русский есть (т.е. тот русский, который хранится в файлах, а не в БД), так же и на сайте. А вот все то, что берется из БД идет без отображения на русском (просто пустое место, не кракозябры), а вот данные на латинском сохранились. Еще заметил, что размер БД на локальном хосте вдвое больше, чем на сервере (пытался делать дампы с разными настройками-ситуация не изменилась), но количество записей в таблицах БД одинаковое..... Напишу хостеру.
*

terry111

  • Осваиваюсь на форуме
  • 28
  • 0 / 1
Re: Проблемы с кодировкой в 1.5
« Ответ #203 : 02.03.2010, 18:26:23 »
Вот кодировка статей отображается ? ?


2.Постоянно п[ри сохранении или удалении материала модуля и т.д вылетает из админки на страницу логина.Ошибок при этом незамечено.Постоянно приходится логиниться заново .
В чем ошибки ?
И куда зайти чтобы поменять кодировку ?
*

vital_s1

  • Захожу иногда
  • 267
  • 26 / 0
  • Joomla магия
Re: Проблемы с кодировкой в 1.5
« Ответ #204 : 02.03.2010, 22:06:50 »
что Вы уже попробовали сделать из того, что в этой теме написано?
Не бойся спрашивать, без этого ни как! -)
*

terry111

  • Осваиваюсь на форуме
  • 28
  • 0 / 1
Re: Проблемы с кодировкой в 1.5
« Ответ #205 : 03.03.2010, 15:43:59 »
AddDefaultCharset utf-8
CharsetSourceEnc utf-8
Пробовал добавлять .htaccess и в htaccess.txt у меня 2 файла
configuration.php в utf8 без BOM
index.php без BOM
Нечего из этого непомогло ( Статьи по прежнему вопросиками
*

terry111

  • Осваиваюсь на форуме
  • 28
  • 0 / 1
Re: Проблемы с кодировкой в 1.5
« Ответ #206 : 03.03.2010, 21:27:21 »
Да че тут писать.Никогда непомогали здесь (
СУЩЕСТВУЮТ ли другие форумы Joomla с техподдержкой ?
*

vital_s1

  • Захожу иногда
  • 267
  • 26 / 0
  • Joomla магия
Re: Проблемы с кодировкой в 1.5
« Ответ #207 : 03.03.2010, 21:32:24 »
Да че тут писать.Никогда непомогали здесь (
СУЩЕСТВУЮТ ли другие форумы Joomla с техподдержкой ?

1. Конечно же ни кто не поможет, если в вопросе нет вопроса, а только слова, - что все плохо и не работает!
Чем лучше вы опишете проблему, тем больше вероятность, что вам помогут, и помогут быстро!!
2. Нет, - это единственный и лучший!
Не забывайте, что Joomla бесплатна и поддержка основана на личном желании и знаниях пользователей форума.
Не бойся спрашивать, без этого ни как! -)
*

Andros

  • Захожу иногда
  • 134
  • 9 / 1
Re: Проблемы с кодировкой в 1.5
« Ответ #208 : 03.03.2010, 21:40:30 »
vital_s1, многа плюсафф!
*

AlexSmirnov

  • Завсегдатай
  • 1862
  • 272 / 16
  • Ищите и найдете
Re: Проблемы с кодировкой в 1.5
« Ответ #209 : 03.03.2010, 21:50:32 »
Да че тут писать.Никогда непомогали здесь (
СУЩЕСТВУЮТ ли другие форумы Joomla с техподдержкой ?

terry111,

joomla - танец для двоих. у нас есть только знания, опыт, желание, энтузиазм и забота помочь Вам, но ответственность за эффективность и качество помощи лежит полностью на Вас, и только на Вас.



# Back the fufalo (особенно ту самую столкершу)! #
# ВАЖНО! Кайфую от удаления присланного в личку спама, почти как от любви (особенно по выходным). #
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Проблемы после переноса с хостинга на денвер

Автор qweqweqwe

Ответов: 6
Просмотров: 2533
Последний ответ 17.07.2014, 09:28:38
от AlekVolsk
Частичная проблема с кодировкой после переноса на новый хостинг

Автор Lem625

Ответов: 0
Просмотров: 1050
Последний ответ 01.07.2014, 12:42:44
от Lem625
Проблемы с загрузкой файлов в RS MediaGallery

Автор AnastaSea

Ответов: 0
Просмотров: 1140
Последний ответ 12.02.2014, 13:07:14
от AnastaSea
Требуется помощь, проблемы с доступом на сайт после установки на хостинг

Автор lekraft

Ответов: 1
Просмотров: 875
Последний ответ 22.10.2013, 10:53:11
от lekraft
Проблемы с Joomla 1,5,22 и PHP 5,3,3....

Автор Spics

Ответов: 10
Просмотров: 7921
Последний ответ 27.12.2012, 12:02:00
от gluck1966