0 Пользователей и 1 Гость просматривают эту тему.
  • 9 Ответов
  • 2229 Просмотров
*

Игорь Матвеев

  • Захожу иногда
  • 82
  • 3 / 1
Стоит ли делать новый сайт на Joomla 3.0? Хотя на 3.0 расширений малавато. Или остаться на 2.5?
*

oshpz

  • Захожу иногда
  • 149
  • 5 / 0
Определенно не стоит пока. Ветка 2.5 продолжает развиваться, и до 2015 года можно смело сидеть на ней не беспокоясь. :)

Переход на 3 версию вызывает трудности даже не наличие многочисленных плагинов, а отсутствие поддержки хостером новой версии PHP, без которой третья Joomla отказывается устанавливаться.
Принимаю благодарности в виде +1 в репу :)
*

art-apple

  • Захожу иногда
  • 386
  • 60 / 2
Переход на 3 версию вызывает трудности даже не наличие многочисленных плагинов, а отсутствие поддержки хостером новой версии PHP, без которой третья Joomla отказывается устанавливаться.
Все нормальные хостинг провайдеры уже давно имеют версии php 5.3 и выше + дают возможность выбрать самому версию php
*

smart

  • Администратор
  • 6485
  • 1315 / 15
  • Хочешь сделать хорошо — сделай!
В ближайшие полгода я точно не спешил бы с переходом на линейку 3.х.
*

SmokerMan

  • Гуру
  • 5293
  • 719 / 26
ну написано же черным по белому
Если не надо какого-то спецефического расширения, которого нет для 3, то может и не стоит.
ЗЫ последняя версия пых на данный момент 5.4, а Jооmla 3+ требует 5.3. На нормальных хостингах эта версия предлагается уже давно
*

ChaosHead

  • Живу я здесь
  • 4954
  • 432 / 13
мне не нравится, что скриптов стало еще больше. разработчики вроде стремятся к мобильности, но сайт запросто может грузить и мутулз и jquery одновременно
*

SmokerMan

  • Гуру
  • 5293
  • 719 / 26
мне не нравится, что скриптов стало еще больше. разработчики вроде стремятся к мобильности, но сайт запросто может грузить и мутулз и jquery одновременно
ой ой ой, можно подумать этой проблемы не было с 1.5)
Большинство расширений для Joomla 1.5 и дальше используют jquery и при этом большинство не заморачивается на отключение стандартного мутулза на морде. Я уже не буду говорить про то, что некоторые "сайтоделы" подключают их несколько раз, как пример - каждый модуль подключает свою библиотеку.

Если уж речь зашла об оптимизации, то уже есть вроде плагины, которые могут отключать ненужные библиотеки на морде
Конечно печально, что до разработчиков никак не дойдет, что этот функционал нужно включить в стандартную сборку

ИМХО: А вообще если они уж перешли на бутсрап, то по хорошему нужно совсем отказаться от мутулз. Но тут надо перелопатить весь клиентский функционал, который разрабатывался тоже не один год. Думаю где-то в 4 версии его не будет, хотя хз)

« Последнее редактирование: 20.05.2013, 16:36:08 от SmokerMan »
*

piratik

  • Осваиваюсь на форуме
  • 44
  • 1 / 0
  • piratik
Вопрос риторический!
Была установлена Joomla 2.5.6. и сейчас обновилась после нажатия  соответствующей кнопки обновления до версии 2.5.11, 
Возможно ли теоретически переход к 3 серии в таком режиме или надо все править ручками или все сносить придется?
*

artlux

  • Захожу иногда
  • 466
  • 58 / 0
Цитировать
Возможно ли теоретически переход к 3 серии в таком режиме или надо все править ручками или все сносить придется?

пока разработчики сохраняют обратную совместимость... но это касается стандартных компонентов...
Но может же появится и 3.2 а в ней уже все по другому будет...
Разработка расширений: Joomla 1.5+, Bitrix 12+, Мобильные приложения для сайтов под Android (PhoneGap).
Для бонусов: Z136221252622, R242724126443, U423945028202. +79211696184(Мегафон), или плюсик в репу!
*

SDKiller

  • Живу я здесь
  • 2706
  • 326 / 5
  • ...ergo sum
Они не то чтобы её сохраняют
Просто другой альтернативы нет - все компоненты ядра в J 3.1 в legacy кроме инсталлера, который удяляется после установки ;)
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Критическая уязвимость. Joomla 1.7

Автор Juseppe

Ответов: 18
Просмотров: 1835
Последний ответ 25.06.2018, 18:48:32
от vebmaster
Миграция с Joomla 1.5 на Joomla 1.6 с помощью J2XML Importer

Автор Nik

Ответов: 100
Просмотров: 46047
Последний ответ 27.04.2018, 17:02:57
от CrazyPr0ger
ошибка после обновления c Joomla 2.5 до 3

Автор akondr

Ответов: 23
Просмотров: 8521
Последний ответ 02.04.2018, 19:08:36
от SeBun
Не обновляется Joomla 2.5.28

Автор SPMBes

Ответов: 47
Просмотров: 2865
Последний ответ 20.03.2018, 21:44:44
от stendapuss
Сайт на Joomla 2.5 взломан.

Автор Likur

Ответов: 14
Просмотров: 954
Последний ответ 21.08.2017, 21:49:28
от ProtectYourSite