Конфликт библиотек в шаблоне Joomla 2.5

  • 5 Ответов
  • 1218 Просмотров

0 Пользователей и 1 Гость просматривают эту тему.

*

Ragnos

  • ****
  • 254
  • 0
Привет, установил модуль всплывающих окон S5 Box на Joomla 2.5, он отказался работать, конфликт скорее всего вызван разными версиями Jquery, в шаблоне стоит версия 1.8.3, а в модуле 1.3.2. В шаблоне убрал вот эту строку

<script src="//ajax.googleapis.com/ajax/libs/jquery/1.8.3/jquery.min.js"></script>

и модуль заработал, но некорректно стал работать Flash калькулятор. Устанавливал плагины JB Library и jQuery Easy, они помогали, но после их включения шаблон конкретно разлетался.

Знает кто нибуть, можно ли как то без помощи плагинов, устранить конфликт. В инете много информации по этому поводу, но там всё так непонятно написано, в том плане что не ясно куда конкретно вставлять тот или иной код для устранения конфликта, поэтому если не трудно объясните нубу как это делается.

*

Ragnos

  • ****
  • 254
  • 0
У меня видать просто уникальные проблемы, раз вообще никто не отвечает

*

ELLE

  • *****
  • 4574
  • 867
jquery до версии 1.4.3 (вроде бы .3) и выше - несовместимы (очень много различий)
поэтому, или отказаться отчего-то или переписать код
« Последнее редактирование: 08.08.2013, 05:42:54 от ELLE »

*

Ragnos

  • ****
  • 254
  • 0
А если прописать код, ну то есть во многих статьях на эту тему предлагается в какихто местах прописать код подобный noConflict или типа этого. Такой вариант не поможет для таких версий библиотек ?


Сегодня столкнулся с той же проблемой. Задолбали разные модули использующие различные версии JQuery.

Решил сравнять и перестал работать S5_Box.

Оказалось, что все проблемы были в старой версии jquery.colorbox.js.

Заливайте новую версию и будет работать как надо, но уже с новым JQuery.

ПС. Спустя два года может уже не актуально, но мало ли кому пригодится.