0 Пользователей и 1 Гость просматривают эту тему.
  • 1 Ответов
  • 2930 Просмотров
*

larissa

  • Новичок
  • 6
  • 0 / 0
После переноса на новый хостинг в админ панели перестали отображаться галереи созданные ранее. Галлерею или категорию можно создать но в админе она не появляется. На сайте все отображается. Никак не могу найти решение. в Google ничего не нашла. Помогите, кто сталкивался с подобными проблемами. Сайт на joomla1.5
*

larissa

  • Новичок
  • 6
  • 0 / 0
проблема решена . не знаю как но помогло это: Иногда случается так, что после переноса на другой хостинг или VPS теряются меню из админки Joomla 1.5 , при этом на самом сайте всё сохраняется и проблем никаких, за исключением того, что невозможно ничего в меню изменить используя админку. Поиски в этом направлении привели меня к тому что связано подобное с несовместимостью версий php. решается приведением кода в соответствие с новой версией, потому что откатывать назад версию php это гораздо более проблематично, а если хостинг вы арендуете, то может стать и так, что вам этого не дадут сделать из разных соображений. Потому после нижеприведённых изменений в файлах всё прекрасно работает - проверено лично:
Ошибка заключается в том, что данные в функцию передаются по ссылке. Для её исправление, достаточно убрать амперсанды в нужных местах.
Для основного меню сайта, в файле /modules/mod_mainmenu/helper.php на строке 31 перед параметром $params.
С админкой телодвижений немного больше
В файле /libraries/joomla/html/html/menu.php на 124ой убираем амперсанд от $children в параметрах вызова функции treerecurse, затем в /libraries/joomla/html/html/grid.php на строках 93,115,157 перед $row

не помню правда с какого сайта эта статья. помогло и с менюшками.

Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Проблемы с отображением Lightbox в IgniteGallery

Автор DmitriyLight

Ответов: 0
Просмотров: 2370
Последний ответ 25.09.2013, 00:58:19
от DmitriyLight
Проблема отображения после переноса!

Автор makasja_74

Ответов: 0
Просмотров: 1282
Последний ответ 02.04.2012, 15:38:01
от makasja_74
MorfeoShow и PhocaGallery не отображают модули на страницах материалов. ignitegallery работает норм

Автор Nick IntegraLL

Ответов: 0
Просмотров: 1761
Последний ответ 02.02.2010, 16:45:23
от Nick IntegraLL