Форма обратной связи в Joomla 3 не работает

  • 27 Ответов
  • 2638 Просмотров

0 Пользователей и 1 Гость просматривают эту тему.

*

Оффлайн schel4ok

в глобальных настройках сайта выбрана функция phpmail

пробовал отправлять письма на свой ящик через стандартную форму контактов

и через модуль s5 quick contacts

ни то ни другое не работает


это последний момент, который мне остался перед публикацией сайта
помогите, пожалуйста!

*

Оффлайн b2z

  • *****
  • 7449
  • [+]739 / [-]0
  • Разраблю понемногу
    • Просмотр профиля
    • NorrNext - расширения для Joomla! и Pagekit

*

Оффлайн schel4ok

а как можно посмотреть куда пропадают письма?
какие-то логи или типа того?

*

Оффлайн schel4ok

и кстати если Joomla не при чем, то почему работает обычный файл test.php

<?php
$to = 'schel4ok@gmail.com';
$subject = 'TEST';
$message = 'hello';
mail($to, $subject, $message);
?>

*

Оффлайн umbabaraumba

  • *******
  • 2441
  • [+]153 / [-]1
  • если помог можете поставить +
    • Просмотр профиля
надо в настройках выбрать Sendmail
Errare humanum est
Ubuntu по-русски
Пишу не сложные модули и компоненты, не дорого но не срочно

*

Оффлайн schel4ok

это тоже не работает
я пробовал разные пути
/usr/sbin/sendmail  и   /usr/sbin/sendmail -t -i

*

Оффлайн umbabaraumba

  • *******
  • 2441
  • [+]153 / [-]1
  • если помог можете поставить +
    • Просмотр профиля
у меня после установки Joomla письма тоже не уходят, по этому сразу меняю настройки в админке
Errare humanum est
Ubuntu по-русски
Пишу не сложные модули и компоненты, не дорого но не срочно

*

Оффлайн b2z

  • *****
  • 7449
  • [+]739 / [-]0
  • Разраблю понемногу
    • Просмотр профиля
    • NorrNext - расширения для Joomla! и Pagekit
и кстати если Joomla не при чем, то почему работает обычный файл test.php

<?php
$to = 'schel4ok@gmail.com';
$subject = 'TEST';
$message = 'hello';
mail($to, $subject, $message);
?>
Чудеса, так как Joomla вызывает вот это:
https://github.com/joomla/joomla-cms/blob/staging/libraries/phpmailer/phpmailer.php#L538

Попробуйте дебаг сделать, посмотреть, что приходит в эту функцию при попытке отправки почты.
Значит косяк в настройках, другого объяснения нет.

*

Оффлайн schel4ok

я включил debug-mode в настройках
а дальше что?

снизу ничего конкретного про функции нет
только это

Сессия
Результаты профилирования
Использование памяти
Запросы к базе данных

*

Оффлайн b2z

  • *****
  • 7449
  • [+]739 / [-]0
  • Разраблю понемногу
    • Просмотр профиля
    • NorrNext - расширения для Joomla! и Pagekit
Я не это имел ввиду - я имел ввиду использование print_r() или var_dump() вместе с die(), чтобы понять, доходит ли процесс до функции mail_passthru. Ну или xdebug'ом.

*

Оффлайн schel4ok

я извиняюсь, но не понимаю, что куда поместить print_r()  чтоб что-то увидеть

поставил себе Xdebug helper для chrome, но он тоже нихрена не показывает

*

Оффлайн schel4ok

и что именно надо поместить в качестве аргумента для print_r()


*

Оффлайн schel4ok

ну вот поместил вот так


private function mail_passthru(...) {
           ........
return $rt;
print_r($to);
die();
  }


потом попробовал отправить письмо - ничего не поменялось
а где на странице должен был появиться аргумент?

на всякий случай вставил еще один раз print_r($to);  прямо в index.php в позицию bottom
и все равно пусто

*

Оффлайн b2z

  • *****
  • 7449
  • [+]739 / [-]0
  • Разраблю понемногу
    • Просмотр профиля
    • NorrNext - расширения для Joomla! и Pagekit
Ну так Вы поставили после return $rt; - конечно ничего не произойдет, так как функция уже вернула результат. Надо перед ставить.

*

Оффлайн schel4ok

поставил до и все равно ничего не выводит

*

Оффлайн b2z

  • *****
  • 7449
  • [+]739 / [-]0
  • Разраблю понемногу
    • Просмотр профиля
    • NorrNext - расширения для Joomla! и Pagekit
Ну значит надо в другом месте искать, пробовать - где-то что-то не срабатывает. Тут только методом тыка либо научным методом с помощью xdebug... Я уже ничем помочь не могу.

*

Оффлайн schel4ok

нашел что у меня xdebug есть на локально хосте open server.
но я с ним раньше никогда не работал и толком не понимаю что искать

загрузил туда свою страницу, с которой отправлял письмо и попробовал поиском найти там функцию mail_passthru
но ничего нету


*

Оффлайн fs-p

Посмотри здесь http://joomlaforum.ru/index.php/topic,262678.msg1332173.html#msg1332173
может сработает
Веб-программирование, верстка fs-p.ru
webmoney Z151537770303,  R437986908223
Яндекс деньги 41001451138405

*

Оффлайн schel4ok

не. не работает

у меня после установки Joomla письма тоже не уходят, по этому сразу меняю настройки в админке
А на что влияет смена этого пункта "Способ отправки" в настройках Joomla? Там три варианта: Sendmail, SMTP и PHP Mail.
У меня не отправляется почта с модуля S5 quick contact вставленного в текст, и смена с PHP Mail на Sendmail, как вы советовали, проблему на решила.

*

Оффлайн Polosatyi

Если не секрет - как решили проблему с отправкой почты? В чем был косяк?

У меня странная ерунда - письма отправляются, но через раз, некоторые вообще не доходят, некоторые с большой задержкой, некоторые практически сразу. Тестовое сообщение отправляется моментально. Стоит  S5 quick contact.
« Последнее редактирование: 30.01.2017, 15:52:57 от Polosatyi »

Если не секрет - как решили проблему с отправкой почты? В чем был косяк?

У меня странная ерунда - письма отправляются, но через раз, некоторые вообще не доходят, некоторые с большой задержкой, некоторые практически сразу. Тестовое сообщение отправляется моментально. Стоит  S5 quick contact.
Даже не помню как я всё настроил. Но такой проблемы как у вас у меня не было. Я начал встраивать S5 quick contact отдельным модулем и чуть корректировал какие-то переменные в таких {} скобках в настройках самих форм. Если у вас всё же письма некоторые доходят, то... что-то странное. Хотя... Объясните по подробнее, что заполняете и что доходит?

*

Оффлайн Polosatyi

Даже не помню как я всё настроил. Но такой проблемы как у вас у меня не было. Я начал встраивать S5 quick contact отдельным модулем и чуть корректировал какие-то переменные в таких {} скобках в настройках самих форм. Если у вас всё же письма некоторые доходят, то... что-то странное. Хотя... Объясните по подробнее, что заполняете и что доходит?

S5 quick contact у  меня опубликован как модуль, в менеджере модулей, но не привязан ни к одному пункту меню. Встроил его прямо в текст на страничке материала, через плагин modules anywhere.  {module S5 Quick Contact}

В качестве административной почты сайта использую почту, созданную на хостинге на этом же домене. Тестовые имэйлы прилетают моментально (Общие настройки - Сервер - Отправить тестовое сообщение)

В настройках S5 quick contact указал имэйл, на который должны приходить письма (на сервере mail.ru, пробовал и @yandex.ru)

Фигня в том, что например сейчас с фронта сайта могу отправить через форму S5 quick contact сообщение, и оно придет на нужный имэйл. Обновляю страницу, через пару минут пытаюсь отправить другое сообщение, нажимаю Отправить, появляется "Ваше сообщение успешно отправлено", но письмо не приходит. Танцую с бубнами, чищу кэш сайта, кэш браузера, и иногда очередное письмо вновь приходит, о потом опять другие письма перестают приходить... КАк-то так.

То есть первое сообщение с формы всё-таки приходит? Полностью? Все поля? А второе сразу нет?

*

Оффлайн Polosatyi

То есть первое сообщение с формы всё-таки приходит? Полностью? Все поля? А второе сразу нет?

Примерно так, но не точно, я не могу уловить условие по которому имэйл отправляется, а по которому нет. Вот сейчас например с интервалом в 2 минуты отправил 3 имэйла. Первый имэйл отправил когда в Общих настройках стоял способ отправки Sendmail, потом изменил способ на PHPmail, очистил кэш браузера и сайта, отправил еще 2 имэйла.  Жду 30 минут - ни одного письма не пришло, не первого, ни двух других.
Отправляю тестовые сообщения из Общие настройки-Сервер  и они прилетает за несколько секунд.
Открыл страницу в Tor, попробовал отправить оттуда - то же самое, "Сообщение успешно отправлено" но письмо не приходит.
Изменил почту на которую отправлять с @mail.ru на @yandex.ru - то же самое, письма не приходят.

А вчера при таких же попытках иногда нет-нет, да какие-то из писем приходили. Причем и при способе Sendmail, и при PHPmail. Потому и не могу понять логики этого косяка, куда в какой код лезть...

*

Оффлайн Polosatyi

Еще странная вещь - увидел что содержимое файла /public_html/libraries/vendor/phpmailer/phpmailer/class.phpmailer.php  отличается вот от этого же файла на гитхабе:
https://github.com/PHPMailer/PHPMailer/releases/tag/v5.2.16

Хотя в обоих файлах написано что версия phpmailer 5.2.16.

Причем судя по тому, что в файле на хостинге есть вот такая запись, его версия не ниже 5.2.20, т.к. в более ранних версиях этого вроде бы не было:
// CVE-2016-10033, CVE-2016-10045: Don't pass -f if characters will be escaped.

Это нормально? Или похоже на взлом? Как установить нормальный PHPmailer?
« Последнее редактирование: 31.01.2017, 21:45:58 от Polosatyi »