0 Пользователей и 1 Гость просматривают эту тему.
  • 27 Ответов
  • 2839 Просмотров
*

schel4ok

  • Захожу иногда
  • 219
  • 3 / 1
в глобальных настройках сайта выбрана функция phpmail

пробовал отправлять письма на свой ящик через стандартную форму контактов

и через модуль s5 quick contacts

ни то ни другое не работает


это последний момент, который мне остался перед публикацией сайта
помогите, пожалуйста!
*

b2z

  • Глобальный модератор
  • 6935
  • 753 / 0
  • Разраблю понемногу
*

schel4ok

  • Захожу иногда
  • 219
  • 3 / 1
а как можно посмотреть куда пропадают письма?
какие-то логи или типа того?
*

schel4ok

  • Захожу иногда
  • 219
  • 3 / 1
и кстати если Joomla не при чем, то почему работает обычный файл test.php

<?php
$to = 'schel4ok@gmail.com';
$subject = 'TEST';
$message = 'hello';
mail($to, $subject, $message);
?>
*

umbabaraumba

  • Живу я здесь
  • 2414
  • 153 / 1
  • если помог можете поставить +
надо в настройках выбрать Sendmail
Errare humanum est
Ubuntu по-русски
Пишу не сложные модули и компоненты, не дорого но не срочно
*

schel4ok

  • Захожу иногда
  • 219
  • 3 / 1
это тоже не работает
я пробовал разные пути
/usr/sbin/sendmail  и   /usr/sbin/sendmail -t -i
*

umbabaraumba

  • Живу я здесь
  • 2414
  • 153 / 1
  • если помог можете поставить +
у меня после установки Joomla письма тоже не уходят, по этому сразу меняю настройки в админке
Errare humanum est
Ubuntu по-русски
Пишу не сложные модули и компоненты, не дорого но не срочно
*

b2z

  • Глобальный модератор
  • 6935
  • 753 / 0
  • Разраблю понемногу
и кстати если Joomla не при чем, то почему работает обычный файл test.php

<?php
$to = 'schel4ok@gmail.com';
$subject = 'TEST';
$message = 'hello';
mail($to, $subject, $message);
?>
Чудеса, так как Joomla вызывает вот это:
https://github.com/joomla/joomla-cms/blob/staging/libraries/phpmailer/phpmailer.php#L538

Попробуйте дебаг сделать, посмотреть, что приходит в эту функцию при попытке отправки почты.
Значит косяк в настройках, другого объяснения нет.
*

schel4ok

  • Захожу иногда
  • 219
  • 3 / 1
я включил debug-mode в настройках
а дальше что?

снизу ничего конкретного про функции нет
только это

Сессия
Результаты профилирования
Использование памяти
Запросы к базе данных
*

b2z

  • Глобальный модератор
  • 6935
  • 753 / 0
  • Разраблю понемногу
Я не это имел ввиду - я имел ввиду использование print_r() или var_dump() вместе с die(), чтобы понять, доходит ли процесс до функции mail_passthru. Ну или xdebug'ом.
*

schel4ok

  • Захожу иногда
  • 219
  • 3 / 1
я извиняюсь, но не понимаю, что куда поместить print_r()  чтоб что-то увидеть

поставил себе Xdebug helper для chrome, но он тоже нихрена не показывает
*

schel4ok

  • Захожу иногда
  • 219
  • 3 / 1
и что именно надо поместить в качестве аргумента для print_r()
*

b2z

  • Глобальный модератор
  • 6935
  • 753 / 0
  • Разраблю понемногу
*

schel4ok

  • Захожу иногда
  • 219
  • 3 / 1
ну вот поместил вот так


Код
private function mail_passthru(...) {
           ........
return $rt;
print_r($to);
die();
  }


потом попробовал отправить письмо - ничего не поменялось
а где на странице должен был появиться аргумент?

на всякий случай вставил еще один раз print_r($to);  прямо в index.php в позицию bottom
и все равно пусто
*

b2z

  • Глобальный модератор
  • 6935
  • 753 / 0
  • Разраблю понемногу
Ну так Вы поставили после return $rt; - конечно ничего не произойдет, так как функция уже вернула результат. Надо перед ставить.
*

schel4ok

  • Захожу иногда
  • 219
  • 3 / 1
поставил до и все равно ничего не выводит
*

b2z

  • Глобальный модератор
  • 6935
  • 753 / 0
  • Разраблю понемногу
Ну значит надо в другом месте искать, пробовать - где-то что-то не срабатывает. Тут только методом тыка либо научным методом с помощью xdebug... Я уже ничем помочь не могу.
*

schel4ok

  • Захожу иногда
  • 219
  • 3 / 1
нашел что у меня xdebug есть на локально хосте open server.
но я с ним раньше никогда не работал и толком не понимаю что искать

загрузил туда свою страницу, с которой отправлял письмо и попробовал поиском найти там функцию mail_passthru
но ничего нету
*

fs-p

  • Захожу иногда
  • 127
  • 49 / 0
Посмотри здесь http://joomlaforum.ru/index.php/topic,262678.msg1332173.html#msg1332173
может сработает
*

schel4ok

  • Захожу иногда
  • 219
  • 3 / 1
не. не работает
*

Kaktus_0,7

  • Новичок
  • 20
  • 0 / 0
у меня после установки Joomla письма тоже не уходят, по этому сразу меняю настройки в админке
А на что влияет смена этого пункта "Способ отправки" в настройках Joomla? Там три варианта: Sendmail, SMTP и PHP Mail.
У меня не отправляется почта с модуля S5 quick contact вставленного в текст, и смена с PHP Mail на Sendmail, как вы советовали, проблему на решила.
*

Polosatyi

  • Захожу иногда
  • 114
  • 3 / 0
Если не секрет - как решили проблему с отправкой почты? В чем был косяк?

У меня странная ерунда - письма отправляются, но через раз, некоторые вообще не доходят, некоторые с большой задержкой, некоторые практически сразу. Тестовое сообщение отправляется моментально. Стоит  S5 quick contact.
« Последнее редактирование: 30.01.2017, 13:52:57 от Polosatyi »
*

Kaktus_0,7

  • Новичок
  • 20
  • 0 / 0
Если не секрет - как решили проблему с отправкой почты? В чем был косяк?

У меня странная ерунда - письма отправляются, но через раз, некоторые вообще не доходят, некоторые с большой задержкой, некоторые практически сразу. Тестовое сообщение отправляется моментально. Стоит  S5 quick contact.
Даже не помню как я всё настроил. Но такой проблемы как у вас у меня не было. Я начал встраивать S5 quick contact отдельным модулем и чуть корректировал какие-то переменные в таких {} скобках в настройках самих форм. Если у вас всё же письма некоторые доходят, то... что-то странное. Хотя... Объясните по подробнее, что заполняете и что доходит?
*

Polosatyi

  • Захожу иногда
  • 114
  • 3 / 0
Даже не помню как я всё настроил. Но такой проблемы как у вас у меня не было. Я начал встраивать S5 quick contact отдельным модулем и чуть корректировал какие-то переменные в таких {} скобках в настройках самих форм. Если у вас всё же письма некоторые доходят, то... что-то странное. Хотя... Объясните по подробнее, что заполняете и что доходит?

S5 quick contact у  меня опубликован как модуль, в менеджере модулей, но не привязан ни к одному пункту меню. Встроил его прямо в текст на страничке материала, через плагин modules anywhere.  {module S5 Quick Contact}

В качестве административной почты сайта использую почту, созданную на хостинге на этом же домене. Тестовые имэйлы прилетают моментально (Общие настройки - Сервер - Отправить тестовое сообщение)

В настройках S5 quick contact указал имэйл, на который должны приходить письма (на сервере mail.ru, пробовал и @yandex.ru)

Фигня в том, что например сейчас с фронта сайта могу отправить через форму S5 quick contact сообщение, и оно придет на нужный имэйл. Обновляю страницу, через пару минут пытаюсь отправить другое сообщение, нажимаю Отправить, появляется "Ваше сообщение успешно отправлено", но письмо не приходит. Танцую с бубнами, чищу кэш сайта, кэш браузера, и иногда очередное письмо вновь приходит, о потом опять другие письма перестают приходить... КАк-то так.
*

Kaktus_0,7

  • Новичок
  • 20
  • 0 / 0
То есть первое сообщение с формы всё-таки приходит? Полностью? Все поля? А второе сразу нет?
*

Polosatyi

  • Захожу иногда
  • 114
  • 3 / 0
То есть первое сообщение с формы всё-таки приходит? Полностью? Все поля? А второе сразу нет?

Примерно так, но не точно, я не могу уловить условие по которому имэйл отправляется, а по которому нет. Вот сейчас например с интервалом в 2 минуты отправил 3 имэйла. Первый имэйл отправил когда в Общих настройках стоял способ отправки Sendmail, потом изменил способ на PHPmail, очистил кэш браузера и сайта, отправил еще 2 имэйла.  Жду 30 минут - ни одного письма не пришло, не первого, ни двух других.
Отправляю тестовые сообщения из Общие настройки-Сервер  и они прилетает за несколько секунд.
Открыл страницу в Tor, попробовал отправить оттуда - то же самое, "Сообщение успешно отправлено" но письмо не приходит.
Изменил почту на которую отправлять с @mail.ru на @yandex.ru - то же самое, письма не приходят.

А вчера при таких же попытках иногда нет-нет, да какие-то из писем приходили. Причем и при способе Sendmail, и при PHPmail. Потому и не могу понять логики этого косяка, куда в какой код лезть...
*

Polosatyi

  • Захожу иногда
  • 114
  • 3 / 0
Еще странная вещь - увидел что содержимое файла /public_html/libraries/vendor/phpmailer/phpmailer/class.phpmailer.php  отличается вот от этого же файла на гитхабе:
https://github.com/PHPMailer/PHPMailer/releases/tag/v5.2.16

Хотя в обоих файлах написано что версия phpmailer 5.2.16.

Причем судя по тому, что в файле на хостинге есть вот такая запись, его версия не ниже 5.2.20, т.к. в более ранних версиях этого вроде бы не было:
// CVE-2016-10033, CVE-2016-10045: Don't pass -f if characters will be escaped.

Это нормально? Или похоже на взлом? Как установить нормальный PHPmailer?
« Последнее редактирование: 31.01.2017, 19:45:58 от Polosatyi »
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Joomla 4 alfa

Автор web3.0

Ответов: 174
Просмотров: 2056
Последний ответ 11.12.2017, 00:12:24
от zomby6888
Видео не влазят в мобильнй экран Joomla 3

Автор bb777

Ответов: 0
Просмотров: 23
Последний ответ 10.12.2017, 19:25:22
от bb777
Необходимо убрать '?layout=category' из ссылок в хлебных крошках - Joomla! 3.6.2б, JoomShoping

Автор mankutila

Ответов: 3
Просмотров: 199
Последний ответ 07.12.2017, 23:12:13
от Aleks.Denezh
Вывод дополнительных полей Joomla 3.7 в шаблоне статьи

Автор mrN

Ответов: 9
Просмотров: 894
Последний ответ 06.12.2017, 10:28:56
от Mitriy
Материалы в Joomla x3

Автор Edward_m

Ответов: 6
Просмотров: 128
Последний ответ 06.12.2017, 08:32:37
от Edward_m