Обновление php на денвере

0 Пользователей и 1 Гость просматривают эту тему.
  • 18 Ответов
  • 17619 Просмотров
*

AlekVolsk

  • Профи
  • ********
  • 6301
  • 336
Обновление php на денвере
« : 18.06.2014, 11:47:36 »
Заменил содержимое папки /usr/local/php5/, оставив только родной php.ini, согласно FAQ с оф.сайта денвера. Обновляю до php 5.5.13.
Опытным путем установил, что в этой папке также должны находится файлы php5apache2_2.dll и php5ts.dll, из поставки денвера.
Сервер запускается, но выдает сообщение на все библиотеки, скрин во вложении. Как это решается?


*

AlekVolsk

  • Профи
  • ********
  • 6301
  • 336
Re: Обновление php на денвере
« Ответ #2 : 18.06.2014, 14:01:22 »
С опенсервером понятно, мне любопытно, как на денвере это решить.

*

AlekVolsk

  • Профи
  • ********
  • 6301
  • 336
Re: Обновление php на денвере
« Ответ #3 : 18.06.2014, 14:11:27 »
В общем, все, что удалось - 5.3.13=>5.3.28, а выше никак...

*

SK

  • Практически профи
  • *******
  • 2141
  • 161
Re: Обновление php на денвере
« Ответ #4 : 18.06.2014, 15:05:41 »
Я недавно копал тему обновления php до версии 5.5 и кажись выяснил для себя, что не получится это сделать так просто - нужно сначала обновить apache с 2.2 до 2.4.
Сборки Денвера пока идут с apache 2.2
Я все-таки поставил php 5.5.11, но для этого установил сборку xampp. В ней уже apache версии 2.4.9.
Кстати, в версии apache 2.4 сильно поменялся кое-какой синтаксис. Будете ставить - изучите сначала.

*

AlekVolsk

  • Профи
  • ********
  • 6301
  • 336
Re: Обновление php на денвере
« Ответ #5 : 18.06.2014, 15:08:44 »
Позвольте нескромную просьбу: вашей сборкой не поделитесь?

*

SK

  • Практически профи
  • *******
  • 2141
  • 161
Re: Обновление php на денвере
« Ответ #6 : 18.06.2014, 15:12:35 »
Позвольте нескромную просьбу: вашей сборкой не поделитесь?
В смысле?
Идите на сайт и качайте нужный исходник https://www.apachefriends.org/ru/index.html
Но предупреждаю, что это годится только для Joomla версии 3.
Все остальные, которые ниже, будут работать с ошибками

*

AlekVolsk

  • Профи
  • ********
  • 6301
  • 336
Re: Обновление php на денвере
« Ответ #7 : 18.06.2014, 15:16:24 »
В смысле?
Я имел ввиду весь обновленный денвер.

*

SK

  • Практически профи
  • *******
  • 2141
  • 161
Re: Обновление php на денвере
« Ответ #8 : 18.06.2014, 15:21:41 »
Я имел ввиду весь обновленный денвер.
Так я ж написал, что на Денвере не получится - там apache 2.2
Поставьте вместо Денвера сборку xampp.

*

AlekVolsk

  • Профи
  • ********
  • 6301
  • 336
Re: Обновление php на денвере
« Ответ #9 : 18.06.2014, 15:30:43 »
Ок, спс.

*

AlekVolsk

  • Профи
  • ********
  • 6301
  • 336
Re: Обновление php на денвере
« Ответ #10 : 18.06.2014, 16:44:06 »
Нашел такую вещь, endels.ru, php5.4.17, обновить до 5.4.29/5.5.13 не удалось.
В общем, неплохая задумка, но вот уж как год не развивается. Регистрация на форуме через почту, письмо на почту не пришло - вопрос не задашь. Заглохла, как и денвер.

*

SK

  • Практически профи
  • *******
  • 2141
  • 161
Re: Обновление php на денвере
« Ответ #11 : 18.06.2014, 17:15:51 »
Нашел такую вещь, endels.ru, php5.4.17, обновить до 5.4.29/5.5.13 не удалось.
В общем, неплохая задумка, но вот уж как год не развивается. Регистрация на форуме через почту, письмо на почту не пришло - вопрос не задашь. Заглохла, как и денвер.
Так там же написано, что используется Apache 2.2.25, а не Apache 2.4...

*

AlekVolsk

  • Профи
  • ********
  • 6301
  • 336
Re: Обновление php на денвере
« Ответ #12 : 18.06.2014, 17:18:39 »
Но php уже не 5.3, а выше.
Я решил опробовать вообще все варианты готовых сборок, которые возможны. Мне необходимо в любой момент иметь возможность поднять локалку в любом месте, по соображения ком.тайны не всегда удобно выкладывать работу на хост (есть такие неудобные заказчики, приходится терпеть).

*

god02

  • Захожу иногда
  • **
  • 17
  • 0
Re: Обновление php на денвере
« Ответ #13 : 23.11.2014, 17:08:20 »
Заменить содержимой папки \usr\local\php5 на содержимое архива php-5.5.9-Win32-VC11-x86.zip  (его сам проверил прост), скачанного с apachelounge.com, закомментить в php.ini строчку
Код
allow_call_time_pass_reference = On
и будет счастье) Просто в этой сборке есть библиотека для взаимодействия php с apache(для php-5.5.9 и apache 2.2), чего нет в других сборках.
--------
Antipov Anton. callback: anton2.ru

*

medwed7777

  • Новичок
  • *
  • 5
  • 1
Re: Обновление php на денвере
« Ответ #14 : 28.04.2015, 07:59:20 »
вот обнова заточенная под apache 2.2 https://phpdev.toolsforresearch.com/php-5.6.8-Win32-VC11-x86.zip
все дело вот в этой библиотеке php5apache2_2.dll которая о обычной обнове отсутствует.
в общем качаем и радуемся ^-^

*

12mv

  • Завсегдатай
  • *****
  • 526
  • 20
  • Гульсина
Re: Обновление php на денвере
« Ответ #15 : 26.10.2015, 10:51:57 »
И у меня возникла необходимость php обновить для Joomla 3)
AlekVolsk, как нибудь вопрос решился?

*

AlekVolsk

  • Профи
  • ********
  • 6301
  • 336
Re: Обновление php на денвере
« Ответ #16 : 26.10.2015, 11:01:24 »
я перешел на openserver

*

neogeek

  • Давно я тут
  • ****
  • 203
  • 18
Re: Обновление php на денвере
« Ответ #17 : 26.10.2015, 11:01:38 »
И у меня возникла необходимость php обновить для Joomla 3)
AlekVolsk, как нибудь вопрос решился?
На локальной машине? Если да, то ставьте Openserver

*

12mv

  • Завсегдатай
  • *****
  • 526
  • 20
  • Гульсина
Re: Обновление php на денвере
« Ответ #18 : 26.10.2015, 11:04:03 »
я перешел на openserver

И я пошла на него))

На локальной машине? Если да, то ставьте Openserver

Уже качаю, спасибо)