0 Пользователей и 1 Гость просматривают эту тему.
  • 2 Ответов
  • 742 Просмотров
*

beltz

  • Новичок
  • 4
  • 0 / 0
Всем добрый день

Конфиг такой: Joomla! 2.5.9 Stable
Задача: перенести сайт на localhost.
Использую: Денвер 5.3 (Денвер 5.2), пробовал и с одним, и с другим.

Проблема в том, что сайт на локалхосте не работает. На хостинге все работает.

Как делал.
Выкачиваю сайт, выкачиваю базу сайта. Все это ставлю в Денвер, прописываю актуальные доступы в configuration.php.

Пытаюсь запустить сайт. Выдается ошибка:

Table 'db_mysite.opps_session' doesn't exist SQL=INSERT INTO `opps_session` (`session_id`, `client_id`, `time`) VALUES ('r8sbcrrat4rbl3p23c4gl0qof3', 0, '1413788540')

Хорошо, делаю отсутствующую таблицу в БД вручную - таким способом.

Код
CREATE TABLE `opps_session` (
  `session_id` varchar(200) NOT NULL default '',
  `client_id` tinyint(3) unsigned NOT NULL default '0',
  `guest` tinyint(4) unsigned default '1',
  `time` varchar(14) default '',
  `data` mediumtext default NULL,
  `userid` int(11) default '0',
  `username` varchar(150) default '',
  `usertype` varchar(50) default '',
  PRIMARY KEY  (`session_id`),
  KEY `whosonline` (`guest`,`usertype`),
  KEY `userid` (`userid`),
  KEY `time` (`time`)
) ENGINE=MyISAM CHARACTER SET=utf8;

Пытаюсь запустить сайт. Снова выдаются ошибки:

Warning: Invalid argument supplied for foreach() in Z:\home\mysite.ru\www\html\libraries\joomla\application\menu.php on line 63

Warning: Invalid argument supplied for foreach() in Z:\home\mysite.ru\www\html\includes\application.php on line 465

Fatal error: Call to a member function get() on a non-object in Z:\home\mysite.ru\www\html\templates\beez_20\error.php on line 10

И их ликвидировать не получается. В панель управления тоже нет доступа.
По умолчанию на сайте стоит другой шаблон, а не beez_20.

Как быть? Кто что подскажет?
« Последнее редактирование: 27.10.2014, 11:27:23 от beltz »
*

beltz

  • Новичок
  • 4
  • 0 / 0
UP
Ну что ж так? Никто так и не подскажет?
*

beltz

  • Новичок
  • 4
  • 0 / 0
Решено. Оказывается с хостинга база выкачивалась не полностью. Поэтому сайт и не запускался.
Мож, кому пригодится.
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

ошибка после обновления c Joomla 2.5 до 3

Автор akondr

Ответов: 0
Просмотров: 233
Последний ответ 21.11.2017, 16:20:49
от akondr
После обновления не работает модуль

Автор virtualov

Ответов: 3
Просмотров: 279
Последний ответ 20.11.2017, 08:29:32
от Adisanut
Автоматическое обновление не работает

Автор zaur111

Ответов: 32
Просмотров: 17463
Последний ответ 17.11.2017, 07:25:44
от m337997
Сайт на Joomla 2.5 взломан.

Автор Likur

Ответов: 14
Просмотров: 534
Последний ответ 21.08.2017, 21:49:28
от ProtectYourSite
Не обновляется Joomla 2.5.28

Автор SPMBes

Ответов: 45
Просмотров: 1618
Последний ответ 02.08.2017, 13:11:34
от lexxbry