0 Пользователей и 1 Гость просматривают эту тему.
  • 40 Ответов
  • 8638 Просмотров
*

zikkuratvk

  • Глобальный модератор
  • 4305
  • 308 / 2
  • Разрабатываем для Joomla
Релиз Joomla 2.5.28 будут последним, по предварительным данным он состоится 10.12.2014.
После этого обновлений для Joomla 2.5 не будет, даже обновлений безопасности, конечно не исключены экстренные апдейты, но системных апдейтов больше уже не будет.

Новость на JoomlaPortal
Хочется уникальное расширение? ===>>>> JoomLine - Разрабатываем расширения под заказ.
Использую хостинг TimeWeb и Reg
*

motokraft

  • Завсегдатай
  • 1326
  • 72 / 13
Re: Поддержка Joomla 2.5 прекращается
« Ответ #1 : 05.12.2014, 20:18:43 »
плохо... Это значит надо переходить на 3-ю версию...
...
*

zikkuratvk

  • Глобальный модератор
  • 4305
  • 308 / 2
  • Разрабатываем для Joomla
Re: Поддержка Joomla 2.5 прекращается
« Ответ #2 : 05.12.2014, 20:27:25 »
плохо... Это значит надо переходить на 3-ю версию...
ну как бы уже два года, даже больше с релиза Joomla 2.5 прошло, по меркам веба целая жизнь.
Хочется уникальное расширение? ===>>>> JoomLine - Разрабатываем расширения под заказ.
Использую хостинг TimeWeb и Reg
*

Taatshi

  • Глобальный модератор
  • 4967
  • 464 / 1
  • Верстаем и немножко кодим. Обращайтесь ;)
Re: Поддержка Joomla 2.5 прекращается
« Ответ #3 : 05.12.2014, 21:08:40 »
motokraft, она вполне уже устойчива. Больше полугода все новые сайты на ней делаю.
*

ChaosHead

  • Живу я здесь
  • 4996
  • 434 / 13
Re: Поддержка Joomla 2.5 прекращается
« Ответ #4 : 05.12.2014, 21:21:51 »
В 2.5 мне больше нравится шаблон админки, может привычка конечно.
*

voland

  • Легенда
  • 9990
  • 549 / 107
  • Эта строка съедает место на вашем мониторе
Re: Поддержка Joomla 2.5 прекращается
« Ответ #5 : 05.12.2014, 21:34:26 »
В 2.5 мне больше нравится шаблон админки, может привычка конечно.
Та же ерунда. Вроде уже много работаю с 3кой, но никак не привыкну.
*

Valerko_O

  • Захожу иногда
  • 177
  • 12 / 0
  • Ничто так не помогает сделать выбор, как пытки...
Re: Поддержка Joomla 2.5 прекращается
« Ответ #6 : 06.12.2014, 07:08:59 »
Настало время отбросить все старое :)
*

motokraft

  • Завсегдатай
  • 1326
  • 72 / 13
Re: Поддержка Joomla 2.5 прекращается
« Ответ #7 : 06.12.2014, 08:52:49 »
я так понимаю должны создать новую 4 версию...
...
*

Valerko_O

  • Захожу иногда
  • 177
  • 12 / 0
  • Ничто так не помогает сделать выбор, как пытки...
Re: Поддержка Joomla 2.5 прекращается
« Ответ #8 : 06.12.2014, 09:05:40 »
я так понимаю должны создать новую 4 версию...
От чего должны? Они над третьей пыхтят.
*

zikkuratvk

  • Глобальный модератор
  • 4305
  • 308 / 2
  • Разрабатываем для Joomla
Re: Поддержка Joomla 2.5 прекращается
« Ответ #9 : 06.12.2014, 11:28:16 »
я так понимаю должны создать новую 4 версию...
четвертая ветка будет открыта ой как не скоро. Да и они все свои планы уже нарушили...
Хочется уникальное расширение? ===>>>> JoomLine - Разрабатываем расширения под заказ.
Использую хостинг TimeWeb и Reg
*

svarg

  • Захожу иногда
  • 125
  • 1 / 1
Re: Поддержка Joomla 2.5 прекращается
« Ответ #10 : 22.12.2014, 20:30:13 »
Не пойму, чего паниковать то? Что значит старое? Бред!
У меня есть сайты на чистом HTML много сайтов на Joomla 1.5 проблем вообще не вижу!
*

Valerko_O

  • Захожу иногда
  • 177
  • 12 / 0
  • Ничто так не помогает сделать выбор, как пытки...
Re: Поддержка Joomla 2.5 прекращается
« Ответ #11 : 22.12.2014, 20:38:50 »
Не пойму, чего паниковать то? У меня много сайтов на Joomla 1.5 проблем вообще не вижу!
А как же безопасность ядра?
*

svarg

  • Захожу иногда
  • 125
  • 1 / 1
Re: Поддержка Joomla 2.5 прекращается
« Ответ #12 : 22.12.2014, 20:59:25 »
А как же безопасность ядра?

Насочиняли хрень всякую про опасности, тут был один сайт по устранению депрессий, там один дифференциальный психолог из vita-luck.ru писал о депрессиях, так вот поддержка не прекращается!
« Последнее редактирование: 04.03.2015, 23:08:59 от svarg »
*

Valerko_O

  • Захожу иногда
  • 177
  • 12 / 0
  • Ничто так не помогает сделать выбор, как пытки...
Re: Поддержка Joomla 2.5 прекращается
« Ответ #13 : 22.12.2014, 21:05:28 »
Скорее всего у сайтов которые вы делали нет конкурентов готовых идти на такую низость как ломать сайты.
У меня коллега один писал сайты на своем движке (если его так можно назвать), так админка вообще без пароля. Заходи не хочу.
И да, никто не ломал. Потому что у сайтов посещаемости ноль. Попробуйте сделать сайт с большой посещаемостью и увидеть как быстро вам придется его чинить.
*

zikkuratvk

  • Глобальный модератор
  • 4305
  • 308 / 2
  • Разрабатываем для Joomla
Re: Поддержка Joomla 2.5 прекращается
« Ответ #14 : 22.12.2014, 21:49:34 »
Давай без фанатизма... учитывая количество сайтов работающих на Joomla 2.5, то вероятней всего выпустят патч безопасности если найдется критическая уязвимость. Во всяком случае с Joomla 1.5 так было.
По сути для меня как для разработчика это звонок, что в ближайшее время надо переходить на Joomla 3, и многие компоненты перестанут обновляться для Joomla 2.5, со временем совместимость с Joomla 2.5 будет утрачена... когда это произойдет я вам точно сказать не могу, судя по Joomla 1.5 этот процесс займет от года до трех лет.
Хочется уникальное расширение? ===>>>> JoomLine - Разрабатываем расширения под заказ.
Использую хостинг TimeWeb и Reg
*

Sgrey

  • Осваиваюсь на форуме
  • 28
  • 1 / 0
Re: Поддержка Joomla 2.5 прекращается
« Ответ #15 : 28.12.2014, 01:10:30 »
Поясните пожалуйста ситуацию. Joomla 2.5 я так понимаю была с долговременной поддержкой, а Joomla 3 с короткой. Получается сейчас ей нет альтернативы в этом плане?
*

zikkuratvk

  • Глобальный модератор
  • 4305
  • 308 / 2
  • Разрабатываем для Joomla
Re: Поддержка Joomla 2.5 прекращается
« Ответ #16 : 29.12.2014, 17:20:55 »
Поясните пожалуйста ситуацию. Joomla 2.5 я так понимаю была с долговременной поддержкой, а Joomla 3 с короткой. Получается сейчас ей нет альтернативы в этом плане?
Альтернативы не будет. По сути теперь будет непрерывное обновление в рамках линейки 3.x... Типа в рамках линейки все будет совместимо, хотя я не поручусь, что в дальнейшем они пересмотрят стратегию выпуска версий.
Хочется уникальное расширение? ===>>>> JoomLine - Разрабатываем расширения под заказ.
Использую хостинг TimeWeb и Reg
*

Татьяна Новикова

  • Новичок
  • 6
  • 0 / 0
Re: Поддержка Joomla 2.5 прекращается
« Ответ #17 : 13.01.2015, 20:19:13 »
Здравствуйте, форумчане!

У меня на хостинге (nic.ru) возникла проблема с установкой Joomla.

Для установки в автоматическом режиме CMS Joomla даже не 3 версии, а 2.5.27 требуется сменить настройки РНР, а именно поменять РНР5.2 на РНР5.3.

У меня это может привести к сбою работы сайтов, так как  для РНР5.3 на моем хостинге не поддерживается Модуль Charset.

В коде сайтов прописано

<meta http-equiv="Content-Type" content="text/html; charset=windows-1251" />

Насколько критично для сайтов будет, если я перейду на РНР5.3 ? Может что-то надо поменять в настройках?
Или может стоит установить более раннюю версию  Joomla? Не очень хочется, так как чую, рано или поздно все равно придется переходить на трешку.

Хелп, плииз!
*

voland

  • Легенда
  • 9990
  • 549 / 107
  • Эта строка съедает место на вашем мониторе
Re: Поддержка Joomla 2.5 прекращается
« Ответ #18 : 13.01.2015, 20:33:55 »
Сразу меняйте php на версию 5.5, потом решаете кучу проблем со старыми сайтами и еще на 5 лет забываете о проблемах.
*

Татьяна Новикова

  • Новичок
  • 6
  • 0 / 0
Re: Поддержка Joomla 2.5 прекращается
« Ответ #19 : 13.01.2015, 21:28:47 »
На хостинге нет РНР 5.5, самая свежая это 5.3, я уже писала.

Я ничего в РНР не понимаю, потому и задала вопрос, насколько критично будет проигнорировать модуль Charset.
*

voland

  • Легенда
  • 9990
  • 549 / 107
  • Эта строка съедает место на вашем мониторе
Re: Поддержка Joomla 2.5 прекращается
« Ответ #20 : 13.01.2015, 21:30:32 »
Я ничего в РНР не понимаю, потому и задала вопрос, насколько критично будет проигнорировать модуль Charset.
Как бы сказать то помягче..
Вы и правда ничего не понимаете в php, там нет модуля charset.
*

Татьяна Новикова

  • Новичок
  • 6
  • 0 / 0
Re: Поддержка Joomla 2.5 прекращается
« Ответ #21 : 13.01.2015, 22:39:53 »
Правда я понимаю или не правда, главное, чтобы вы понимали, профи ))
А если вот так попробовать поискать charset_module ? - Узнаете много нового     ;D




*

voland

  • Легенда
  • 9990
  • 549 / 107
  • Эта строка съедает место на вашем мониторе
Re: Поддержка Joomla 2.5 прекращается
« Ответ #22 : 13.01.2015, 22:56:13 »
Правда я понимаю или не правда, главное, чтобы вы понимали, профи ))
А если вот так попробовать поискать charset_module ? - Узнаете много нового     ;D





Не узнал. Все ссылки ведут на nic.ru - видимо от их приблуда для умножения проблем.
*

Татьяна Новикова

  • Новичок
  • 6
  • 0 / 0
Re: Поддержка Joomla 2.5 прекращается
« Ответ #23 : 13.01.2015, 23:12:43 »
Если вы не знаете ответа на мой вопрос, зачем тратите свое и мое время?

http://php5.kiev.ua/nginx/http/ngx_http_charset_module.html
« Последнее редактирование: 13.01.2015, 23:16:48 от Татьяна Новикова »
*

ChaosHead

  • Живу я здесь
  • 4996
  • 434 / 13
Re: Поддержка Joomla 2.5 прекращается
« Ответ #24 : 14.01.2015, 00:42:15 »
Это модуль не php, а скажем так серверной программы nginx.

Вобще мне кажется вы какую-то проблему на пустом месте выдумываете. Проблемы кодировки никак не связаны с версией php. Nginx работающий на серверах хостинга тоже не связан с версией php, это лишь программа отдающая файлы браузеру.

На хостингах, что я встречал, php 5.3 считается основной рекомендуемой версией.

В конце концов сменить и проверить - 5 минут делов.
« Последнее редактирование: 14.01.2015, 00:47:51 от ChaosHead »
*

Татьяна Новикова

  • Новичок
  • 6
  • 0 / 0
Re: Поддержка Joomla 2.5 прекращается
« Ответ #25 : 14.01.2015, 02:18:04 »
Спасибо, в принципе именно это я и хотела выяснить. Я могу переключить РНР на более позднюю версию, а если что-то пойдет не так вернуть обратно 5.2? Я правильно поняла?


вот скриншот сообщения на хостинге

*

voland

  • Легенда
  • 9990
  • 549 / 107
  • Эта строка съедает место на вашем мониторе
Re: Поддержка Joomla 2.5 прекращается
« Ответ #26 : 14.01.2015, 02:34:45 »
А почему не спросить у хостера?
Это был бы самый разумный шаг.

Приведу аналогию - мы ездим на иномарках и тазиках, льем бензин, а некий Кулибин собрал тележку из запорожца с Альфа-Ромео и написал что если залить в неё 95ый бензин, то она сломается.. как наш опыт поможет в ответе?
*

Apoca1ypto

  • Давно я тут
  • 745
  • 71 / 0
Re: Поддержка Joomla 2.5 прекращается
« Ответ #27 : 14.01.2015, 11:31:52 »
charset_module - производит корректное преобразование из кодировки хранения в кодировку у клиента при передаче документа клиенту и произвести обратное преобразование при приеме информации от клиента (submit формы и т.п.).
Во время спора в Интернете Ваш оппонент приводит неопровержимые доказательства своей точки зрения? Не отчаивайтесь. До...тесь до орфографии.
*

Татьяна Новикова

  • Новичок
  • 6
  • 0 / 0
Re: Поддержка Joomla 2.5 прекращается
« Ответ #28 : 14.01.2015, 16:54:57 »
А почему не спросить у хостера?
Это был бы самый разумный шаг.

Приведу аналогию - мы ездим на иномарках и тазиках, льем бензин, а некий Кулибин собрал тележку из запорожца с Альфа-Ромео и написал что если залить в неё 95ый бензин, то она сломается.. как наш опыт поможет в ответе?

Если у вас нет опыта, зачем отвечаете?
Во-вторых, первый у кого я спросила, был хостер. Если интересно, почитайте его ответ

"Здравствуйте!

При установке CMS в автоматическом режиме, на хостинге происходит изменение настроек PHP в соответствии с требованиями устанавливаемой Вами CMS. Изменить настройки PHP для отдельного сайта не представляется возможным по техническим причинам. В связи с этим, настройки PHP меняются для всей услуги хостинга. Если новые настройки не подходят для остальных Ваших сайтов на этой услуге, то сайты могут перестать работать или начать работать некорректно. В связи с этим выводится предупреждающее сообщение об изменении настроек. Для решения данного вопроса Вам необходимо определить - являются ли требования к настройке PHP на хостинге для Ваших существующих сайтов идентичными или схожими с требованиями Joomla или Wordpress. Получить эту информацию можно у разработчиков сайта, либо в документации по уже используемым Вами CMS. Если уточнить эту информацию не представляется возможным, рекомендуем Вам во избежание изменений настроек PHP установить Joomla или Wordpress вручную, без использования раздела "Установка CMS" в панели управления хостингом. Инструкции по установке данных CMS вручную Вы можете найти на сайтах разработчиков:

Joomla: http://joomla.org/
Wordpress: http://ru.wordpress.org/

Модуль Charset в настоящий момент не поддерживается на нашем хостинге для PHP версии 5.3, поэтому, если для Ваших сайтов наличие данного модуля в системе критично, рекомендуем обратиться к разработчику сайтов для уточнения возможности отказаться от использования данного модуля."




*

voland

  • Легенда
  • 9990
  • 549 / 107
  • Эта строка съедает место на вашем мониторе
Re: Поддержка Joomla 2.5 прекращается
« Ответ #29 : 14.01.2015, 17:04:47 »
Получить эту информацию можно у разработчиков сайта, либо в документации по уже используемым Вами CMS.
И какой отношение тема про Joomla 2.5 имеет к Вашим сайтам?
Наличие кодировки 1251 говорит о том что там стоит либо Joomla 1.0 либо другая CMS.

Или была мысль не обновлять новые движки? Но эта мысль в корне неправильна.
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Критическая уязвимость. Joomla 1.7

Автор Juseppe

Ответов: 18
Просмотров: 2059
Последний ответ 25.06.2018, 18:48:32
от vebmaster
Миграция с Joomla 1.5 на Joomla 1.6 с помощью J2XML Importer

Автор Nik

Ответов: 100
Просмотров: 46615
Последний ответ 27.04.2018, 17:02:57
от CrazyPr0ger
ошибка после обновления c Joomla 2.5 до 3

Автор akondr

Ответов: 23
Просмотров: 8777
Последний ответ 02.04.2018, 19:08:36
от SeBun
Не обновляется Joomla 2.5.28

Автор SPMBes

Ответов: 47
Просмотров: 3574
Последний ответ 20.03.2018, 21:44:44
от stendapuss
Сайт на Joomla 2.5 взломан.

Автор Likur

Ответов: 14
Просмотров: 1113
Последний ответ 21.08.2017, 21:49:28
от ProtectYourSite