0 Пользователей и 1 Гость просматривают эту тему.
  • 13 Ответов
  • 1024 Просмотров
*

Михайло

  • Осваиваюсь на форуме
  • 58
  • 0 / 0
Здравствуйте! Прежде всего, речь идет о работе под Windows 8.1.
В Winnows 7 и 8 все работало нормально. А в 8.1 раньше у меня не запускался wampserver, любой: красный значок в трее, коричневый и все - не зеленеет и не работает. Теперь неожиданно стали работать и wampsrver 2.4, и wampserver 2.5, НО:
В wampservere 2.4 при помещении пакета Joomla 2.5 (как и 3.3) в папку www при клике по ним на главной странице wampservera начинается инсталляция Joomla (обеих версий), доходит до формирования и подключения базы данных, после чего зависает в цикле и ни с места.


При установке wampsever 2.5 и того хуже - инсталляция Joomla вообще не начинается, а выдается сообщение типа "Joomla....  не может
подключиться к серверу localhost...", хотя сервер работает, значки сервера в правом трее зеленые у обоих версий wampserwera.

Почему так происходит - понять не могу и что делать - не знаю. Главное, обидно - вроде локальный сервер заработал, но толку нет.
Нужна какая-то донастройка или обновление, но какое?

Начало логов в wampservere 2.5 (чтобы не загромождать письмо, сокращаю). Кто знает, тот поймет причину уже по первой строчке:
"2015-02-24 18:54:42 3496 [Note] Plugin 'FEDERATED' is disabled.
2015-02-24 18:54:42 3496 [Note] InnoDB: Using atomics to ref count buffer pool pages
2015-02-24 18:54:42 3496 [Note] InnoDB: The InnoDB memory heap is disabled
2015-02-24 18:54:42 3496 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions
2015-02-24 18:54:42 3496 [Note] InnoDB: Compressed tables use zlib 1.2.3"...

Кто разбирается, помогите пожалуйста. Спасибо. Михаил.
« Последнее редактирование: 24.02.2015, 20:32:02 от Михайло »
*

umbabaraumba

  • Практически профи
  • 2441
  • 153 / 1
  • если помог можете поставить +
Посмотрите тут
Errare humanum est
Ubuntu по-русски
Пишу не сложные модули и компоненты, не дорого но не срочно
*

capricorn

  • Практически профи
  • 1739
  • 111 / 3
поиском Windows поищите my.ini файл. Должен быть один. И выложите его под спойлер.
*

Михайло

  • Осваиваюсь на форуме
  • 58
  • 0 / 0
Файл my.ini нет нужды искать поиском Windows, он появляется в запущенном wampsevere. А "под спойлер" - это куда?
Хоть файл и здоровенный, но я на всякий случай выкладываю его здесь:

Спойлер
[свернуть]
*

Михайло

  • Осваиваюсь на форуме
  • 58
  • 0 / 0
umbabaraumba, спасибо, но Ваша ссылка не помогла.

capricorn, а насчет спойлера - я, как видите, его нашел и выложил файл. Только чем это поможет?
               Тогда уж выложу и MySQL log:
Спойлер
[свернуть]
« Последнее редактирование: 25.02.2015, 08:02:16 от Михайло »
*

capricorn

  • Практически профи
  • 1739
  • 111 / 3
Цитировать
Файл my.ini нет нужды искать поиском Windows, он появляется в запущенном wampsevere

Это файл конфигурации MySQL, и насколько я понимаю, он всегда присутствует. И должна быть возможность его редактировать.

Вопрос - phpMyAdmin открывается? Как произошел переход с WAMP 2.4 на 2.5, мне кажется они одновременно не должны присутствовать, если это ваш случай. Пока не вижу особых вопросов с my.ini.
« Последнее редактирование: 27.02.2015, 21:49:39 от capricorn »
*

Михайло

  • Осваиваюсь на форуме
  • 58
  • 0 / 0
Я просто скачал и установил wampserwer 2.5. PHPMyAdin работает, проблем с доступом к my.ini нет. Но и толку тоже нет.
Все вроде работает. Но речь идет об установке Joomla. На четвертом шаге установки, там где подключатся база данных, система либо уходит в глухой непрерывный цикл, либо сразу выдает сообщение: "Невозможно подключиться к к базе данных".

Проблем с доступом к my.ini, но ведь надо знать, что там править. Вы знаете? Поделитесь, пожалуйста. Спасибо. Михаил.     
*

Михайло

  • Осваиваюсь на форуме
  • 58
  • 0 / 0
capricorn, а что Вы решили с моим файлом my.ini? Ничего? Я его выложил под спойлер.

Кстати, обратите внимание на начало (см. выше, начало логов, где упоминается в первой же строчке плагин FEDERATED, он недоступен. ни в этом ли дело?
Как его подключить? Спасибо.
« Последнее редактирование: 02.03.2015, 17:14:37 от Михайло »
*

capricorn

  • Практически профи
  • 1739
  • 111 / 3
да вроде нет вопросов с my.ini. MySQL работает.

попробуйте на шаге создания БД подключаться как root пользователь MySQL. если пароль не задавали - оставьте это поле пустым.
Цитировать

плагин FEDERATED, он недоступен. ни в этом ли дело?

думаю нет.

Ну еще - попробуйте сделать в my.ini - max_allowed_packet=500M (у вас сейчас 1М), рестартовав после этого WAMP.

Тут:
Цитировать
# The MySQL server
[wampmysqld]
port      = 3306
socket      = /tmp/mysql.sock
key_buffer = 16M
max_allowed_packet = 1M



« Последнее редактирование: 02.03.2015, 17:36:52 от capricorn »
*

Михайло

  • Осваиваюсь на форуме
  • 58
  • 0 / 0
capricorn, но ведь я так и делаю, пользователь root, пароль оставляю пустым   
*

capricorn

  • Практически профи
  • 1739
  • 111 / 3
Честно не знаю, что и думать. Из командной строки Windows тоже нет подключения как root?
*

Михайло

  • Осваиваюсь на форуме
  • 58
  • 0 / 0
Как подклчить из комндной строки root?
*

capricorn

  • Практически профи
  • 1739
  • 111 / 3
Цитировать
Как подклчить из комндной строки root?

Михайло, давайте букварь обсуждать.

Лень погуглить и понять?

Мой вам совет - поднимайте себе на ПК веб-связку вручную. Это не сложно. У меня нет желания стать тестером WAMP для Win 8.1.


« Последнее редактирование: 03.03.2015, 05:42:44 от capricorn »
*

Михайло

  • Осваиваюсь на форуме
  • 58
  • 0 / 0
Я установил Joomla! Но технология установки совсем другая, как и панель управления. Как догадался, сам не пойму.
Компьютерное шаманство, короче!
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться