Весь сайт на локальной машине стал выдавать ошибку 404 и "мутировал" один из модулей

  • 1 Ответов
  • 408 Просмотров

0 Пользователей и 1 Гость просматривают эту тему.

Заранее прошу прощения за возможные тупость и косноязычие - я не специалист и терминологией владею плохо.
Ситуация следующая. На ноуте стоит сборка XAMPP c Apach и SQL, на нее установлена Joomla 3.3.6, если верить файлу установки. Для работы еще нужен модуль К2 http://getk2.org/extend/ (версия 2.6.9) для работы с тегами. У него несколько дебильная система создания тегов с 3 полями - в одном надо тег ввести, после сохранения материала тег можно будет выбрать во втором, чтобы добавить в третье. После этого тег приписан к материалу. Несколько месяцев все прекрасно работало, а сегодня решил поменять теги у одного материала. Создаю, а он не создается - список доступных тегов не меняется. Удалить уже приписанные тоже не могу. Полез в настройки Joomla, попутно нашел настройки формирования URL, поотключал добавку префиксов от ID материала в URL. Потом стал смотреть какую-то страницу сайта - ошибка 404. И так на любую страницу. Отжал обратно галки настройки формирования URL (вроде все) - не помогает. Вообще весь адрес 127.0.0.1/joomla/ выдает ошибку 404. Снес Joomla, переустановил... В К2 осталось только одно поле формирования тега, причем оно почему-то стало набираться каким-то шрифтом, не таким как везде на странице. Внизу приписка "введите название тега, потом ретурн или запятую и будет вам щассте". Нифига. Тег не добавляется. Снес уже и ХАМРР, все переустановил - та же фигня. Ничего не понимаю, помогите христаради.

Уточнение.
С ошибкой 404 так и не понятно, но вроде больше не повторяется. А вот теги, судя по всему, перестают создаваться и редактироваться, если в этот момент компьютер не подключен к интернету. Что это за бред, связан он с Joomla или с К2, и как его побороть?