Fatal error после установки шаблона Ot-smartsolutions на Joomla 3.3.3

  • 7 Ответов
  • 1494 Просмотров

0 Пользователей и 1 Гость просматривают эту тему.

*

Korben

  • *
  • 1
  • 0
Сначала пытался установить данный шаблон через менеджер расширений - безуспешно.
Затем попытался установить через Quik Start. В админке шаблон виден. Но при попытке открыть сайт выдает такую ошибку:


Fatal error: Cannot use object of type JRegistry as array in Z:\home\localhost\www\joomla\plugins\system\jarvis\lib\jarvis\template\Builder.php on line 59

Подскажите пожалуйста в чем может быть проблема?? !
Заранее спасибо.

*

SeBun

  • *******
  • 3071
  • 185
  • @SeBun48
Затем попытался установить через Quik Start...
Это как?

Если вы корректно установили Quik Start, то он должен корректно работать.
Оказываю услуги по Joomla | Миграция на Joomla 3.x | Администрирование
Ник занят | По личным вопросам не консультирую

Сначала пытался установить данный шаблон через менеджер расширений - безуспешно.
Затем попытался установить через Quik Start. В админке шаблон виден. Но при попытке открыть сайт выдает такую ошибку:


Fatal error: Cannot use object of type JRegistry as array in Z:\home\localhost\www\joomla\plugins\system\jarvis\lib\jarvis\template\Builder.php on line 59

Подскажите пожалуйста в чем может быть проблема?? !
Заранее спасибо.
У меня такая же беда.
atal error: Cannot use object of type JRegistry as array in Z:\home\kosmolazer.com.ua\www\plugins\system\jarvis\lib\jarvis\template\Builder.php on line 58
У Вас получилось решить проблему?

*

darkghost

  • *******
  • 2100
  • 94
версия PHP Денвера какая?

*

AlekVolsk

  • ********
  • 6301
  • 336
На денвере штатно версия php5.3.13, имеет глюк при работе с копированием файлов. лечится обновлением php до 5.3.last путем тупого копирования с заменой.

Не рекомендую шаблоны на jarvis - тот еще гемор...

С денвера попробовал перейти на опен сервер. Та же хрень: Fatal error: Cannot use object of type JRegistry as array in C:\OpenServer\domains\kosmolazer\plugins\system\jarvis\lib\jarvis\template\Builder.php on line 58

вот Builder.php  on line 58 (с 55 по 66 строки) может подскажете, где может быть ошибка...

   public function head() {
      $customCode = array();

      if (!empty($this->params['bookmarkIcon'])) {
         $extension = pathinfo($this->params['bookmarkIcon'], PATHINFO_EXTENSION);
         $href = \JURI::root(true). '/' . $this->params['bookmarkIcon'];
         $types = array(
            'png' => 'image/png',
            'ico' => 'image/x-icon',
            'gif' => 'image/gif'
         );


На денвере штатно версия php5.3.13, имеет глюк при работе с копированием файлов. лечится обновлением php до 5.3.last путем тупого копирования с заменой.

Не рекомендую шаблоны на jarvis - тот еще гемор...
php обновил, не помогло(((
может есть еще идеи?

Разобрался!
Помогло вот это: РАСШИРЕНИЯ - МЕНЕДЖЕР РАСШИРЕНИЙ - слева жмём БАЗА ДАННЫХ (у меня здесь выдало две ошибки) далее жмём кнопку ИСПРАВИТЬ!
И всё запустилось!