Сохраняются ли пути к языковым файлам расширений где-то ещё помимо как в XML файле расширения?

  • 9 Ответов
  • 460 Просмотров

0 Пользователей и 1 Гость просматривают эту тему.

*

borro

  • Живу я здесь
  • ******
  • 1272
  • 21
  • желаю вам счастья
Здравствуйте!

У расширения(компонента Joomla update) есть языковой файл, путь к которому прописан в XML файле расширения следующим образом:
Код
<language tag="en-GB">language/en-GB.com_joomlaupdate.ini
</language>

Скажите, сохраняются ли пути к языковым файлам расширений ещё где-либо в принципе в Joomla - в базе данных или других файлах?

*

robert

  • Профи
  • ********
  • 4002
  • 371
Запись в xml-файле, как я понял, только для установки и удаления. Сами языковые файлы загружаются автоматически. Может быть, расскажете, что задумали делать?
  • Не будь паразитом, сделай что-нибудь самостоятельно!
  • В личке и по Skype не даю советов.

*

borro

  • Живу я здесь
  • ******
  • 1272
  • 21
  • желаю вам счастья
Запись в xml-файле, как я понял, только для установки и удаления. Сами языковые файлы загружаются автоматически. Может быть, расскажете, что задумали делать?
дело в том, что я на пути обновления с J2.5 до 3.4. В инструкции по миграции советуется менять настройки в этом самом Joomla update компоненте. По необъяснимой для меня причине в моей 2.5 Joomla нет этого компонента совсем, ни в меню Компоненты, ни среди записей таблицы extensions базы данных.
Я решил создать установочный пакет этого расширения с версии Joomla, в которой он есть. Для этого я решил воспользоваться компонентом Folcomedia Packager. Но и тут пути к обновлению Joomla оказались перекрыты :) Этот самый Folcomedia Packager выдал ошибку
Цитировать
FMPackager Error: The file administrator/language/en-GB/en-GB.com_joomlaupdate.ini listed in XML manifest file is missing on your host.
я пошел по указанному пути и, действительно, никакого en-GB.com_joomlaupdate.ini там не оказалось. Тогда я копировал его туда из подпапки \administrator\language\en-GB\ на уровень выше. Попробовал ещё раз сгенерить установочный пакет для Joomla update, но ошибка повторилась. Тогда я подредактировал путь в XML файле, но опять неудача :)
Это натолкнуло на мысль, что похоже программа ищет языковой по старому пути, который хранится где-то еще нежели в administrator\components\com_joomlaupdate\joomlaupdate.xml файле либо может надо где-то что-то обновить/кэш сбросить, но где?..

В общем, помогите, кто может :)

*

robert

  • Профи
  • ********
  • 4002
  • 371
Не пользуюсь Folcomedia Packager, поэтому не могу ничего сказать. Но зачем вы пошли по такому сложному пути? Посмотрите в XML какие папки должны быть, скопируйте туда папки компонента и языковые файлы из админки и фронта, ко всему добавьте тот самый XML. Вот и все дела.

P.S. Вот сейчас посмотрел xml:
1. Создайте папку admin и скопируйте в нее содержимое папки com_joomlaupdate.
2. Внутри папки admin создайте папку language и скопируйте туда en-GB.com_joomlaupdate.ini.
3. В XML измените версию 2.5 на 3.0.
« Последнее редактирование: 07.05.2015, 17:45:12 от robert »
  • Не будь паразитом, сделай что-нибудь самостоятельно!
  • В личке и по Skype не даю советов.

*

borro

  • Живу я здесь
  • ******
  • 1272
  • 21
  • желаю вам счастья
Не пользуюсь Folcomedia Packager, поэтому не могу ничего сказать. Но зачем вы пошли по такому сложному пути? Посмотрите в XML какие папки должны быть, скопируйте туда папки компонента и языковые файлы из админки и фронта, ко всему добавьте тот самый XML. Вот и все дела.

P.S. Вот сейчас посмотрел xml:
1. Создайте папку admin и скопируйте в нее содержимое папки com_joomlaupdate.
2. Внутри папки admin создайте папку language и скопируйте туда en-GB.com_joomlaupdate.ini.
3. В XML измените версию 2.5 на 3.0.
Спасибо
немного не дорассказали, по-моему:
1. Создать папку admin - где, в любом месте на компе?
2. Потом это надо заархивировать и я получу установочный пакет?
3. Мне компонент нужен под Joomla 2.5. Значит пункт три мне не нужен?

*

neogeek

  • Давно я тут
  • ****
  • 203
  • 18
Попробуйте перейти по адресу вашсайт/administrator/index.php?option=com_joomlaupdate если не работает, то:
Скачайте последнюю версию Joomla 2.5, распакуйте и перезалейте файлы по ftp
потом идем в админку в Расширения -Менеджер расширений - там жмем поиск и устанавливаем нужный нам компонент обновления

*

neogeek

  • Давно я тут
  • ****
  • 203
  • 18
А вообще сначала попробуйте сделать поиск расширений, может он уже есть, надо только установить

*

borro

  • Живу я здесь
  • ******
  • 1272
  • 21
  • желаю вам счастья
Скачайте последнюю версию Joomla 2.5, распакуйте и перезалейте файлы по ftp
потом идем в админку в Расширения -Менеджер расширений - там жмем поиск и устанавливаем нужный нам компонент обновления
не нашел я Joomla updates, следуя Вашим инструкциям. Вот что я делал:
1. Распаковал архив Joomla_2.5.28-Stable-Full_Package и из него все файлы залил с перезаписью на локальный сайт, работающий на XAMPP
2. Удалил инсталяционную папку, поскольку она не давала открыть админку
3. Открыл менеджер расширений и нашел там на вкладке управления расширениями по слову update лишь пару плагинов:
Quick Icon - Joomla! Extensions Updates Notification и Quick Icon - Joomla! Update Notification
Где я ошибся? Понял, надо было на вкладку Discover обратиться

*

neogeek

  • Давно я тут
  • ****
  • 203
  • 18
да надо на вкладку discover
/administrator/index.php?option=com_installer&view=discover

*

neogeek

  • Давно я тут
  • ****
  • 203
  • 18