Проблема с созданными модулями

  • 4 Ответов
  • 297 Просмотров

0 Пользователей и 1 Гость просматривают эту тему.

Здравствуйте уважаемые знатоки! Прошу вашей помощи в следующей проблеме: используя стандартный джумловский шаблон "protostar" пробую создать интернет магазин на лок. сервере. В футере, у него как я понял, всего навсего одна позиция для модулей . Посмотрел видео урок на ютубе, как создавать позиции для модулей. Ту единственную позицию в футере потратил на "верхнее меню". Но ещё необходимо как минимум место для лого с информацией, и место для изображения - т.е всего мне нужны 3 позиции . Так вот, из видео: сначала добавил в файл index.php класс нового модуля (в раздел кода футера), затем в файл templates.css подгоняя под место добавил код display:block;position:absolute;top:2100px; left:30%; ]  и в заключении в templateDetails.xtml добавил название позиции. Создал два недостающих модуля, и вставил информацию и изображение. Обновил - все круто и красиво смотрится, но как только перехожу с главной, на любую другую страницу, эти два модуля сдвигаются далеко вниз, я так понимаю на вот эту позицию display:block;position:absolute;top:2100px; left:30%;. Я искал в коде вариант как можно зафиксировать их вместе с первым футреровским модулем, но так и ничего не нашел, единственный вариант оставлять на главной странице, но и тут, когда изменяешь ширину браузера, эти модули начинают бегать по странице, в то время как оригинальный (футеровский) спокойно адаптируется. Прошу вас пожалуйста помочь!
Ниже скрины с главной страницы, где все ровно, и второй скриншот, где на любой другой странице изображение (созданный модуль) оказывается снизу.
« Последнее редактирование: 15.06.2015, 11:24:03 от mariopirlo »

*

Онлайн vipiusss

  • ********
  • 5448
  • [+]327 / [-]10
  • Skype: renor_
    • Просмотр профиля
Re: Проблема с созданными модулями
« Ответ #1 : 15.06.2015, 11:26:02 »
Может стоить в div обернуть картинку с менюшкой или таблицей хотя бы?И тогда уже CSS задать диву общему.
Миграция, установка, обновление версий Joomla  |  Создание сайтов "под ключ"  |  Эксклюзивные заглушки "offline"  |  Работа с "напильником" над шаблонами и расширениями

Re: Проблема с созданными модулями
« Ответ #2 : 15.06.2015, 11:36:59 »
Может стоить в div обернуть картинку с менюшкой или таблицей хотя бы?И тогда уже CSS задать диву общему.
Если я правильно вас понял, то мне нужно переставить данные

"блоки" в нужное место? Так понимаю в php.ini? Не шибко силен просто в веб.программировании но спасибо, сейчас поищем.

Re: Проблема с созданными модулями
« Ответ #3 : 15.06.2015, 11:51:00 »
в joomle ещё, во вкладе позиция модулей, на созданных модулях надпись на красном "Position: test11 [ Style: none outline]" в то время как на стандартных в квадратных скобках указано [ Style: xhtml outline].
---
хотя нет, это явно не из за этого

---

FireBug показывает что все модули (вкл созданные) находятся в одном месте, правда что с установкой пикселей и процентов отступов, что без них, картинка все равно не хочет встраиваться в блок.
« Последнее редактирование: 15.06.2015, 12:16:37 от mariopirlo »

Re: Проблема с созданными модулями
« Ответ #4 : 15.06.2015, 19:52:49 »
Ещё раз здравствуйте! Все разобрался по первому пункту, позицию нашел) Но появилась другая проблема, позиции для модулей, которые создал  -не адаптивны,  и если по ширине суживать страницу, они накладываются друг на друга (в отличии от всего остального функционала на сайте, которые с покорностью подставляется под размер окна браузера). Скажите пожалуйста, с чем это связано и как исправить данную проблему?